aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-10-20 15:13:58 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-10-20 15:13:58 +0000
commit953ce7353dcac5c87bc5de4a8447d0010ae1251b (patch)
tree0d844e8fa3b150c019b3e1ce3cfdf11bc53dc5a3
parent1f43541dd961cf446e7303ed369aab66c9ad0874 (diff)
downloadports-953ce7353dcac5c87bc5de4a8447d0010ae1251b.tar.gz
ports-953ce7353dcac5c87bc5de4a8447d0010ae1251b.zip
MFH: r371269
patch-parser.c: Replace allready applied patch with new patch from upstream to unbreak the xmlcatalog command. patch-uri.c: Revert uri.c commit that causes the document chain to fail. Reported by: antoine@ Tested by: bapt@ Approved by: portmgr (bapt@)
Notes
Notes: svn path=/branches/2014Q4/; revision=371276
-rw-r--r--textproc/libxml2/Makefile2
-rw-r--r--textproc/libxml2/files/patch-parser.c53
-rw-r--r--textproc/libxml2/files/patch-uri.c25
3 files changed, 49 insertions, 31 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index 8595fb2f2e85..dce9137a172b 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -4,7 +4,7 @@
PORTNAME= libxml2
PORTVERSION= 2.9.2
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= textproc gnome
MASTER_SITES= ftp://xmlsoft.org/libxml2/ \
http://xmlsoft.org/sources/ \
diff --git a/textproc/libxml2/files/patch-parser.c b/textproc/libxml2/files/patch-parser.c
index bcb56d02f8e4..fd7d5a5903d6 100644
--- a/textproc/libxml2/files/patch-parser.c
+++ b/textproc/libxml2/files/patch-parser.c
@@ -1,38 +1,31 @@
-CVE-2014-0191
+From 0e6659ec960734b0b01aad196d4bdb4a3800b493 Mon Sep 17 00:00:00 2001
+From: Lubomir Rintel <lkundrak@v3.sk>
+Date: Thu, 16 Oct 2014 19:10:59 +0200
+Subject: [PATCH] Revert "Missing initialization for the catalog module"
-From 9cd1c3cfbd32655d60572c0a413e017260c854df Mon Sep 17 00:00:00 2001
-From: Daniel Veillard <veillard@redhat.com>
-Date: Tue, 22 Apr 2014 15:30:56 +0800
-Subject: Do not fetch external parameter entities
+It's not correct to always load the default catalog.
+https://bugzilla.redhat.com/show_bug.cgi?id=1153753
-Unless explicitely asked for when validating or replacing entities
-with their value. Problem pointed out by Daniel Berrange <berrange@redhat.com>
+This reverts commit 054c716ea1bf001544127a4ab4f4346d1b9947e7.
+
+---
+ parser.c | 3 ---
+ 1 file changed, 3 deletions(-)
diff --git a/parser.c b/parser.c
-index 9347ac9..c0dea05 100644
+index 1d93967..67c9dfd 100644
--- parser.c
+++ parser.c
-@@ -2598,6 +2598,20 @@ xmlParserHandlePEReference(xmlParserCtxtPtr ctxt) {
- xmlCharEncoding enc;
-
- /*
-+ * Note: external parsed entities will not be loaded, it is
-+ * not required for a non-validating parser, unless the
-+ * option of validating, or substituting entities were
-+ * given. Doing so is far more secure as the parser will
-+ * only process data coming from the document entity by
-+ * default.
-+ */
-+ if ((entity->etype == XML_EXTERNAL_PARAMETER_ENTITY) &&
-+ ((ctxt->options & XML_PARSE_NOENT) == 0) &&
-+ ((ctxt->options & XML_PARSE_DTDVALID) == 0) &&
-+ (ctxt->validate == 0))
-+ return;
-+
-+ /*
- * handle the extra spaces added before and after
- * c.f. http://www.w3.org/TR/REC-xml#as-PE
- * this is done independently.
+@@ -14830,9 +14830,6 @@ xmlInitParser(void) {
+ #ifdef LIBXML_XPATH_ENABLED
+ xmlXPathInit();
+ #endif
+-#ifdef LIBXML_CATALOG_ENABLED
+- xmlInitializeCatalog();
+-#endif
+ xmlParserInitialized = 1;
+ #ifdef LIBXML_THREAD_ENABLED
+ }
--
-cgit v0.10.1
+1.9.3
diff --git a/textproc/libxml2/files/patch-uri.c b/textproc/libxml2/files/patch-uri.c
new file mode 100644
index 000000000000..bad003e8c96a
--- /dev/null
+++ b/textproc/libxml2/files/patch-uri.c
@@ -0,0 +1,25 @@
+Revert the following commit, it makes the freebsd doc chain fail.
+
+From 8eb55d782a2b9afacc7938694891cc6fad7b42a5 Mon Sep 17 00:00:00 2001
+From: Dennis Filder <d.filder@web.de>
+Date: Fri, 13 Jun 2014 14:56:14 +0800
+Subject: xmlSaveUri() incorrectly recomposes URIs with rootless paths
+
+For https://bugzilla.gnome.org/show_bug.cgi?id=731063
+
+xmlSaveUri() of libxml2 (snapshot 2014-05-31 and earlier) returns
+bogus values when called with URIs that have rootless paths
+(e.g. "urx:b:b" becomes "urx://b%3Ab" where "urx:b%3Ab" would be
+correct)
+
+--- uri.c.orig 2014-10-03 13:28:06.000000000 +0200
++++ uri.c 2014-10-20 14:22:57.677231158 +0200
+@@ -1198,6 +1198,8 @@
+ if (temp == NULL) goto mem_error;
+ ret = temp;
+ }
++ ret[len++] = '/';
++ ret[len++] = '/';
+ }
+ if (uri->path != NULL) {
+ p = uri->path;