aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2016-02-02 23:33:56 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2016-02-02 23:33:56 +0000
commit956722682a61331139e387595fb8ed40df5f0651 (patch)
tree31304de3136dea7e12b00331e9fea0c5316c482f
parent2fa62d405051b59bc9c64d35b303b4ccd9a32e6f (diff)
downloadports-956722682a61331139e387595fb8ed40df5f0651.tar.gz
ports-956722682a61331139e387595fb8ed40df5f0651.zip
Notes
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/libqtelegram-ae/Makefile24
-rw-r--r--net-im/libqtelegram-ae/distinfo2
-rw-r--r--net-im/libqtelegram-ae/pkg-descr5
-rw-r--r--net-im/libqtelegram-ae/pkg-plist176
5 files changed, 208 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index c92f6d95aa91..471ddeed88d3 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -62,6 +62,7 @@
SUBDIR += libnice-gst010
SUBDIR += libnice-gst1
SUBDIR += libpurple
+ SUBDIR += libqtelegram-ae
SUBDIR += libstrophe
SUBDIR += libtelepathy
SUBDIR += libyahoo2
diff --git a/net-im/libqtelegram-ae/Makefile b/net-im/libqtelegram-ae/Makefile
new file mode 100644
index 000000000000..79d192fa7cd2
--- /dev/null
+++ b/net-im/libqtelegram-ae/Makefile
@@ -0,0 +1,24 @@
+# Created by: Henry Hu <henry.hu.sh@gmail.com>
+# $FreeBSD$
+
+PORTNAME= libqtelegram-ae
+PORTVERSION= 6.1
+DISTVERSIONPREFIX= v
+DISTVERSIONSUFFIX= -stable
+CATEGORIES= net-im
+
+MAINTAINER= henry.hu.sh@gmail.com
+COMMENT= Fork of libqtelegram by Aseman Team
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= Aseman-Land
+GH_PROJECT= libqtelegram-aseman-edition
+
+USES= qmake:outsource
+USE_QT5= qmake_build buildtools_build core gui network multimedia
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/net-im/libqtelegram-ae/distinfo b/net-im/libqtelegram-ae/distinfo
new file mode 100644
index 000000000000..834b46547478
--- /dev/null
+++ b/net-im/libqtelegram-ae/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Aseman-Land-libqtelegram-aseman-edition-v6.1-stable_GH0.tar.gz) = ffc1f85a7b0cdd16149c89722f33c43de9fa3db15271d0ff26734ba35e0a02c0
+SIZE (Aseman-Land-libqtelegram-aseman-edition-v6.1-stable_GH0.tar.gz) = 202513
diff --git a/net-im/libqtelegram-ae/pkg-descr b/net-im/libqtelegram-ae/pkg-descr
new file mode 100644
index 000000000000..54d6757f546e
--- /dev/null
+++ b/net-im/libqtelegram-ae/pkg-descr
@@ -0,0 +1,5 @@
+libqtelegram-aseman-edition is a fork of libqtelegram by Aseman Team which is
+porting to windows and mac alongside linux support. It's also build using qmake
+instead of cmake.
+
+WWW: https://github.com/Aseman-Land/libqtelegram-aseman-edition
diff --git a/net-im/libqtelegram-ae/pkg-plist b/net-im/libqtelegram-ae/pkg-plist
new file mode 100644
index 000000000000..0ae2fd637c09
--- /dev/null
+++ b/net-im/libqtelegram-ae/pkg-plist
@@ -0,0 +1,176 @@
+include/libqtelegram-ae/core/abstractapi.h
+include/libqtelegram-ae/core/api.h
+include/libqtelegram-ae/core/connection.h
+include/libqtelegram-ae/core/dc.h
+include/libqtelegram-ae/core/dcauth.h
+include/libqtelegram-ae/core/dcprovider.h
+include/libqtelegram-ae/core/endpoint.h
+include/libqtelegram-ae/core/eventtimer.h
+include/libqtelegram-ae/core/inboundpkt.h
+include/libqtelegram-ae/core/outboundpkt.h
+include/libqtelegram-ae/core/query.h
+include/libqtelegram-ae/core/querymethods.h
+include/libqtelegram-ae/core/session.h
+include/libqtelegram-ae/core/sessionmanager.h
+include/libqtelegram-ae/core/settings.h
+include/libqtelegram-ae/file/downloadfile.h
+include/libqtelegram-ae/file/file.h
+include/libqtelegram-ae/file/filehandler.h
+include/libqtelegram-ae/file/fileoperation.h
+include/libqtelegram-ae/file/uploadfileengine.h
+include/libqtelegram-ae/libqtelegram_global.h
+include/libqtelegram-ae/secret/decryptedmessage.h
+include/libqtelegram-ae/secret/decryptedmessageaction.h
+include/libqtelegram-ae/secret/decryptedmessagebuilder.h
+include/libqtelegram-ae/secret/decryptedmessagemedia.h
+include/libqtelegram-ae/secret/decrypter.h
+include/libqtelegram-ae/secret/encrypter.h
+include/libqtelegram-ae/secret/secretchat.h
+include/libqtelegram-ae/secret/secretchatmessage.h
+include/libqtelegram-ae/secret/secretstate.h
+include/libqtelegram-ae/telegram.h
+include/libqtelegram-ae/telegram/coretypes.h
+include/libqtelegram-ae/telegram/functions/account.h
+include/libqtelegram-ae/telegram/functions/auth.h
+include/libqtelegram-ae/telegram/functions/contacts.h
+include/libqtelegram-ae/telegram/functions/functions.h
+include/libqtelegram-ae/telegram/functions/geochats.h
+include/libqtelegram-ae/telegram/functions/help.h
+include/libqtelegram-ae/telegram/functions/messages.h
+include/libqtelegram-ae/telegram/functions/photos.h
+include/libqtelegram-ae/telegram/functions/telegramfunctionobject.h
+include/libqtelegram-ae/telegram/functions/updates.h
+include/libqtelegram-ae/telegram/functions/upload.h
+include/libqtelegram-ae/telegram/functions/users.h
+include/libqtelegram-ae/telegram/types/accountauthorizations.h
+include/libqtelegram-ae/telegram/types/accountdaysttl.h
+include/libqtelegram-ae/telegram/types/accountpassword.h
+include/libqtelegram-ae/telegram/types/accountpasswordinputsettings.h
+include/libqtelegram-ae/telegram/types/accountpasswordsettings.h
+include/libqtelegram-ae/telegram/types/accountprivacyrules.h
+include/libqtelegram-ae/telegram/types/accountsentchangephonecode.h
+include/libqtelegram-ae/telegram/types/audio.h
+include/libqtelegram-ae/telegram/types/authauthorization.h
+include/libqtelegram-ae/telegram/types/authcheckedphone.h
+include/libqtelegram-ae/telegram/types/authexportedauthorization.h
+include/libqtelegram-ae/telegram/types/authorization.h
+include/libqtelegram-ae/telegram/types/authpasswordrecovery.h
+include/libqtelegram-ae/telegram/types/authsentcode.h
+include/libqtelegram-ae/telegram/types/chat.h
+include/libqtelegram-ae/telegram/types/chatfull.h
+include/libqtelegram-ae/telegram/types/chatinvite.h
+include/libqtelegram-ae/telegram/types/chatlocated.h
+include/libqtelegram-ae/telegram/types/chatparticipant.h
+include/libqtelegram-ae/telegram/types/chatparticipants.h
+include/libqtelegram-ae/telegram/types/chatphoto.h
+include/libqtelegram-ae/telegram/types/config.h
+include/libqtelegram-ae/telegram/types/contact.h
+include/libqtelegram-ae/telegram/types/contactblocked.h
+include/libqtelegram-ae/telegram/types/contactfound.h
+include/libqtelegram-ae/telegram/types/contactlink.h
+include/libqtelegram-ae/telegram/types/contactsblocked.h
+include/libqtelegram-ae/telegram/types/contactscontacts.h
+include/libqtelegram-ae/telegram/types/contactsfound.h
+include/libqtelegram-ae/telegram/types/contactsimportedcontacts.h
+include/libqtelegram-ae/telegram/types/contactslink.h
+include/libqtelegram-ae/telegram/types/contactssuggested.h
+include/libqtelegram-ae/telegram/types/contactstatus.h
+include/libqtelegram-ae/telegram/types/contactsuggested.h
+include/libqtelegram-ae/telegram/types/dcoption.h
+include/libqtelegram-ae/telegram/types/dialog.h
+include/libqtelegram-ae/telegram/types/disabledfeature.h
+include/libqtelegram-ae/telegram/types/document.h
+include/libqtelegram-ae/telegram/types/documentattribute.h
+include/libqtelegram-ae/telegram/types/encryptedchat.h
+include/libqtelegram-ae/telegram/types/encryptedfile.h
+include/libqtelegram-ae/telegram/types/encryptedmessage.h
+include/libqtelegram-ae/telegram/types/exportedchatinvite.h
+include/libqtelegram-ae/telegram/types/filelocation.h
+include/libqtelegram-ae/telegram/types/geochatmessage.h
+include/libqtelegram-ae/telegram/types/geochatslocated.h
+include/libqtelegram-ae/telegram/types/geochatsmessages.h
+include/libqtelegram-ae/telegram/types/geochatsstatedmessage.h
+include/libqtelegram-ae/telegram/types/geopoint.h
+include/libqtelegram-ae/telegram/types/helpappupdate.h
+include/libqtelegram-ae/telegram/types/helpinvitetext.h
+include/libqtelegram-ae/telegram/types/helpsupport.h
+include/libqtelegram-ae/telegram/types/importedcontact.h
+include/libqtelegram-ae/telegram/types/inputappevent.h
+include/libqtelegram-ae/telegram/types/inputaudio.h
+include/libqtelegram-ae/telegram/types/inputchatphoto.h
+include/libqtelegram-ae/telegram/types/inputcontact.h
+include/libqtelegram-ae/telegram/types/inputdocument.h
+include/libqtelegram-ae/telegram/types/inputencryptedchat.h
+include/libqtelegram-ae/telegram/types/inputencryptedfile.h
+include/libqtelegram-ae/telegram/types/inputfile.h
+include/libqtelegram-ae/telegram/types/inputfilelocation.h
+include/libqtelegram-ae/telegram/types/inputgeochat.h
+include/libqtelegram-ae/telegram/types/inputgeopoint.h
+include/libqtelegram-ae/telegram/types/inputmedia.h
+include/libqtelegram-ae/telegram/types/inputnotifypeer.h
+include/libqtelegram-ae/telegram/types/inputpeer.h
+include/libqtelegram-ae/telegram/types/inputpeernotifyevents.h
+include/libqtelegram-ae/telegram/types/inputpeernotifysettings.h
+include/libqtelegram-ae/telegram/types/inputphoto.h
+include/libqtelegram-ae/telegram/types/inputphotocrop.h
+include/libqtelegram-ae/telegram/types/inputprivacykey.h
+include/libqtelegram-ae/telegram/types/inputprivacyrule.h
+include/libqtelegram-ae/telegram/types/inputstickerset.h
+include/libqtelegram-ae/telegram/types/inputuser.h
+include/libqtelegram-ae/telegram/types/inputvideo.h
+include/libqtelegram-ae/telegram/types/message.h
+include/libqtelegram-ae/telegram/types/messageaction.h
+include/libqtelegram-ae/telegram/types/messagemedia.h
+include/libqtelegram-ae/telegram/types/messagesaffectedhistory.h
+include/libqtelegram-ae/telegram/types/messagesaffectedmessages.h
+include/libqtelegram-ae/telegram/types/messagesallstickers.h
+include/libqtelegram-ae/telegram/types/messageschatfull.h
+include/libqtelegram-ae/telegram/types/messageschats.h
+include/libqtelegram-ae/telegram/types/messagesdhconfig.h
+include/libqtelegram-ae/telegram/types/messagesdialogs.h
+include/libqtelegram-ae/telegram/types/messagesfilter.h
+include/libqtelegram-ae/telegram/types/messagesmessage.h
+include/libqtelegram-ae/telegram/types/messagesmessages.h
+include/libqtelegram-ae/telegram/types/messagessentencryptedmessage.h
+include/libqtelegram-ae/telegram/types/messagessentmessage.h
+include/libqtelegram-ae/telegram/types/messagesstickers.h
+include/libqtelegram-ae/telegram/types/messagesstickerset.h
+include/libqtelegram-ae/telegram/types/nearestdc.h
+include/libqtelegram-ae/telegram/types/notifypeer.h
+include/libqtelegram-ae/telegram/types/peer.h
+include/libqtelegram-ae/telegram/types/peernotifyevents.h
+include/libqtelegram-ae/telegram/types/peernotifysettings.h
+include/libqtelegram-ae/telegram/types/photo.h
+include/libqtelegram-ae/telegram/types/photosize.h
+include/libqtelegram-ae/telegram/types/photosphoto.h
+include/libqtelegram-ae/telegram/types/photosphotos.h
+include/libqtelegram-ae/telegram/types/privacykey.h
+include/libqtelegram-ae/telegram/types/privacyrule.h
+include/libqtelegram-ae/telegram/types/receivednotifymessage.h
+include/libqtelegram-ae/telegram/types/sendmessageaction.h
+include/libqtelegram-ae/telegram/types/stickerpack.h
+include/libqtelegram-ae/telegram/types/stickerset.h
+include/libqtelegram-ae/telegram/types/storagefiletype.h
+include/libqtelegram-ae/telegram/types/telegramtypeobject.h
+include/libqtelegram-ae/telegram/types/types.h
+include/libqtelegram-ae/telegram/types/update.h
+include/libqtelegram-ae/telegram/types/updatesdifference.h
+include/libqtelegram-ae/telegram/types/updatesstate.h
+include/libqtelegram-ae/telegram/types/updatestype.h
+include/libqtelegram-ae/telegram/types/uploadfile.h
+include/libqtelegram-ae/telegram/types/user.h
+include/libqtelegram-ae/telegram/types/userfull.h
+include/libqtelegram-ae/telegram/types/userprofilephoto.h
+include/libqtelegram-ae/telegram/types/userstatus.h
+include/libqtelegram-ae/telegram/types/video.h
+include/libqtelegram-ae/telegram/types/wallpaper.h
+include/libqtelegram-ae/telegram/types/webpage.h
+include/libqtelegram-ae/util/asserter.h
+include/libqtelegram-ae/util/constants.h
+include/libqtelegram-ae/util/cryptoutils.h
+include/libqtelegram-ae/util/tlvalues.h
+include/libqtelegram-ae/util/utils.h
+lib/libqtelegram-ae.so
+lib/libqtelegram-ae.so.1
+lib/libqtelegram-ae.so.1.0
+lib/libqtelegram-ae.so.1.0.0