aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-06-29 21:45:03 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-06-29 21:45:03 +0000
commit97a5771bb57263f738dd256d0c2e8451b07b7413 (patch)
tree49d8c3a8d5b446073221330cde97594ee1c14c24
parentf85956c3f5d7f4282f94c67a194a292c2d181df9 (diff)
downloadports-97a5771bb57263f738dd256d0c2e8451b07b7413.tar.gz
ports-97a5771bb57263f738dd256d0c2e8451b07b7413.zip
Notes
-rw-r--r--astro/wmglobe/Makefile2
-rw-r--r--misc/wmweather+/Makefile2
-rw-r--r--x11-wm/libwraster/Makefile10
-rw-r--r--x11-wm/libwraster/pkg-plist4
-rw-r--r--x11-wm/windowmaker/Makefile22
-rw-r--r--x11-wm/windowmaker/pkg-plist6
-rw-r--r--x11-wm/wmakerconf/Makefile2
-rw-r--r--x11/wdm/Makefile2
8 files changed, 23 insertions, 27 deletions
diff --git a/astro/wmglobe/Makefile b/astro/wmglobe/Makefile
index 84bf34e6b062..f19c2d2ad19b 100644
--- a/astro/wmglobe/Makefile
+++ b/astro/wmglobe/Makefile
@@ -3,7 +3,7 @@
PORTNAME= wmglobe
PORTVERSION= 1.3
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= astro windowmaker geography
MASTER_SITES= http://hamete.org/static/wmg/
diff --git a/misc/wmweather+/Makefile b/misc/wmweather+/Makefile
index 091e78b7128e..f3ba8699b5a9 100644
--- a/misc/wmweather+/Makefile
+++ b/misc/wmweather+/Makefile
@@ -3,7 +3,7 @@
PORTNAME= wmweather+
PORTVERSION= 2.15
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc windowmaker geography
MASTER_SITES= SF/wmweatherplus/wmweather%2B/ \
SF/nemysisfreebsdp/misc/:icons
diff --git a/x11-wm/libwraster/Makefile b/x11-wm/libwraster/Makefile
index 34b1c6393d72..0e3ff592801a 100644
--- a/x11-wm/libwraster/Makefile
+++ b/x11-wm/libwraster/Makefile
@@ -2,7 +2,7 @@
PORTNAME= libwraster
PORTVERSION= 0.95.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-wm windowmaker
MASTER_SITES= http://windowmaker.org/pub/%SUBDIR%/
MASTER_SITE_SUBDIR= source/release
@@ -18,12 +18,12 @@ LIB_DEPENDS= libgif.so:${PORTSDIR}/graphics/giflib \
libjbig.so:${PORTSDIR}/graphics/jbigkit \
libtiff.so:${PORTSDIR}/graphics/tiff
-USES= pathfix pkgconfig
-USE_AUTOTOOLS= libtool
+USES= libtool pathfix pkgconfig
USE_LDCONFIG= yes
USE_XORG= xft xinerama xmu xpm
BUILD_WRKSRC= ${WRKSRC}/wrlib
INSTALL_WRKSRC= ${WRKSRC}/wrlib
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-pixmapdir=${PREFIX}/include/X11/pixmaps \
--with-nlsdir=${PREFIX}/share/locale \
--with-libs-from="-L${LOCALBASE}/lib" \
@@ -32,11 +32,11 @@ CONFIGURE_ARGS= --with-pixmapdir=${PREFIX}/include/X11/pixmaps \
--enable-modelock \
--enable-xinerama --enable-usermenu \
--with-x
-CPPFLAGS+= -DPREFIX=\\\"${PREFIX}\\\" -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
pre-build:
- cd ${WRKSRC} && ${MAKE} config-paths.h
+ cd ${WRKSRC} && ${MAKE_CMD} config-paths.h
post-install:
cd ${WRKSRC}/doc && ${INSTALL_MAN} \
diff --git a/x11-wm/libwraster/pkg-plist b/x11-wm/libwraster/pkg-plist
index fac5afcd6ef4..34f08cc7f974 100644
--- a/x11-wm/libwraster/pkg-plist
+++ b/x11-wm/libwraster/pkg-plist
@@ -1,8 +1,8 @@
bin/get-wraster-flags
include/wraster.h
lib/libwraster.a
-lib/libwraster.la
lib/libwraster.so
-lib/libwraster.so.4
+lib/libwraster.so.3
+lib/libwraster.so.3.1.1
libdata/pkgconfig/wrlib.pc
man/man1/get-wraster-flags.1.gz
diff --git a/x11-wm/windowmaker/Makefile b/x11-wm/windowmaker/Makefile
index c6602d4f8b77..42cc461e551e 100644
--- a/x11-wm/windowmaker/Makefile
+++ b/x11-wm/windowmaker/Makefile
@@ -3,7 +3,7 @@
PORTNAME= windowmaker
PORTVERSION= 0.95.5
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11-wm windowmaker
MASTER_SITES= http://windowmaker.org/pub/%SUBDIR%/
MASTER_SITE_SUBDIR= source/release
@@ -22,10 +22,10 @@ LIB_DEPENDS= libgif.so:${PORTSDIR}/graphics/giflib \
RUN_DEPENDS= libwraster>=${PORTVERSION}:${PORTSDIR}/x11-wm/libwraster \
${LOCALBASE}/share/WindowMaker/Themes/LeetWM.themed/style:${PORTSDIR}/graphics/wmicons
-USES= pathfix perl5 pkgconfig
-USE_AUTOTOOLS= libtool
+USES= libtool pathfix perl5 pkgconfig
USE_LDCONFIG= yes
USE_XORG= xft xinerama xmu xpm
+GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_header_sys_inotify_h=no
CONFIGURE_ARGS= --with-pixmapdir=${PREFIX}/include/X11/pixmaps \
--with-nlsdir=${PREFIX}/share/locale \
@@ -35,7 +35,7 @@ CONFIGURE_ARGS= --with-pixmapdir=${PREFIX}/include/X11/pixmaps \
--enable-modelock \
--enable-xinerama --enable-usermenu \
--with-x
-CPPFLAGS+= -DPREFIX=\\\"${PREFIX}\\\" -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
PORTDOCS= AUTHORS BUGFORM BUGS ChangeLog FAQ FAQ.I18N INSTALL \
INSTALL-WMAKER NEWS README README.definable-cursor TODO
@@ -50,14 +50,10 @@ NLS_CONFIGURE_ENABLE= locale
XRANDR_USE= XORG=xrandr
XRANDR_CONFIGURE_ENABLE= xrandr
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == amd64 && ${OSVERSION} < 800000
-CONFIGURE_ENV+= ac_cv_c_inline_asm=no
-.endif
-.if ${OSVERSION} < 800000
-CPPFLAGS+= -DHAVE_SYS_SELECT_H
-.endif
+post-patch:
+ @${REINPLACE_CMD} 's,PREFIX,"${PREFIX}",' \
+ ${WRKSRC}/WINGs/wapplication.c ${WRKSRC}/WPrefs.app/Menu.c \
+ ${WRKSRC}/WPrefs.app/Paths.c ${WRKSRC}/util/wmgenmenu.c
post-install:
@${MKDIR} \
@@ -66,4 +62,4 @@ post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-wm/windowmaker/pkg-plist b/x11-wm/windowmaker/pkg-plist
index bab074f7646d..59ab75ec97ee 100644
--- a/x11-wm/windowmaker/pkg-plist
+++ b/x11-wm/windowmaker/pkg-plist
@@ -103,17 +103,17 @@ include/WINGs/WINGsP.h
include/WINGs/WUtil.h
include/WMaker.h
lib/libWINGs.a
-lib/libWINGs.la
lib/libWINGs.so
lib/libWINGs.so.2
+lib/libWINGs.so.2.0.1
lib/libWMaker.a
-lib/libWMaker.la
lib/libWMaker.so
lib/libWMaker.so.1
+lib/libWMaker.so.1.0.1
lib/libWUtil.a
-lib/libWUtil.la
lib/libWUtil.so
lib/libWUtil.so.3
+lib/libWUtil.so.3.0.0
libdata/pkgconfig/WINGs.pc
share/WINGs/Images.tiff
share/WINGs/Images.xpm
diff --git a/x11-wm/wmakerconf/Makefile b/x11-wm/wmakerconf/Makefile
index b79f93b8ece4..9bbc62f6c765 100644
--- a/x11-wm/wmakerconf/Makefile
+++ b/x11-wm/wmakerconf/Makefile
@@ -4,7 +4,7 @@
PORTNAME= wmakerconf
PORTVERSION= 2.12
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= x11-wm
MASTER_SITES= SF
DISTNAME= ${PORTNAME}_${PORTVERSION}
diff --git a/x11/wdm/Makefile b/x11/wdm/Makefile
index efce86645c25..8fb2e04ef544 100644
--- a/x11/wdm/Makefile
+++ b/x11/wdm/Makefile
@@ -3,7 +3,7 @@
PORTNAME= wdm
PORTVERSION= 1.28
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= x11 windowmaker
MASTER_SITES= http://voins.program.ru/wdm/:wdm \
http://wolfram.schneider.org/bsd/gif/bsd/:pic_large \