aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2016-11-02 18:24:12 +0000
committerSteve Wills <swills@FreeBSD.org>2016-11-02 18:24:12 +0000
commit97e3c7a495a19af1ff2fdcb09f941c4ecf048c92 (patch)
tree677ddb4f91b07c2995f685948ba3c7a85dfcd73d
parent758c7b407920252ae95b5a045a487ae2cc620ccc (diff)
downloadports-97e3c7a495a19af1ff2fdcb09f941c4ecf048c92.tar.gz
ports-97e3c7a495a19af1ff2fdcb09f941c4ecf048c92.zip
Notes
-rw-r--r--Mk/bsd.ruby.mk7
1 files changed, 0 insertions, 7 deletions
diff --git a/Mk/bsd.ruby.mk b/Mk/bsd.ruby.mk
index 021cc327e690..feea3c398b3f 100644
--- a/Mk/bsd.ruby.mk
+++ b/Mk/bsd.ruby.mk
@@ -31,7 +31,6 @@ Ruby_Include_MAINTAINER= ruby@FreeBSD.org
# USE_RUBY - Says that the port uses ruby for building and running.
# RUBY_NO_BUILD_DEPENDS - Says that the port should not build-depend on ruby.
# RUBY_NO_RUN_DEPENDS - Says that the port should not run-depend on ruby.
-# USE_LIBRUBY - Says that the port uses libruby.
# USE_RUBY_EXTCONF - Says that the port uses extconf.rb to configure.
# Implies USE_RUBY.
# RUBY_EXTCONF - Set to the alternative name of extconf.rb
@@ -95,7 +94,6 @@ Ruby_Include_MAINTAINER= ruby@FreeBSD.org
# RUBY_PORT - Port path of ruby without PORTSDIR.
# RUBY_RDOC_PORT - Port path of rdoc without PORTSDIR.
#
-# DEPEND_LIBRUBY - LIB_DEPENDS entry for libruby.
# DEPEND_RUBY - BUILD_DEPENDS/RUN_DEPENDS entry for ruby.
# DEPEND_RUBY_RDOC - BUILD_DEPENDS entry for rdoc.
#
@@ -272,7 +270,6 @@ RUBY_BASE_PORT?= lang/ruby${RUBY_VER:S/.//}
RUBY_PORT?= ${RUBY_BASE_PORT}
# Depends
-DEPEND_LIBRUBY?= lib${RUBY_NAME}.so.${RUBY_SHLIBVER}:${RUBY_PORT}
DEPEND_RUBY?= ${RUBY}:${RUBY_PORT}
# Directories
@@ -394,10 +391,6 @@ ruby-setup-install:
${SETENV} ${MAKE_ENV} ${RUBY} ${RUBY_FLAGS} ${RUBY_SETUP} install --prefix=${STAGEDIR}
.endif
-.if defined(USE_LIBRUBY)
-LIB_DEPENDS+= ${DEPEND_LIBRUBY}
-.endif
-
.if defined(USE_RUBY)
.if !defined(RUBY_NO_BUILD_DEPENDS)
EXTRACT_DEPENDS+= ${DEPEND_RUBY}