aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2021-02-22 04:35:03 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2021-02-22 04:35:03 +0000
commit98d1ae4d292eaf7aa6fd5bd820c9082b227347d3 (patch)
tree764aec59774dad451b42495fe72796507cc5e1b6
parent5e45aac75d65d04290c7bbadc935121903971b9c (diff)
downloadports-98d1ae4d292eaf7aa6fd5bd820c9082b227347d3.tar.gz
ports-98d1ae4d292eaf7aa6fd5bd820c9082b227347d3.zip
- Unbreak with patches.
- Bump portrevision.
Notes
Notes: svn path=/head/; revision=566263
-rw-r--r--math/octave-forge-level-set/Makefile4
-rw-r--r--math/octave-forge-level-set/files/patch-FastMarching.cpp4
-rw-r--r--math/octave-forge-level-set/files/patch-geomGamma.cpp11
-rw-r--r--math/octave-forge-level-set/files/patch-internal__fastmarching.cpp20
-rw-r--r--math/octave-forge-level-set/files/patch-internal__mesh.cpp20
5 files changed, 54 insertions, 5 deletions
diff --git a/math/octave-forge-level-set/Makefile b/math/octave-forge-level-set/Makefile
index c03f4984f67c..09570a1dc374 100644
--- a/math/octave-forge-level-set/Makefile
+++ b/math/octave-forge-level-set/Makefile
@@ -3,7 +3,7 @@
PORTNAME= octave-forge-level-set
PORTVERSION= 0.3.0
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= math
MAINTAINER= stephen@FreeBSD.org
@@ -15,8 +15,6 @@ ALL_TARGET= oct
USES= compiler:c++0x
GNU_CONFIGURE= yes
-BROKEN= does not build with octave-6.2.0
-
# OCTSRC is the name of the directory of the package.
# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
OCTSRC= ${OCTAVE_PKGNAME}
diff --git a/math/octave-forge-level-set/files/patch-FastMarching.cpp b/math/octave-forge-level-set/files/patch-FastMarching.cpp
index cc177c28b612..ea513e11b594 100644
--- a/math/octave-forge-level-set/files/patch-FastMarching.cpp
+++ b/math/octave-forge-level-set/files/patch-FastMarching.cpp
@@ -1,5 +1,5 @@
---- FastMarching.cpp-orig 2015-02-20 03:51:59.000000000 +0000
-+++ FastMarching.cpp 2015-02-20 03:52:16.000000000 +0000
+--- FastMarching.cpp.orig 2015-12-17 12:32:55 UTC
++++ FastMarching.cpp
@@ -22,6 +22,7 @@
#include <cmath>
#include <memory>
diff --git a/math/octave-forge-level-set/files/patch-geomGamma.cpp b/math/octave-forge-level-set/files/patch-geomGamma.cpp
new file mode 100644
index 000000000000..4885bcecea42
--- /dev/null
+++ b/math/octave-forge-level-set/files/patch-geomGamma.cpp
@@ -0,0 +1,11 @@
+--- geomGamma.cpp.orig 2021-02-22 04:26:32 UTC
++++ geomGamma.cpp
+@@ -192,7 +192,7 @@ DEFUN_DLD (__levelset_geomGamma, args, nargout,
+ const Matrix inout = args(4).matrix_value ();
+
+ /* Extract and check the dimensions. */
+- const unsigned nNodes = phi.nelem ();
++ const unsigned nNodes = phi.numel ();
+ const unsigned nElem = getDimension (nodelist, -1, 4);
+ const unsigned nBdryEl = getDimension (bdryInd, -1, 1);
+ getDimension (edges, nBdryEl, 4);
diff --git a/math/octave-forge-level-set/files/patch-internal__fastmarching.cpp b/math/octave-forge-level-set/files/patch-internal__fastmarching.cpp
new file mode 100644
index 000000000000..abdc32dfe237
--- /dev/null
+++ b/math/octave-forge-level-set/files/patch-internal__fastmarching.cpp
@@ -0,0 +1,20 @@
+--- internal_fastmarching.cpp.orig 2021-02-22 04:24:09 UTC
++++ internal_fastmarching.cpp
+@@ -74,7 +74,7 @@ DEFUN_DLD (__levelset_internal_fastmarching, args, nar
+ {
+ const Array<octave_idx_type> idx = getOctaveIdx (c);
+ assert (c.size () == D
+- && static_cast<dimensionT> (idx.length ()) == D);
++ && static_cast<dimensionT> (idx.numel ()) == D);
+
+ if (domain(idx))
+ {
+@@ -99,7 +99,7 @@ DEFUN_DLD (__levelset_internal_fastmarching, args, nar
+ {
+ const Array<octave_idx_type> idx = getOctaveIdx (c);
+ assert (c.size () == D
+- && static_cast<dimensionT> (idx.length ()) == D);
++ && static_cast<dimensionT> (idx.numel ()) == D);
+
+ const Grid& constGrid(grid);
+ const Entry* e = constGrid.get (c);
diff --git a/math/octave-forge-level-set/files/patch-internal__mesh.cpp b/math/octave-forge-level-set/files/patch-internal__mesh.cpp
new file mode 100644
index 000000000000..0a01f2db50f4
--- /dev/null
+++ b/math/octave-forge-level-set/files/patch-internal__mesh.cpp
@@ -0,0 +1,20 @@
+--- internal_mesh.cpp.orig 2021-02-22 04:30:13 UTC
++++ internal_mesh.cpp
+@@ -300,7 +300,7 @@ getInnerSegment (const octave_scalar_map& segs,
+
+ assert (innerPts.empty ());
+ const ColumnVector inners = segs.contents ("inners").column_vector_value ();
+- const unsigned nInners = inners.nelem ();
++ const unsigned nInners = inners.numel ();
+ for (unsigned i = 0; i < nInners; ++i)
+ innerPts.push_back (inners(nInners - i - 1) - 1);
+ }
+@@ -387,7 +387,7 @@ DEFUN_DLD (__levelset_internal_mesh, args, nargout,
+ {
+ const unsigned cur = bdryElems(i) - 1;
+ const Cell cellSegs = bdryelSegs(i).cell_value ();
+- const unsigned nSegs = cellSegs.nelem ();
++ const unsigned nSegs = cellSegs.numel ();
+
+ std::vector<octave_scalar_map> segs;
+ indexArr endEdges;