aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-27 22:21:34 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-27 22:21:34 +0000
commit99606f0b7a7996b759ed34658c619f1f473f1c4e (patch)
tree896d68c550d3737320eecb1a19d6fcf46bda9576
parent2fe28174438d5eff68f6d1aa4be6f5ef81556944 (diff)
downloadports-99606f0b7a7996b759ed34658c619f1f473f1c4e.tar.gz
ports-99606f0b7a7996b759ed34658c619f1f473f1c4e.zip
Notes
-rw-r--r--security/Makefile1
-rw-r--r--security/fakeroot/Makefile24
-rw-r--r--security/fakeroot/distinfo2
-rw-r--r--security/fakeroot/files/patch-communicate.h12
-rw-r--r--security/fakeroot/files/patch-doc.Makefile18
-rw-r--r--security/fakeroot/files/patch-fakeroot12
-rw-r--r--security/fakeroot/files/patch-libfakeroot.c10
-rw-r--r--security/fakeroot/pkg-descr11
-rw-r--r--security/fakeroot/pkg-plist6
9 files changed, 96 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 1404dbe15348..044173186385 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -76,6 +76,7 @@
SUBDIR += f-prot-sig
SUBDIR += fakebo
SUBDIR += fakeident
+ SUBDIR += fakeroot
SUBDIR += find-zlib
SUBDIR += find_ddos
SUBDIR += finger_mysql
diff --git a/security/fakeroot/Makefile b/security/fakeroot/Makefile
new file mode 100644
index 000000000000..cf9981bcf6b2
--- /dev/null
+++ b/security/fakeroot/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: fakeroot
+# Date created: 11 March 2004
+# Whom: Meno Abels <meno.abels@adviser.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fakeroot
+PORTVERSION= 0.9.6
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_DEBIAN}
+MASTER_SITE_SUBDIR= pool/main/f/fakeroot
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= Meno.Abels@Adviser.com
+COMMENT= Simulate the root user behaviour
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+MAN1= faked.1 fakeroot.1
+
+.include <bsd.port.mk>
diff --git a/security/fakeroot/distinfo b/security/fakeroot/distinfo
new file mode 100644
index 000000000000..8fa5c13c2fae
--- /dev/null
+++ b/security/fakeroot/distinfo
@@ -0,0 +1,2 @@
+MD5 (fakeroot_0.9.6.tar.gz) = 7e54cb1ac258908ca5eecf244bd1d680
+SIZE (fakeroot_0.9.6.tar.gz) = 851101
diff --git a/security/fakeroot/files/patch-communicate.h b/security/fakeroot/files/patch-communicate.h
new file mode 100644
index 000000000000..efacb33bc0f6
--- /dev/null
+++ b/security/fakeroot/files/patch-communicate.h
@@ -0,0 +1,12 @@
+--- communicate.h Fri Sep 26 04:07:11 2003
++++ communicate.h Thu Mar 11 12:51:34 2004
+@@ -38,7 +38,9 @@
+ #if defined(sun) || __GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 1)
+ #define STAT64_SUPPORT
+ #else
++#if !defined(__FreeBSD__)
+ #warning Not using stat64 support
++#endif
+ /* if glibc is 2.0 or older, undefine these again */
+ #undef STAT64_SUPPORT
+ #undef _LARGEFILE64_SOURCE
diff --git a/security/fakeroot/files/patch-doc.Makefile b/security/fakeroot/files/patch-doc.Makefile
new file mode 100644
index 000000000000..0a57835e359d
--- /dev/null
+++ b/security/fakeroot/files/patch-doc.Makefile
@@ -0,0 +1,18 @@
+--- doc/Makefile.am Tue Sep 2 06:00:59 2003
++++ doc/Makefile.am Thu Mar 11 13:23:43 2004
+@@ -1,5 +1,4 @@
+ AUTOMAKE_OPTIONS=foreign
+-SUBDIRS = es fr sv
+
+ man_MANS = faked.1 fakeroot.1
+
+--- doc/Makefile.in Sun Feb 22 23:18:19 2004
++++ doc/Makefile.in Thu Mar 11 13:23:47 2004
+@@ -161,7 +161,6 @@
+ target_os = @target_os@
+ target_vendor = @target_vendor@
+ AUTOMAKE_OPTIONS = foreign
+-SUBDIRS = es fr sv
+ man_MANS = faked.1 fakeroot.1
+
+ #another automake bug workaround
diff --git a/security/fakeroot/files/patch-fakeroot b/security/fakeroot/files/patch-fakeroot
new file mode 100644
index 000000000000..3f305273d19a
--- /dev/null
+++ b/security/fakeroot/files/patch-fakeroot
@@ -0,0 +1,12 @@
+--- ../fakeroot-0.8.5/scripts/fakeroot Wed Nov 12 17:07:18 2003
++++ scripts/fakeroot Thu Mar 11 13:40:00 2004
+@@ -16,7 +16,7 @@
+ PREFIX=`dirname ${BINDIR}`
+
+ LIB=libfakeroot.so.0
+-PATHS=${PREFIX}/lib/libfakeroot:${PREFIX}/lib64/libfakeroot
++PATHS=${PREFIX}/lib
+ FAKED=${BINDIR}/faked
+
+ FAKED_MODE="unknown-is-root"
+
diff --git a/security/fakeroot/files/patch-libfakeroot.c b/security/fakeroot/files/patch-libfakeroot.c
new file mode 100644
index 000000000000..dcbbb69c14b9
--- /dev/null
+++ b/security/fakeroot/files/patch-libfakeroot.c
@@ -0,0 +1,10 @@
+--- libfakeroot.c Fri Dec 19 03:38:05 2003
++++ libfakeroot.c Thu Mar 11 12:52:45 2004
+@@ -667,6 +667,6 @@
+ return 0;
+ }
+
+-int setgroups(size_t size, const gid_t *list){
++int setgroups(int size, const gid_t *list){
+ return 0;
+ }
diff --git a/security/fakeroot/pkg-descr b/security/fakeroot/pkg-descr
new file mode 100644
index 000000000000..a1112fcc229b
--- /dev/null
+++ b/security/fakeroot/pkg-descr
@@ -0,0 +1,11 @@
+Fakeroot runs a command in an environment were it appears to have
+root privileges for file manipulation, by setting LD_PRELOAD to a
+library with alternative versions of getuid(), stat(), etc. This
+is useful for allowing users to create archives (tar, ar, .deb .rpm
+etc.) with files in them with root permissions/ownership. Without
+fakeroot one would have to have root privileges to create the
+constituent files of the archives with the correct permissions and
+ownership, and then pack them up, or one would have to construct
+the archives directly, without using the archiver.
+
+WWW: http://freshmeat.net/projects/fakeroot
diff --git a/security/fakeroot/pkg-plist b/security/fakeroot/pkg-plist
new file mode 100644
index 000000000000..8bc7c630b3ed
--- /dev/null
+++ b/security/fakeroot/pkg-plist
@@ -0,0 +1,6 @@
+bin/faked
+bin/fakeroot
+lib/libfakeroot.la
+lib/libfakeroot.so.0
+lib/libfakeroot.so
+lib/libfakeroot.a