aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-12-01 07:29:13 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-12-01 07:29:13 +0000
commit9ab200b78cb47b89d0df75ed7a816d6e2c785692 (patch)
tree9f02e9da92c968e5f07d68e02b4e2c51ce2de913
parentdfd1887dbe46464ce3ff71879ba5cf073b48e0b6 (diff)
downloadports-9ab200b78cb47b89d0df75ed7a816d6e2c785692.tar.gz
ports-9ab200b78cb47b89d0df75ed7a816d6e2c785692.zip
Correct run dependencies by using ':=' assign
Fix build with NOPORTEXAMPLES Remove md5 checksum Approved by: Rob Farmer (maintainer)
Notes
Notes: svn path=/head/; revision=265501
-rw-r--r--math/jlatexmath/Makefile9
-rw-r--r--math/jlatexmath/distinfo1
2 files changed, 5 insertions, 5 deletions
diff --git a/math/jlatexmath/Makefile b/math/jlatexmath/Makefile
index 4867dc09dccb..e8d95146972b 100644
--- a/math/jlatexmath/Makefile
+++ b/math/jlatexmath/Makefile
@@ -7,6 +7,7 @@
PORTNAME= jlatexmath
PORTVERSION= 0.9.3
+PORTREVISION= 1
CATEGORIES= math java
MASTER_SITES= http://forge.scilab.org/upload/jlatexmath/files/ \
http://www.predatorlabs.net/dl/
@@ -31,15 +32,15 @@ OPTIONS= FOP "textproc/fop plugin (required for math/scilab)" ON
.if defined(WITHOUT_FOP)
PLIST_SUB+= FOP="@comment "
.else
-BUILD_DEPENDS+= fop:${PORTSDIR}/textproc/fop \
+BUILD_DEPENDS= fop:${PORTSDIR}/textproc/fop \
${JAVALIBDIR}/xmlgraphics-commons.jar:${PORTSDIR}/graphics/xmlgraphics-commons \
- ${LOCALBASE}/share/java/batik/batik.jar:${PORTSDIR}/graphics/batik \
+ ${JAVASHAREDIR}/batik/batik.jar:${PORTSDIR}/graphics/batik \
${JAVALIBDIR}/avalon-framework.jar:${PORTSDIR}/devel/avalon-framework \
${JAVALIBDIR}/commons-io.jar:${PORTSDIR}/devel/jakarta-commons-io \
${JAVALIBDIR}/commons-logging.jar:${PORTSDIR}/java/jakarta-commons-logging \
${JAVALIBDIR}/xml-apis-ext.jar:${PORTSDIR}/textproc/xml-commons
-RUN_DEPENDS+= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
ALL_TARGET+= fop
@@ -54,7 +55,7 @@ post-patch:
do-install:
${INSTALL_DATA} ${WRKSRC}/dist/jlatexmath-${PORTVERSION}.jar ${JAVAJARDIR}/jlatexmath.jar
${INSTALL_DATA} ${WRKSRC}/dist/jlatexmath-fop-${PORTVERSION}.jar ${JAVAJARDIR}/jlatexmath-fop.jar
-.if !defined(NOPORTDOCS)
+.if !defined(NOPORTEXAMPLES)
(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
.endif
diff --git a/math/jlatexmath/distinfo b/math/jlatexmath/distinfo
index 6611e260e55e..7b027d9bb86c 100644
--- a/math/jlatexmath/distinfo
+++ b/math/jlatexmath/distinfo
@@ -1,3 +1,2 @@
-MD5 (jlatexmath-src-all-0.9.3.zip) = 14b5a3ae9941c1fbf39f241a779b7458
SHA256 (jlatexmath-src-all-0.9.3.zip) = 88b54226800d0811e1e927730b991557f80429d952da70ef220b2a9251c4998b
SIZE (jlatexmath-src-all-0.9.3.zip) = 1092337