aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2020-11-12 03:03:26 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2020-11-12 03:03:26 +0000
commit9b5ea5eb179eb2371755c4ad333b3c17342cbb3d (patch)
tree44bd1f8e7eacbe02f1dd54dd62034f4fff7fbbc3
parent2d5d9d2cd3294b1fbc6eac299e6386392861f15c (diff)
downloadports-9b5ea5eb179eb2371755c4ad333b3c17342cbb3d.tar.gz
ports-9b5ea5eb179eb2371755c4ad333b3c17342cbb3d.zip
Notes
-rw-r--r--x11/xnee/Makefile24
1 files changed, 16 insertions, 8 deletions
diff --git a/x11/xnee/Makefile b/x11/xnee/Makefile
index 697e2185bce1..7ee504883d1e 100644
--- a/x11/xnee/Makefile
+++ b/x11/xnee/Makefile
@@ -7,20 +7,14 @@ PORTREVISION= 2
CATEGORIES= x11
MASTER_SITES= GNU
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= zab@zltech.eu
COMMENT= X11 events recorder and player
LICENSE= GPLv3
-# Fix build with -fno-common (llvm 11)
-CFLAGS+= -fcommon
-
-DEPRECATED= Unmaintained and dead upstream, does not build with -fno-common (llvm 11)
-EXPIRATION_DATE=2021-04-01
-
GNU_CONFIGURE= yes
USES= gmake pathfix xorg
-USE_XORG= xtst
+USE_XORG= x11 xtst
CONFIGURE_ARGS= --enable-cli --disable-doc --disable-xinput2
@@ -54,8 +48,22 @@ post-patch:
s|$$(libgnomeui_LIBS)||g' ${WRKSRC}/gnee/src/Makefile.in
@${REINPLACE_CMD} -e \
's|src test|src|g' ${WRKSRC}/libxnee/Makefile.in
+ @${REINPLACE_CMD} -E 's,} (${_ENUM_NAMES:ts|}),},' \
+ ${WRKSRC}/libxnee/include/libxnee/xnee.h \
+ ${WRKSRC}/libxnee/include/libxnee/xnee_grab.h \
+ ${WRKSRC}/libxnee/include/libxnee/xnee_internal.h \
+ ${WRKSRC}/libxnee/include/libxnee/xnee_window.h
+ @${REINPLACE_CMD} -e \
+ 's|^xnee_option_t|extern &|' ${WRKSRC}/cnee/src/cnee_demo.c
post-install:
${INSTALL_DATA} ${WRKSRC}/doc/xnee.info ${STAGEDIR}${PREFIX}/${INFO_PATH}
+# We must trim the names from enums below to build with -fno-common
+_ENUM_NAMES= _bool_string_values _cont_proc_commands _return_values \
+ _xnee_grab_modes _xnee_protocol_data_numbers \
+ _xnee_replay_backend _xnee_resolution_states \
+ xnee_data_types xnee_grab_modifiers_control xnee_mode \
+ xnee_option_type xnee_override_display xnee_window_types
+
.include <bsd.port.mk>