aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-09-26 14:30:06 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-09-26 14:30:06 +0000
commit9b74482bde2bc380b1b003838b43cc7727012a28 (patch)
treeff13a68712fa0dfe681223d6ce1b22c6340aff07
parentad04e16bfd5a8704332f60b46a2e9f4bcd288256 (diff)
downloadports-9b74482bde2bc380b1b003838b43cc7727012a28.tar.gz
ports-9b74482bde2bc380b1b003838b43cc7727012a28.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-WWW-WebArchive/Makefile33
-rw-r--r--www/p5-WWW-WebArchive/distinfo3
-rw-r--r--www/p5-WWW-WebArchive/p5-WWW-WebArchive-0.50.tbzbin0 -> 15089 bytes
-rw-r--r--www/p5-WWW-WebArchive/pkg-descr14
-rw-r--r--www/p5-WWW-WebArchive/pkg-plist9
6 files changed, 60 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 55a13dc7805d..2bdbead8e58a 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -816,6 +816,7 @@
SUBDIR += p5-WWW-SourceForge
SUBDIR += p5-WWW-TWSMS
SUBDIR += p5-WWW-VenusEnvy
+ SUBDIR += p5-WWW-WebArchive
SUBDIR += p5-WWW-Wikipedia
SUBDIR += p5-WebService-Basecamp
SUBDIR += p5-WebService-Bloglines
diff --git a/www/p5-WWW-WebArchive/Makefile b/www/p5-WWW-WebArchive/Makefile
new file mode 100644
index 000000000000..953af177d450
--- /dev/null
+++ b/www/p5-WWW-WebArchive/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-WWW-WebArchive
+# Date created: 2006-08-20
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-WebArchive
+PORTVERSION= 0.50
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WWW
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Retrieve old versions of public web pages from various web archives
+
+RUN_DEPENDS= ${SITE_PERL}/App/Options.pm:${PORTSDIR}/devel/p5-App-Options \
+ ${SITE_PERL}/App/Trace.pm:${PORTSDIR}/devel/p5-App-Trace \
+ ${SITE_PERL}/WWW/Mechanize.pm:${PORTSDIR}/www/p5-WWW-Mechanize
+
+PERL_CONFIGURE= yes
+
+MAN3= WWW::WebArchive.3 WWW::WebArchive::Agent.3 \
+ WWW::WebArchive::WaybackMachine.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601 # Inherited from www/p5-WWW-Mechanize
+IGNORE= requires Perl 5.6.1 or newer. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-WWW-WebArchive/distinfo b/www/p5-WWW-WebArchive/distinfo
new file mode 100644
index 000000000000..b76ec6c51968
--- /dev/null
+++ b/www/p5-WWW-WebArchive/distinfo
@@ -0,0 +1,3 @@
+MD5 (WWW-WebArchive-0.50.tar.gz) = 4698844c414a4d4dced403bbe4ff5f6c
+SHA256 (WWW-WebArchive-0.50.tar.gz) = f6db17f395e4a52c94d7cf6dea75628b5fee28fc6d5e2b7ded16a4805936355e
+SIZE (WWW-WebArchive-0.50.tar.gz) = 6147
diff --git a/www/p5-WWW-WebArchive/p5-WWW-WebArchive-0.50.tbz b/www/p5-WWW-WebArchive/p5-WWW-WebArchive-0.50.tbz
new file mode 100644
index 000000000000..eb1f150922e5
--- /dev/null
+++ b/www/p5-WWW-WebArchive/p5-WWW-WebArchive-0.50.tbz
Binary files differ
diff --git a/www/p5-WWW-WebArchive/pkg-descr b/www/p5-WWW-WebArchive/pkg-descr
new file mode 100644
index 000000000000..9a0b6c60fc81
--- /dev/null
+++ b/www/p5-WWW-WebArchive/pkg-descr
@@ -0,0 +1,14 @@
+WWW-WebArchive is a set of modules to retrieve old versions of public
+web pages from various web archives.
+
+ * http://www.archive.org - Internet Archive's Wayback Machine
+ * http://www.google.com - Google's page cache
+
+This is useful if
+
+ 1. Your web server crashed and you didn't have complete backups
+ 2. A site (such as a valuable reference source) changed or went away
+ and you want to restore an old version of the site to your local
+ disk
+
+WWW: http://search.cpan.org/dist/WWW-WebArchive/
diff --git a/www/p5-WWW-WebArchive/pkg-plist b/www/p5-WWW-WebArchive/pkg-plist
new file mode 100644
index 000000000000..575cef1d8691
--- /dev/null
+++ b/www/p5-WWW-WebArchive/pkg-plist
@@ -0,0 +1,9 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW-WebArchive/.packlist
+%%SITE_PERL%%/WWW/WebArchive.pm
+%%SITE_PERL%%/WWW/WebArchive/Agent.pm
+%%SITE_PERL%%/WWW/WebArchive/WaybackMachine.pm
+bin/webarchive
+@dirrmtry %%SITE_PERL%%/WWW/WebArchive
+@dirrmtry %%SITE_PERL%%/WWW
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW-WebArchive