aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-10-28 05:59:04 +0000
committerWill Andrews <will@FreeBSD.org>2000-10-28 05:59:04 +0000
commit9c52298bb96bbebe44e36f3cf4fd05fed66bc9ce (patch)
tree325a03b336f525a77760f5fd78f45ba5bacec757
parenta5f0c654a9ec9ea63b4c2e0e81dd87f2795ac820 (diff)
downloadports-9c52298bb96bbebe44e36f3cf4fd05fed66bc9ce.tar.gz
ports-9c52298bb96bbebe44e36f3cf4fd05fed66bc9ce.zip
Add p5-Audio-CD 0.04, a perl interface to libcdaudio.
PR: 22215 Submitted by: Roman Shterenzon <roman@xpert.com>
Notes
Notes: svn path=/head/; revision=34339
-rw-r--r--audio/Makefile1
-rw-r--r--audio/p5-Audio-CD/Makefile28
-rw-r--r--audio/p5-Audio-CD/distinfo1
-rw-r--r--audio/p5-Audio-CD/files/patch-aa12
-rw-r--r--audio/p5-Audio-CD/pkg-comment1
-rw-r--r--audio/p5-Audio-CD/pkg-descr13
-rw-r--r--audio/p5-Audio-CD/pkg-plist7
7 files changed, 63 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 28506cf28fb4..75cb771ecac5 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -100,6 +100,7 @@
SUBDIR += nspmod
SUBDIR += openal
SUBDIR += opennap
+ SUBDIR += p5-Audio-CD
SUBDIR += p5-MP3-ID3v1Tag
SUBDIR += p5-MP3-Info
SUBDIR += pimp3
diff --git a/audio/p5-Audio-CD/Makefile b/audio/p5-Audio-CD/Makefile
new file mode 100644
index 000000000000..22a4ba85fa0b
--- /dev/null
+++ b/audio/p5-Audio-CD/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Audio-CD
+# Date created: 22 Oct 2000
+# Whom: Roman Shterenzon <roman@xpert.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Audio-CD
+PORTVERSION= 0.04
+CATEGORIES= audio perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Audio
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= roman@xpert.com
+
+LIB_DEPENDS= cdaudio.1:${PORTSDIR}/audio/libcdaudio
+
+USE_PERL5= YES
+
+MAN3= Audio::CD.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+do-configure:
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ CC="${CC}" CCFLAGS="${CFLAGS}"
+
+.include <bsd.port.mk>
diff --git a/audio/p5-Audio-CD/distinfo b/audio/p5-Audio-CD/distinfo
new file mode 100644
index 000000000000..d7f996375b74
--- /dev/null
+++ b/audio/p5-Audio-CD/distinfo
@@ -0,0 +1 @@
+MD5 (Audio-CD-0.04.tar.gz) = 5b3051fd01a36c557a54e83ac0bde567
diff --git a/audio/p5-Audio-CD/files/patch-aa b/audio/p5-Audio-CD/files/patch-aa
new file mode 100644
index 000000000000..a809565deae2
--- /dev/null
+++ b/audio/p5-Audio-CD/files/patch-aa
@@ -0,0 +1,12 @@
+--- Makefile.PL.orig Wed May 17 08:12:52 2000
++++ Makefile.PL Sun Oct 22 17:41:36 2000
+@@ -7,7 +7,8 @@
+ 'macro' => {
+ CVSROOT => 'modperl.com:/local/cvs_repository',
+ },
+- 'LIBS' => ["-lcdaudio"],
++ 'INC' => "-I$ENV{'PREFIX'}/include",
++ 'LIBS' => "-L$ENV{'PREFIX'}/lib -lcdaudio",
+ DEFINE => '-g',
+ OBJECT => 'cddb_lookup.o CD.o',
+ );
diff --git a/audio/p5-Audio-CD/pkg-comment b/audio/p5-Audio-CD/pkg-comment
new file mode 100644
index 000000000000..122c91e841d4
--- /dev/null
+++ b/audio/p5-Audio-CD/pkg-comment
@@ -0,0 +1 @@
+Perl interface to libcdaudio (cd + cddb)
diff --git a/audio/p5-Audio-CD/pkg-descr b/audio/p5-Audio-CD/pkg-descr
new file mode 100644
index 000000000000..a21746b41522
--- /dev/null
+++ b/audio/p5-Audio-CD/pkg-descr
@@ -0,0 +1,13 @@
+Perl interface to libcdaudio (cd + cddb): http://cdcd.undergrid.net/
+
+This module was created for adding CDDB support to <Xmms::shell> and
+cd tray <eject>. I added methods for a good chunk of other
+<libcdaudio> functions while I was at it, but the docs and glue is
+not complete. I do not have interest in completing the interface and
+docs, because xmms/Xmms::shell provides everything I need (at the
+moment) for audio. If you have an interesting reason for needing the
+missing pieces, I'll probably be interested in adding them.
+
+WWW: http://www.perl.com/CPAN/authors/id/R/RC/RCAPUTO/
+
+Roman Shterenzon <roman@xpert.com>
diff --git a/audio/p5-Audio-CD/pkg-plist b/audio/p5-Audio-CD/pkg-plist
new file mode 100644
index 000000000000..c8f74cab5ebd
--- /dev/null
+++ b/audio/p5-Audio-CD/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Audio/CD.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Audio/CD/CD.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Audio/CD/CD.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Audio/CD/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Audio/CD
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Audio 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Audio 2>/dev/null || true