aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2021-10-02 14:52:35 +0000
committerDimitry Andric <dim@FreeBSD.org>2021-10-03 10:13:35 +0000
commit9ce64e91907aaa43fc43a7b2faaae5bf99faaa56 (patch)
tree27c8798006f3b909ed4b1ccecebc9333d9345664
parent6587d3a4d2ecb023ce2625ac948f19b2cf080ba3 (diff)
downloadports-9ce64e91907aaa43fc43a7b2faaae5bf99faaa56.tar.gz
ports-9ce64e91907aaa43fc43a7b2faaae5bf99faaa56.zip
-rw-r--r--lang/erlang-runtime21/Makefile7
-rw-r--r--lang/erlang-runtime23/Makefile7
-rw-r--r--lang/erlang/Makefile7
3 files changed, 18 insertions, 3 deletions
diff --git a/lang/erlang-runtime21/Makefile b/lang/erlang-runtime21/Makefile
index ab3a649924b3..1ea27a8c3200 100644
--- a/lang/erlang-runtime21/Makefile
+++ b/lang/erlang-runtime21/Makefile
@@ -15,7 +15,7 @@ LICENSE= APACHE20
BROKEN_sparc64= Fails to build: error: fp_except undeclared
-USES= autoreconf:build cpe gmake ncurses perl5
+USES= compiler autoreconf:build cpe gmake ncurses perl5
USE_GITHUB= nodefault
GH_ACCOUNT= erlang:otp,corba
GH_PROJECT= otp:otp corba:corba
@@ -95,6 +95,11 @@ WX_VARS= USE_GL="gl glu" \
.include <bsd.port.pre.mk>
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 130
+# PR 258494
+CONFIGURE_ARGS+= --disable-pgo
+.endif
+
.if ${OPSYS} == FreeBSD
CFLAGS+= -DMAP_NORESERVE=0
.endif
diff --git a/lang/erlang-runtime23/Makefile b/lang/erlang-runtime23/Makefile
index 4a585d177c6e..5bff1294db73 100644
--- a/lang/erlang-runtime23/Makefile
+++ b/lang/erlang-runtime23/Makefile
@@ -15,7 +15,7 @@ LICENSE= APACHE20
BROKEN_sparc64= Fails to build: error: fp_except undeclared
-USES= autoreconf:build cpe gmake ncurses perl5
+USES= autoreconf:build compiler cpe gmake ncurses perl5
USE_GITHUB= nodefault
GH_ACCOUNT= erlang:otp,corba
GH_PROJECT= otp:otp corba:corba
@@ -94,6 +94,11 @@ WX_VARS= USE_GL="gl glu" \
.include <bsd.port.pre.mk>
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 130
+# PR 258494
+CONFIGURE_ARGS+= --disable-pgo
+.endif
+
.if ${OPSYS} == FreeBSD
CFLAGS+= -DMAP_NORESERVE=0
.endif
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index 867c69b8c4c0..baa0bf975b30 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -15,7 +15,7 @@ LICENSE= APACHE20
BROKEN_sparc64= Fails to build: error: fp_except undeclared
-USES= cpe gmake ncurses perl5
+USES= compiler cpe gmake ncurses perl5
CPE_VENDOR= erlang
CPE_PRODUCT= erlang/otp
USE_GITHUB= nodefault
@@ -106,6 +106,11 @@ WX_VARS= USE_GL="gl glu" \
.include <bsd.port.pre.mk>
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 130
+# PR 258494
+CONFIGURE_ARGS+= --disable-pgo
+.endif
+
.if ${OPSYS} == FreeBSD
CFLAGS+= -DMAP_NORESERVE=0
.endif