aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2018-05-22 05:15:28 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2018-05-22 05:15:28 +0000
commit9d44f7f4d0f93fc581a0fce2b7edb6070ffb993d (patch)
treedc7d0beab4d3a5c00773969f6bc6edf29ed9210f
parent68ec769804ab433b84a48ef4a510587a0a3178a0 (diff)
downloadports-9d44f7f4d0f93fc581a0fce2b7edb6070ffb993d.tar.gz
ports-9d44f7f4d0f93fc581a0fce2b7edb6070ffb993d.zip
Notes
-rw-r--r--textproc/py-rst2html5/Makefile12
-rw-r--r--textproc/py-rst2html5/files/patch-setup.py19
2 files changed, 26 insertions, 5 deletions
diff --git a/textproc/py-rst2html5/Makefile b/textproc/py-rst2html5/Makefile
index ebf44634c814..31ce45735e25 100644
--- a/textproc/py-rst2html5/Makefile
+++ b/textproc/py-rst2html5/Makefile
@@ -11,13 +11,15 @@ MAINTAINER= python@FreeBSD.org
COMMENT= Produces HTML5 documents from reStructuredText sources
LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Genshi>=0.7:textproc/py-genshi@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pygments>=2.1:textproc/py-pygments@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}docutils>=0.12:textproc/py-docutils@${FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Genshi>=0.7:textproc/py-genshi@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pygments>=2.0.2:textproc/py-pygments@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}docutils>=0.12:textproc/py-docutils@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils concurrent autoplist
-USES= python:2.7
-USE_PYTHON= distutils autoplist
NO_ARCH= yes
.include <bsd.port.mk>
diff --git a/textproc/py-rst2html5/files/patch-setup.py b/textproc/py-rst2html5/files/patch-setup.py
new file mode 100644
index 000000000000..ebab3e266e6c
--- /dev/null
+++ b/textproc/py-rst2html5/files/patch-setup.py
@@ -0,0 +1,19 @@
+# Conflicts with docutils >-= 0.13.1
+# 1d6174076454 doesn't actually resolve the (file) conflict
+# https://bitbucket.org/andre_felipe_dias/rst2html5/issues/27/
+# https://github.com/getnikola/nikola/issues/2657
+# https://github.com/marianoguerra/rst2html5/issues/87
+
+--- setup.py.orig 2018-05-22 02:47:00 UTC
++++ setup.py
+@@ -51,8 +51,8 @@ setup(
+ include_package_data=True,
+ entry_points={
+ 'console_scripts': [
+- 'rst2html5 = rst2html5_:main',
+- 'rst2html5.py = rst2html5_:main', # overrides docutils' rst2html5.py
++ 'rst2html5-rst2html5 = rst2html5_:main',
++ 'rst2html5-rst2html5.py = rst2html5_:main', # overrides docutils' rst2html5.py
+ ],
+ },
+ )