aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-08-14 08:56:57 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-08-14 08:56:57 +0000
commit9e4075b7bedc928622f6ee4ee6b430441dd758dc (patch)
tree9f7ff2fac7e69edcde77b37324dcde0b1322ed8e
parent10726afe783e38bb9f8a450c53f11dbb0d4ad000 (diff)
downloadports-9e4075b7bedc928622f6ee4ee6b430441dd758dc.tar.gz
ports-9e4075b7bedc928622f6ee4ee6b430441dd758dc.zip
Notes
-rw-r--r--mail/spamprobe/Makefile3
-rw-r--r--mail/spamprobe/files/patch-src_includes_LRUCache.h11
2 files changed, 12 insertions, 2 deletions
diff --git a/mail/spamprobe/Makefile b/mail/spamprobe/Makefile
index 8e125234b90a..4f7d118c6e21 100644
--- a/mail/spamprobe/Makefile
+++ b/mail/spamprobe/Makefile
@@ -3,7 +3,7 @@
PORTNAME= spamprobe
PORTVERSION= 1.4d
-PORTREVISION= 18
+PORTREVISION= 19
CATEGORIES= mail
MASTER_SITES= SF
@@ -12,7 +12,6 @@ COMMENT= Spam detector using Bayesian analysis of word counts
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-default-8bit
-USE_GCC= any
PLIST_FILES= bin/spamprobe man/man1/spamprobe.1.gz
diff --git a/mail/spamprobe/files/patch-src_includes_LRUCache.h b/mail/spamprobe/files/patch-src_includes_LRUCache.h
new file mode 100644
index 000000000000..2b489bd9d609
--- /dev/null
+++ b/mail/spamprobe/files/patch-src_includes_LRUCache.h
@@ -0,0 +1,11 @@
+--- src/includes/LRUCache.h.orig 2018-08-14 08:00:27 UTC
++++ src/includes/LRUCache.h
+@@ -60,7 +60,7 @@ template<class KeyType, class ValueType> class LRUCach
+ {
+ public:
+ bool operator()(const NodeType *a,
+- const NodeType *b)
++ const NodeType *b) const
+ {
+ return a->key < b->key;
+ }