aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce M Simpson <bms@FreeBSD.org>2003-09-29 00:06:37 +0000
committerBruce M Simpson <bms@FreeBSD.org>2003-09-29 00:06:37 +0000
commit9e6dd4e54a28c497674e1069af554a4b65d05400 (patch)
tree3e0f3d36a7cee828bc573ae0aa99853717bf23d2
parent9c94da82a8e41ea42a2e574616b867d8850eb4b5 (diff)
downloadports-9e6dd4e54a28c497674e1069af554a4b65d05400.tar.gz
ports-9e6dd4e54a28c497674e1069af554a4b65d05400.zip
Notes
-rw-r--r--security/Makefile1
-rw-r--r--security/sectok/Makefile27
-rw-r--r--security/sectok/distinfo1
-rw-r--r--security/sectok/files/patch-Makefile41
-rw-r--r--security/sectok/files/patch-cyberflex.c17
-rw-r--r--security/sectok/pkg-descr8
-rw-r--r--security/sectok/pkg-plist1
7 files changed, 96 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 87d95e6197c7..fdcc1e0f2984 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -333,6 +333,7 @@
SUBDIR += scanssh
SUBDIR += seahorse
SUBDIR += secpanel
+ SUBDIR += sectok
SUBDIR += sfs
SUBDIR += sha
SUBDIR += sig2dot
diff --git a/security/sectok/Makefile b/security/sectok/Makefile
new file mode 100644
index 000000000000..3699c67aa12d
--- /dev/null
+++ b/security/sectok/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: sectok
+# Date created: 28 September 2003
+# Whom: Bruce M. Simpson <bms@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sectok
+PORTVERSION= 20030825
+CATEGORIES= security
+MASTER_SITES= http://www.citi.umich.edu/projects/smartcard/
+DISTNAME= sectok-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= bms@FreeBSD.org
+COMMENT= ISO 7816 Smartcard Utility
+
+LIB_DEPENDS= libsectok.3:${PORTSDIR}/security/libsectok
+
+USE_OPENSSL= yes
+
+INSTALLS_SHLIB= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+MAN1= sectok.1
+
+.include <bsd.port.mk>
diff --git a/security/sectok/distinfo b/security/sectok/distinfo
new file mode 100644
index 000000000000..2d6cd85b3991
--- /dev/null
+++ b/security/sectok/distinfo
@@ -0,0 +1 @@
+MD5 (sectok-20030825.tgz) = f9e25112036e6fe1a3ac24626bc12535
diff --git a/security/sectok/files/patch-Makefile b/security/sectok/files/patch-Makefile
new file mode 100644
index 000000000000..b1867f2e4a06
--- /dev/null
+++ b/security/sectok/files/patch-Makefile
@@ -0,0 +1,41 @@
+--- Makefile.orig Thu Jan 3 21:16:01 2002
++++ Makefile Mon Sep 29 01:00:21 2003
+@@ -1,13 +1,19 @@
+ # Standard installation:
+-INCLUDES=
+-LIBS= -lsectok -lcrypto
++#INCLUDES=
++#LIBS= -lsectok -lcrypto
++
++# FreeBSD
++#PREFIX?= ${PREFIX}
++#LOCALBASE?= ${LOCALBASE}
++INCLUDES= -I$(LOCALBASE)/include
++LIBS= -L$(LOCALBASE)/lib -lsectok -lcrypto
+
+ # For building locally (libsectok not installed)
+ #INCLUDES= -I../libsectok
+ #LIBS= ../libsectok/libsectok.a -lcrypto
+
+ # If crypto is included with openssl you might need this
+-#INCLUDES= -I/usr/include/openssl
++INCLUDES+= -I${OPENSSLINC}
+
+ # You shouldn't have to change anything below this line
+
+@@ -17,7 +23,6 @@
+ CC= gcc
+ CFLAGS= -g -Wall
+ INSTALL= install
+-PREFIX= /usr/local
+ RELEASE= sectok-`date "+%Y%m%d"`
+
+ all : $(TARGETS)
+@@ -30,6 +35,7 @@
+
+ install :
+ $(INSTALL) $(TARGETS) $(PREFIX)/bin
++ $(INSTALL) sectok.1 $(PREFIX)/man/man1
+
+ release :
+ rm -rf $(RELEASE)
diff --git a/security/sectok/files/patch-cyberflex.c b/security/sectok/files/patch-cyberflex.c
new file mode 100644
index 000000000000..f5889c1ed600
--- /dev/null
+++ b/security/sectok/files/patch-cyberflex.c
@@ -0,0 +1,17 @@
+--- cyberflex.c.orig Thu Jun 19 23:37:35 2003
++++ cyberflex.c Mon Sep 29 00:58:56 2003
+@@ -48,7 +48,13 @@
+ #define SHA1Init SHA1_Init
+ #define SHA1Update SHA1_Update
+ #define SHA1Final SHA1_Final
+-#else /* __linux */
++#elif defined(__FreeBSD__)
++#define SHA1_CTX SHA_CTX
++#define SHA1Init SHA1_Init
++#define SHA1Update SHA1_Update
++#define SHA1Final SHA1_Final
++#include <sha.h>
++#else
+ #include <sha1.h>
+ #endif
+ #else
diff --git a/security/sectok/pkg-descr b/security/sectok/pkg-descr
new file mode 100644
index 000000000000..bd82d99e3bc2
--- /dev/null
+++ b/security/sectok/pkg-descr
@@ -0,0 +1,8 @@
+This is the sectok tool from citi.umich.edu. Originally targeted
+for OpenBSD. This is a quick port of the basic application; it relies
+upon the libsectok library for ISO 7816 Smart Card device communication.
+
+WWW: http://www.citi.umich.edu/projects/smartcard/sectok.html
+
+Bruce
+bms@FreeBSD.org
diff --git a/security/sectok/pkg-plist b/security/sectok/pkg-plist
new file mode 100644
index 000000000000..a41f114dae6b
--- /dev/null
+++ b/security/sectok/pkg-plist
@@ -0,0 +1 @@
+bin/sectok