aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Gallamore <ultima@FreeBSD.org>2022-01-09 22:58:13 +0000
committerRichard Gallamore <ultima@FreeBSD.org>2022-01-09 23:09:24 +0000
commit9f1b1be53d965ca9eedef7a6547eb47973c8dae0 (patch)
tree4eb833c71d297628b21ac9f2f0723c8f1c53aee0
parent09c92fbf7d0964d87e98dca4310bc53eadbd9eca (diff)
*: Updated guacamole-[server|client] to 1.4.0
Major rework to guacamole-client. As of 1.4.0, guacamole-client requires npm to build. Instead of building guacamole-client, changed the port to simply downloading the precompiled binaries. Since the precompiled binaries don't completely adhere to heir, added symlink to appropriate location
-rw-r--r--net/guacamole-server/Makefile3
-rw-r--r--net/guacamole-server/distinfo6
-rw-r--r--net/guacamole-server/pkg-plist4
-rw-r--r--www/guacamole-client/Makefile51
-rw-r--r--www/guacamole-client/distinfo24
-rw-r--r--www/guacamole-client/files/pkg-message.in2
-rw-r--r--www/guacamole-client/pkg-plist6
7 files changed, 49 insertions, 47 deletions
diff --git a/net/guacamole-server/Makefile b/net/guacamole-server/Makefile
index 249b38397dd6..8f171b0e0068 100644
--- a/net/guacamole-server/Makefile
+++ b/net/guacamole-server/Makefile
@@ -1,8 +1,7 @@
# Created by: Richard Gallamore <ultima@FreeBSD.org>
PORTNAME= guacamole-server
-DISTVERSION= 1.3.0
-PORTREVISION= 1
+DISTVERSION= 1.4.0
CATEGORIES= net
MAINTAINER= ultima@FreeBSD.org
diff --git a/net/guacamole-server/distinfo b/net/guacamole-server/distinfo
index 40bb4aaf721e..c7238ad68f93 100644
--- a/net/guacamole-server/distinfo
+++ b/net/guacamole-server/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1611226900
-SHA256 (apache-guacamole-server-1.3.0_GH0.tar.gz) = 1a544d12b45d35c7c197e6729bece05136aaad4541f976fbb0cfaa41de57ef93
-SIZE (apache-guacamole-server-1.3.0_GH0.tar.gz) = 532339
+TIMESTAMP = 1641668633
+SHA256 (apache-guacamole-server-1.4.0_GH0.tar.gz) = 4646b7850828aa8f35d69308656479b3a4855cafbe6673ae575c0e282d298846
+SIZE (apache-guacamole-server-1.4.0_GH0.tar.gz) = 550354
diff --git a/net/guacamole-server/pkg-plist b/net/guacamole-server/pkg-plist
index 4665b80878d4..1db6fc48bb75 100644
--- a/net/guacamole-server/pkg-plist
+++ b/net/guacamole-server/pkg-plist
@@ -65,8 +65,8 @@ include/guacamole/wol.h
%%VNC%%lib/libguac-client-vnc.so.0.0.0
lib/libguac.a
lib/libguac.so
-lib/libguac.so.19
-lib/libguac.so.19.0.0
+lib/libguac.so.20
+lib/libguac.so.20.0.0
%%GUACENC%%man/man1/guacenc.1.gz
%%GUACLOG%%man/man1/guaclog.1.gz
man/man5/guacd.conf.5.gz
diff --git a/www/guacamole-client/Makefile b/www/guacamole-client/Makefile
index f2f3e37edee1..b1212909d287 100644
--- a/www/guacamole-client/Makefile
+++ b/www/guacamole-client/Makefile
@@ -1,31 +1,28 @@
# Created by: Richard Gallamore <ultima@FreeBSD.org>
PORTNAME= guacamole-client
-DISTVERSION= 1.3.0
+DISTVERSION= 1.4.0
CATEGORIES= www java
-MASTER_SITES+= https://sourceforge.net/projects/distfiles/files/${PORTNAME}/:repo \
- http://sourceforge.net/projects/distfiles/files/${PORTNAME}/:repo
-DISTFILES= repository-${DISTVERSION}${EXTRACT_SUFX}:repo
+MASTER_SITES= ${MASTER_SITE_APACHE}
+MASTER_SITE_SUBDIR= guacamole/${DISTVERSIONFULL}/binary
+DISTFILES= guacamole-${DISTVERSIONFULL}.war \
+ guacamole-auth-duo-${DISTVERSIONFULL}${EXTRACT_SUFX} \
+ guacamole-auth-header-${DISTVERSIONFULL}${EXTRACT_SUFX} \
+ guacamole-auth-jdbc-${DISTVERSIONFULL}${EXTRACT_SUFX} \
+ guacamole-auth-json-${DISTVERSIONFULL}${EXTRACT_SUFX} \
+ guacamole-auth-ldap-${DISTVERSIONFULL}${EXTRACT_SUFX} \
+ guacamole-auth-quickconnect-${DISTVERSIONFULL}${EXTRACT_SUFX} \
+ guacamole-auth-sso-${DISTVERSIONFULL}${EXTRACT_SUFX} \
+ guacamole-auth-totp-${DISTVERSIONFULL}${EXTRACT_SUFX}
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= ultima@FreeBSD.org
COMMENT= HTML5 Clientless Remote Desktop
LICENSE= APACHE20
-LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${LOCALBASE}/share/java/maven33/bin/mvn:devel/maven33
-
-USES= tar:xz
-USE_JAVA= yes
-JAVA_VERSION= 1.8+
-
-USE_GITHUB= yes
-GH_ACCOUNT= apache
-
-MVN= mvn
-MVN_ARGS= package -Duser.home=${WRKDIR}
NO_ARCH= yes
+NO_BUILD= yes
SUB_FILES= pkg-message
@@ -42,31 +39,23 @@ TOMCAT_VARS= TOMCAT_VER=9.0
SERVER_RUN_DEPENDS= guacd:net/guacamole-server
-AUTH_EXTENSION= cas duo header ldap openid quickconnect saml totp
-
-post-patch:
- @${REINPLACE_CMD} 's|/etc/guacamole|${ETCDIR}| ; \
- s|"/etc"|"${ETCDIR:S|/${PORTNAME}||}"|' \
- ${WRKSRC}/guacamole-ext/src/main/java/org/apache/guacamole/environment/LocalEnvironment.java
-
-do-build:
- cd ${WRKSRC} && ${MVN} ${MVN_ARGS}
+do-extract:
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
@${MKDIR} ${STAGEDIR}${ETCDIR}
+ @${MKDIR} ${STAGEDIR}/etc
- ${INSTALL_DATA} ${WRKSRC}/guacamole/target/guacamole-${DISTVERSIONFULL}.war \
+ ${INSTALL_DATA} ${_DISTDIR}/${DISTFILES:M*.war} \
${STAGEDIR}${DATADIR}/guacamole.war
-.for i in ${AUTH_EXTENSION}
- ${INSTALL_DATA} ${WRKSRC}/extensions/guacamole-auth-$i/target/guacamole-auth-$i-*.tar.gz \
- ${STAGEDIR}/${DATADIR}/guacamole-auth-$i.tar.gz
+.for i in ${DISTFILES:N*.war}
+ ${INSTALL_DATA} ${_DISTDIR}/${i}${DISTVERSIONFULL}${EXTRACT_SUFX} \
+ ${STAGEDIR}/${DATADIR}/${i:S|-$||}${EXTRACT_SUFX}
.endfor
- ${INSTALL_DATA} ${WRKSRC}/extensions/guacamole-auth-jdbc/modules/guacamole-auth-jdbc-dist/target/guacamole-auth-jdbc-${DISTVERSIONFULL}.tar.gz \
- ${STAGEDIR}/${DATADIR}/guacamole-auth-jdbc.tar.gz
${INSTALL_DATA} ${FILESDIR}/user-mapping.xml.sample ${STAGEDIR}${ETCDIR}/
${INSTALL_DATA} ${FILESDIR}/logback.xml.sample ${STAGEDIR}${ETCDIR}/
${INSTALL_DATA} ${FILESDIR}/guacamole.properties.sample ${STAGEDIR}${ETCDIR}/
+ ${RLN} ${STAGEDIR}${ETCDIR} ${STAGEDIR}/etc/guacamole
do-install-TOMCAT-on:
@${MKDIR} ${STAGEDIR}${PREFIX}/apache-tomcat-${TOMCAT_VER}/webapps
diff --git a/www/guacamole-client/distinfo b/www/guacamole-client/distinfo
index 05aefd49b7de..936efd124509 100644
--- a/www/guacamole-client/distinfo
+++ b/www/guacamole-client/distinfo
@@ -1,5 +1,19 @@
-TIMESTAMP = 1611111000
-SHA256 (guacamole-client/repository-1.3.0.tar.xz) = 26d844f88991b65e1f6bc4f5632082a5149b3232fbfd609d3521e436cb2aaacc
-SIZE (guacamole-client/repository-1.3.0.tar.xz) = 67415228
-SHA256 (guacamole-client/apache-guacamole-client-1.3.0_GH0.tar.gz) = b1b37588ebb28846e1a8a289b3478445b753fc49aa978eacba906e129965e705
-SIZE (guacamole-client/apache-guacamole-client-1.3.0_GH0.tar.gz) = 6153515
+TIMESTAMP = 1641761453
+SHA256 (guacamole-client/guacamole-1.4.0.war) = 92fb06e3ce8fe4f932ddfdffd75a352c06ab58d3bd0a946faa5beda73e8592f0
+SIZE (guacamole-client/guacamole-1.4.0.war) = 13011205
+SHA256 (guacamole-client/guacamole-auth-duo-1.4.0.tar.gz) = 62917e25cb9b6c7e08c5e13da43308469fa58ab317cd7e1f9e140ec94e4a2fda
+SIZE (guacamole-client/guacamole-auth-duo-1.4.0.tar.gz) = 3596849
+SHA256 (guacamole-client/guacamole-auth-header-1.4.0.tar.gz) = 3f5491737b3295056949d235120dca60ee9518c951b09271780dddf15166a9de
+SIZE (guacamole-client/guacamole-auth-header-1.4.0.tar.gz) = 3566935
+SHA256 (guacamole-client/guacamole-auth-jdbc-1.4.0.tar.gz) = 47f4f121cad74ab64d5baf3d14e8f709677a26b3058005a977277a07716d4d9c
+SIZE (guacamole-client/guacamole-auth-jdbc-1.4.0.tar.gz) = 16486378
+SHA256 (guacamole-client/guacamole-auth-json-1.4.0.tar.gz) = 7398f04ae1630c93249edb4f0f267ca43b3ba66722f23d13e05acf7d79a80468
+SIZE (guacamole-client/guacamole-auth-json-1.4.0.tar.gz) = 11511282
+SHA256 (guacamole-client/guacamole-auth-ldap-1.4.0.tar.gz) = f28488717b26168a5396e125ec7fbff1b7268a658c6100f6ad1bbfbd18a17779
+SIZE (guacamole-client/guacamole-auth-ldap-1.4.0.tar.gz) = 9575832
+SHA256 (guacamole-client/guacamole-auth-quickconnect-1.4.0.tar.gz) = 5c4f6c5d581b7420bf658d16be585a9ef4499c3dabac14ac4289b73640665117
+SIZE (guacamole-client/guacamole-auth-quickconnect-1.4.0.tar.gz) = 3584581
+SHA256 (guacamole-client/guacamole-auth-sso-1.4.0.tar.gz) = 55ef6adac3beb753361b67eadda1c789ce3ffc70fe74794e9ddef70d8e6b8b8c
+SIZE (guacamole-client/guacamole-auth-sso-1.4.0.tar.gz) = 22414937
+SHA256 (guacamole-client/guacamole-auth-totp-1.4.0.tar.gz) = 4c4c5390eecb68d1df07e15fa25829e51a079d4a83887c5e417ac8d7419e787b
+SIZE (guacamole-client/guacamole-auth-totp-1.4.0.tar.gz) = 4769666
diff --git a/www/guacamole-client/files/pkg-message.in b/www/guacamole-client/files/pkg-message.in
index da50a7500211..ea724c5735c3 100644
--- a/www/guacamole-client/files/pkg-message.in
+++ b/www/guacamole-client/files/pkg-message.in
@@ -6,7 +6,7 @@ For a quick Guacamole setup and test:
cp %%ETCDIR%%/user-mapping.xml.sample \
%%ETCDIR%%/user-mapping.xml
- Once tomcat8 and guacd are running
+ Once tomcat and guacd are running
http://localhost:8080/guacamole
For upgrading guacamole, this is a reminder to upgrade
diff --git a/www/guacamole-client/pkg-plist b/www/guacamole-client/pkg-plist
index 71e64f4b006e..e8bc0fac9404 100644
--- a/www/guacamole-client/pkg-plist
+++ b/www/guacamole-client/pkg-plist
@@ -1,14 +1,14 @@
+/etc/guacamole
%%TOMCAT%%apache-tomcat-%%TOMCAT_VER%%/webapps/guacamole.war
%%ETCDIR%%/guacamole.properties.sample
%%ETCDIR%%/logback.xml.sample
%%ETCDIR%%/user-mapping.xml.sample
%%DATADIR%%/guacamole-auth-duo.tar.gz
-%%DATADIR%%/guacamole-auth-cas.tar.gz
%%DATADIR%%/guacamole-auth-header.tar.gz
%%DATADIR%%/guacamole-auth-jdbc.tar.gz
+%%DATADIR%%/guacamole-auth-json.tar.gz
%%DATADIR%%/guacamole-auth-ldap.tar.gz
-%%DATADIR%%/guacamole-auth-openid.tar.gz
%%DATADIR%%/guacamole-auth-quickconnect.tar.gz
-%%DATADIR%%/guacamole-auth-saml.tar.gz
+%%DATADIR%%/guacamole-auth-sso.tar.gz
%%DATADIR%%/guacamole-auth-totp.tar.gz
%%DATADIR%%/guacamole.war