aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-05-03 16:11:26 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-05-03 16:11:26 +0000
commit9f5b3d910b617ad1cb164e146e13cacdbc2f022f (patch)
tree07f638103b42055bef57755f58891b584d8e0ab2
parent24229e4be2f0299ed6a1f16eccf8796c026b59a9 (diff)
downloadports-9f5b3d910b617ad1cb164e146e13cacdbc2f022f.tar.gz
ports-9f5b3d910b617ad1cb164e146e13cacdbc2f022f.zip
Notes
-rw-r--r--math/fftw-float/Makefile2
-rw-r--r--math/fftw/Makefile19
2 files changed, 12 insertions, 9 deletions
diff --git a/math/fftw-float/Makefile b/math/fftw-float/Makefile
index 46d6148b6ab7..be69b2c7e961 100644
--- a/math/fftw-float/Makefile
+++ b/math/fftw-float/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
#
-PORTREVISION= 1
+PORTREVISION= 2
COMMENT= Fast C routines (Single Percision)
diff --git a/math/fftw/Makefile b/math/fftw/Makefile
index 530f6632e8a2..d09824493922 100644
--- a/math/fftw/Makefile
+++ b/math/fftw/Makefile
@@ -26,15 +26,17 @@ FFTW_SUFIX=
USE_FORTRAN= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= autoconf:env automake:env libtool
+USE_AUTOTOOLS= aclocal automake autoconf libtool
+ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
CONFIGURE_ARGS= --enable-shared
-INFO= fftw
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
PLIST_SUB= FFTW_SUFX="${FFTW_SUFX}"
+PORTSCOUT= limit:^2\.
+
.include <bsd.port.pre.mk>
.if ${FFTW_FLAVOR}=="float"
@@ -43,6 +45,7 @@ FFTW_SUFX= s
FFTW_PKGNAMESUFFIX= -float
PLIST_SUB+= DEF="@comment "
.else
+INFO= fftw
PLIST_SUB+= DEF=""
.endif
@@ -55,16 +58,16 @@ BROKEN= does not build
.endif
post-patch:
- @${RM} ${WRKSRC}/doc/fftw.info*
-.if ${FFTW_FLAVOR}=="float"
- @${REINPLACE_CMD} -e '/^SUBDIRS/s|doc||' ${WRKSRC}/Makefile.in
-.endif
+ @${REINPLACE_CMD} -e '/^SUBDIRS/s|doc | |' ${WRKSRC}/Makefile.am
-pre-configure:
- @(cd ${WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTORECONF})
+post-build:
+.if ${FFTW_FLAVOR}=="default"
+ @cd ${WRKSRC}/doc && makeinfo fftw.texi
+.endif
post-install:
.if ${FFTW_FLAVOR}=="default"
+ ${INSTALL_DATA} ${WRKSRC}/doc/fftw.info ${PREFIX}/${INFO_PATH}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/fftw.ps ${DOCSDIR}/fftw.ps