aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-06-22 08:48:20 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-06-22 08:48:20 +0000
commita04c600ca8e8818cf0c3de3cf60860ab7b7574ea (patch)
treea88d15e415acd41744db2aa1ba1550adbeaee126
parent9b146adb59a0de1be2afcde476c3481fe8625fcc (diff)
downloadports-a04c600ca8e8818cf0c3de3cf60860ab7b7574ea.tar.gz
ports-a04c600ca8e8818cf0c3de3cf60860ab7b7574ea.zip
New port: net/coturn: TURN server
Notes
Notes: svn path=/head/; revision=504852
-rw-r--r--net/Makefile1
-rw-r--r--net/coturn/Makefile31
-rw-r--r--net/coturn/distinfo3
-rw-r--r--net/coturn/pkg-descr9
-rw-r--r--net/coturn/pkg-plist34
5 files changed, 78 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 9d8a7d114503..fcd95f2ce09c 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -91,6 +91,7 @@
SUBDIR += corkscrew
SUBDIR += corosync2
SUBDIR += corosync3
+ SUBDIR += coturn
SUBDIR += courier-authlib-ldap
SUBDIR += cppzmq
SUBDIR += cryptcat
diff --git a/net/coturn/Makefile b/net/coturn/Makefile
new file mode 100644
index 000000000000..a3df156a017a
--- /dev/null
+++ b/net/coturn/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= coturn
+DISTVERSION= 4.5.1.1
+CATEGORIES= net
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= TURN server
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libevent_core.so:devel/libevent
+
+USES= gettext-runtime gmake mysql shebangfix sqlite ssl
+USE_GITHUB= yes
+
+SHEBANG_FILES= examples/scripts/oauth.sh examples/scripts/restapi/shared_secret_maintainer.pl
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-static --enable-shared --turndbdir=/var/db/${PORTNAME}
+
+DOCSDIR= ${PREFIX}/share/doc/turnserver
+EXAMPLESDIR= ${PREFIX}/share/examples/turnserver
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+PORTDOCS= *
+PORTEXAMPLES= *
+
+.include <bsd.port.mk>
diff --git a/net/coturn/distinfo b/net/coturn/distinfo
new file mode 100644
index 000000000000..5b8bba1e5ebb
--- /dev/null
+++ b/net/coturn/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1561191516
+SHA256 (coturn-coturn-4.5.1.1_GH0.tar.gz) = 8eabe4c241ad9a74655d8516c69b1fa3275e020e7f7fca50a6cb822809e7c220
+SIZE (coturn-coturn-4.5.1.1_GH0.tar.gz) = 420069
diff --git a/net/coturn/pkg-descr b/net/coturn/pkg-descr
new file mode 100644
index 000000000000..50e4eb07c81c
--- /dev/null
+++ b/net/coturn/pkg-descr
@@ -0,0 +1,9 @@
+The TURN Server is a VoIP media traffic NAT traversal server and gateway. It can
+be used as a general-purpose network traffic TURN server and gateway, too.
+
+On-line management interface (over telnet or over HTTPS) for the TURN server is
+available.
+
+The implementation also includes some extra experimental features.
+
+WWW: https://github.com/coturn/coturn
diff --git a/net/coturn/pkg-plist b/net/coturn/pkg-plist
new file mode 100644
index 000000000000..2fca35054614
--- /dev/null
+++ b/net/coturn/pkg-plist
@@ -0,0 +1,34 @@
+bin/turnadmin
+bin/turnserver
+bin/turnutils_natdiscovery
+bin/turnutils_oauth
+bin/turnutils_peer
+bin/turnutils_stunclient
+bin/turnutils_uclient
+etc/turnserver.conf.default
+include/turn/client/TurnMsgLib.h
+include/turn/client/ns_turn_ioaddr.h
+include/turn/client/ns_turn_msg.h
+include/turn/client/ns_turn_msg_addr.h
+include/turn/client/ns_turn_msg_defs.h
+include/turn/client/ns_turn_msg_defs_experimental.h
+include/turn/ns_turn_defs.h
+lib/libturnclient.a
+man/man1/coturn.1.gz
+man/man1/turnadmin.1.gz
+man/man1/turnserver.1.gz
+man/man1/turnutils.1.gz
+man/man1/turnutils_natdiscovery.1.gz
+man/man1/turnutils_oauth.1.gz
+man/man1/turnutils_peer.1.gz
+man/man1/turnutils_stunclient.1.gz
+man/man1/turnutils_uclient.1.gz
+share/turnserver/schema.mongo.sh
+share/turnserver/schema.sql
+share/turnserver/schema.stats.redis
+share/turnserver/schema.userdb.redis
+share/turnserver/testmongosetup.sh
+share/turnserver/testredisdbsetup.sh
+share/turnserver/testsqldbsetup.sql
+/var/db/coturn/turndb
+@dir /var/db/coturn