aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2002-04-11 07:47:48 +0000
committerPeter Pentchev <roam@FreeBSD.org>2002-04-11 07:47:48 +0000
commita06b809e8ab9524cb5d272d90401bfffa8f2a6b0 (patch)
treeb52a58881626feac21fcf31b1da8ea5d2451eaee
parent02e954fe016888567ae1e59ae45f375b128b7488 (diff)
downloadports-a06b809e8ab9524cb5d272d90401bfffa8f2a6b0.tar.gz
ports-a06b809e8ab9524cb5d272d90401bfffa8f2a6b0.zip
Update to 1.5.
PR: 36760 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=57565
-rw-r--r--misc/birthday/Makefile7
-rw-r--r--misc/birthday/distinfo2
-rw-r--r--misc/birthday/files/patch-Makefile62
-rw-r--r--misc/birthday/files/patch-getopt.h29
4 files changed, 55 insertions, 45 deletions
diff --git a/misc/birthday/Makefile b/misc/birthday/Makefile
index a8476d886f50..b838fc8e8f35 100644
--- a/misc/birthday/Makefile
+++ b/misc/birthday/Makefile
@@ -6,16 +6,13 @@
#
PORTNAME= birthday
-PORTVERSION= 1.4
+PORTVERSION= 1.5
CATEGORIES= misc
-MASTER_SITES= ftp://ftp.nl.debian.org/debian/pool/main/b/birthday/
-DISTNAME= birthday_1.4
+MASTER_SITES= http://users.zetnet.co.uk/mortia/source/
MAINTAINER= niek@bergboer.net
MAN1= birthday.1
MANCOMPRESSED= no
-WRKSRC= ${WRKDIR}/birthday-1.4
-
.include <bsd.port.mk>
diff --git a/misc/birthday/distinfo b/misc/birthday/distinfo
index dd1abb999050..15bc0a7f9193 100644
--- a/misc/birthday/distinfo
+++ b/misc/birthday/distinfo
@@ -1 +1 @@
-MD5 (birthday_1.4.tar.gz) = 43a3fb421c4221a61719b61fd47055b2
+MD5 (birthday-1.5.tar.gz) = d2ceb7ca58d998645a4bdc04d986139c
diff --git a/misc/birthday/files/patch-Makefile b/misc/birthday/files/patch-Makefile
index 749125497af5..93013d80f796 100644
--- a/misc/birthday/files/patch-Makefile
+++ b/misc/birthday/files/patch-Makefile
@@ -1,11 +1,10 @@
---- Makefile-- Sat Jan 16 18:08:59 1999
-+++ Makefile Thu May 24 21:49:08 2001
-@@ -1,24 +1,27 @@
+--- Makefile Sat Jan 16 18:08:59 1999
++++ Makefile Thu Apr 4 19:21:49 2002
+@@ -1,24 +1,39 @@
-# overall makefile for birthday, to get around the differing syntax of Borland and GNU makes.
+######################################################################
+# birthday. Reminder of birthdays and other events in the near future.
-+# CVS/RCS string removed
-+# Edited by Niek Bergboer <niek@bergboer.net> for FreeBSD ports
++# $Id: Makefile.in,v 1.3 2000/01/02 19:17:33 andy Exp $
-# version for GNU make
-Makefile.gnu: makemake Makefile.in
@@ -31,51 +30,36 @@
- tar --exclude=RCS/* --dereference -czf ../birthday.tgz *
+all: birthday
+
++# NB note the different syntax for if
++
++# UNIX is replaced by name of OS by makemake
+OS=UNIX
-+OSCFLAGS=-Wall -Wstrict-prototypes
-+CFLAGS+=-D$(OS) $(OSCFLAGS)
+
++# can override this on the commandline if req'd
++DEBUG=
++OSCFLAGS=-Wall -Wstrict-prototypes
++CFLAGS+=-O2 $(DEBUG) -D$(OS) $(OSCFLAGS)
+# engine
+ENGSRC=bdengine.c xmalloc.c
-+CMDSRC=birthday.c bdcal.c $(ENGSRC)
++
++# OS-specific sources
++OSSRC=
++
++CMDSRC=birthday.c bdcal.c $(ENGSRC) $(OSSRC)
+
+CMDOBJ=$(CMDSRC:.c=.o)
+
+birthday: $(CMDOBJ)
+ $(CC) $(LDFLAGS) $(CMDOBJ) -o $@
+
++# you can override this to use the new FHS locations.
++SHARE=
++#SHARE=/share
++
+install: birthday birthday.man
-+ # Installation of dirs bin and man/man1 removed
-+ install -c -s birthday $(PREFIX)/bin/birthday
-+ install -c -m 0644 birthday.man $(PREFIX)/man/man1/birthday.1
++ # Installation of dirs bin and man/man1 removed
++ install -s birthday $(PREFIX)/bin/birthday
++ install -m 0644 birthday.man $(PREFIX)/man/man1/birthday.1
+
+clean:
+ rm -f birthday *.o
---- bdengine.c-- Thu May 10 20:03:34 2001
-+++ bdengine.c Thu May 24 21:43:51 2001
-@@ -186,9 +186,10 @@
- if (n > 0) { \
- ptr+=sprintf(ptr, "%d " txt "%s", n, (n == 1 ? "" : "s")); \
- terms--; \
-- if (orgterms > 1) \
-- if (terms == 1) ptr += sprintf(ptr, " and "); \
-- else if (terms > 1) ptr += sprintf(ptr, ", "); \
-+ if (orgterms > 1) { \
-+ if (terms == 1) { ptr += sprintf(ptr, " and "); } \
-+ else { if (terms > 1) ptr += sprintf(ptr, ", "); } \
-+ } \
- }
- #endif /* NUMS_AS_WORDS */
-
---- getopt.h-- Fri Aug 9 11:53:20 1996
-+++ getopt.h Thu May 24 21:43:51 2001
-@@ -100,7 +100,8 @@
- errors, only prototype getopt for the GNU C library. */
- extern int getopt (int argc, char *const *argv, const char *shortopts);
- #else /* not __GNU_LIBRARY__ */
--extern int getopt ();
-+/* But FreeBSD STDC does have the GNU syntax */
-+extern int getopt (int argc, char *const *argv, const char *shortopts);
- #endif /* not __GNU_LIBRARY__ */
- extern int getopt_long (int argc, char *const *argv, const char *shortopts,
- const struct option *longopts, int *longind);
diff --git a/misc/birthday/files/patch-getopt.h b/misc/birthday/files/patch-getopt.h
new file mode 100644
index 000000000000..b6f814d98c83
--- /dev/null
+++ b/misc/birthday/files/patch-getopt.h
@@ -0,0 +1,29 @@
+--- getopt.h Thu Apr 4 19:15:06 2002
++++ getopt.h Thu Apr 4 19:15:32 2002
+@@ -93,15 +93,22 @@
+ optional_argument
+ };
+
++
++// Note: FreeBSD does follow the normal GNU definition for getopt, but
++// the checks below would cause it to use a new --conflicting-- definition.
++// Therefore, the checks have been commented out.
++//
++// Niek Bergboer, 04-Apr-2002
++
+ #if __STDC__
+-#if defined(__GNU_LIBRARY__)
++//#if defined(__GNU_LIBRARY__)
+ /* Many other libraries have conflicting prototypes for getopt, with
+ differences in the consts, in stdlib.h. To avoid compilation
+ errors, only prototype getopt for the GNU C library. */
+ extern int getopt (int argc, char *const *argv, const char *shortopts);
+-#else /* not __GNU_LIBRARY__ */
+-extern int getopt ();
+-#endif /* not __GNU_LIBRARY__ */
++//#else /* not __GNU_LIBRARY__ */
++//extern int getopt ();
++//#endif /* not __GNU_LIBRARY__ */
+ extern int getopt_long (int argc, char *const *argv, const char *shortopts,
+ const struct option *longopts, int *longind);
+ extern int getopt_long_only (int argc, char *const *argv,