aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2014-04-16 16:29:38 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2014-04-16 16:29:38 +0000
commita189085d535285bff8ee5feccf292d7ceadeffed (patch)
tree95c24d297be1f9224477c5c5c63007a1a0368c39
parent99631c4b6e706723625125d5c0dbb885256653c9 (diff)
downloadports-a189085d535285bff8ee5feccf292d7ceadeffed.tar.gz
ports-a189085d535285bff8ee5feccf292d7ceadeffed.zip
- Make default target "make stage" if staging supported.
This is so that 'make' followed by 'make deinstall install' will, by default, have a much shorter period of files missing on the system as it is without staging. Discussed with: bapt With hat: portmgr
Notes
Notes: svn path=/head/; revision=351399
-rw-r--r--CHANGES6
-rw-r--r--Mk/bsd.port.mk4
2 files changed, 10 insertions, 0 deletions
diff --git a/CHANGES b/CHANGES
index 87135b4c8c95..214228d61325 100644
--- a/CHANGES
+++ b/CHANGES
@@ -10,6 +10,12 @@ in the release notes and/or placed into UPDATING.
All ports committers are allowed to commit to this file.
+20140416:
+AUTHOR: bdrewery@FreeBSD.org
+
+ The default target for 'make' now runs 'make stage' if the port supports
+ it, otherwise 'make build' as before.
+
20140411:
AUTHOR: bdrewery@FreeBSD.org
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index c56f7e0e5e83..6bdf841c358f 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3165,7 +3165,11 @@ all:
.endif
.if !target(all)
+. if defined(NO_STAGE)
all: build
+. else
+all: stage
+. endif
.endif
.if !defined(DEPENDS_TARGET)