aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2005-12-17 16:02:09 +0000
committerErwin Lansing <erwin@FreeBSD.org>2005-12-17 16:02:09 +0000
commita1b6ae659b4059ee44ce2c05c7d94095dc40c702 (patch)
treef3d23d0b2cc6ee80aeb0e4aa9135faf3659ddde9
parenta9fd566668badebe30eb598913b2e1dcdce11f21 (diff)
downloadports-a1b6ae659b4059ee44ce2c05c7d94095dc40c702.tar.gz
ports-a1b6ae659b4059ee44ce2c05c7d94095dc40c702.zip
Notes
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Digest-Elf/Makefile24
-rw-r--r--security/p5-Digest-Elf/distinfo3
-rw-r--r--security/p5-Digest-Elf/pkg-descr5
-rw-r--r--security/p5-Digest-Elf/pkg-plist7
5 files changed, 40 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index f5b87fc50b7e..7f00152774d7 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -336,6 +336,7 @@
SUBDIR += p5-Digest-DJB
SUBDIR += p5-Digest-DMAC
SUBDIR += p5-Digest-EMAC
+ SUBDIR += p5-Digest-Elf
SUBDIR += p5-Digest-HMAC
SUBDIR += p5-Digest-Hashcash
SUBDIR += p5-Digest-Haval256
diff --git a/security/p5-Digest-Elf/Makefile b/security/p5-Digest-Elf/Makefile
new file mode 100644
index 000000000000..fcfb2cc1240e
--- /dev/null
+++ b/security/p5-Digest-Elf/Makefile
@@ -0,0 +1,24 @@
+# Ports collection Makefile for: p5-Digest-Elf
+# Date created: 17 Dec 2005
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Digest-Elf
+PORTVERSION= 1.4
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Digest
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension for ElfHash hash algorithm
+
+PERL_CONFIGURE= yes
+
+MAN3= Digest::Elf.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-Digest-Elf/distinfo b/security/p5-Digest-Elf/distinfo
new file mode 100644
index 000000000000..910b7523711f
--- /dev/null
+++ b/security/p5-Digest-Elf/distinfo
@@ -0,0 +1,3 @@
+MD5 (Digest-Elf-1.4.tar.gz) = 59e6737aae2f9efd1a8af8bc8655f575
+SHA256 (Digest-Elf-1.4.tar.gz) = 8a17e49814cc596d9884194ae119a19ee37810c10912136f1136d0af74429aa7
+SIZE (Digest-Elf-1.4.tar.gz) = 2678
diff --git a/security/p5-Digest-Elf/pkg-descr b/security/p5-Digest-Elf/pkg-descr
new file mode 100644
index 000000000000..7f403897cae2
--- /dev/null
+++ b/security/p5-Digest-Elf/pkg-descr
@@ -0,0 +1,5 @@
+Digest::Elf provides an XS based implementation of the ElfHash algorithm.
+ElfHash generates resonably 32 bit integer value from a string in a
+reasonably short period of time.
+
+WWW: http://search.cpan.org/dist/Digest-Elf
diff --git a/security/p5-Digest-Elf/pkg-plist b/security/p5-Digest-Elf/pkg-plist
new file mode 100644
index 000000000000..ffc327260dba
--- /dev/null
+++ b/security/p5-Digest-Elf/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Digest/Elf.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/Elf/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/Elf/Elf.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/Elf/Elf.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/Elf/
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/ 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Digest/ 2>/dev/null || true