aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2019-03-14 20:21:27 +0000
committerKai Knoblich <kai@FreeBSD.org>2019-03-14 20:21:27 +0000
commita1fd09a28058163a8f4c0ff2795382d4081b819a (patch)
treef0cb0699267243d36c4dcbb4ed37fff2e6488a26
parenta9c2dcba6947e3bde92e1ced154313d5518b7bde (diff)
downloadports-a1fd09a28058163a8f4c0ff2795382d4081b819a.tar.gz
ports-a1fd09a28058163a8f4c0ff2795382d4081b819a.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django-common-helpers/Makefile22
-rw-r--r--www/py-django-common-helpers/distinfo3
-rw-r--r--www/py-django-common-helpers/pkg-descr23
4 files changed, 49 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 853782e73dcf..fda8aa7a5957 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1542,6 +1542,7 @@
SUBDIR += py-django-caching-app-plugins
SUBDIR += py-django-classy-tags
SUBDIR += py-django-cms
+ SUBDIR += py-django-common-helpers
SUBDIR += py-django-configurations
SUBDIR += py-django-constance
SUBDIR += py-django-contact-form
diff --git a/www/py-django-common-helpers/Makefile b/www/py-django-common-helpers/Makefile
new file mode 100644
index 000000000000..13be61cc6798
--- /dev/null
+++ b/www/py-django-common-helpers/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= django-common-helpers
+PORTVERSION= 0.9.2
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= kai@FreeBSD.org
+COMMENT= Common things every Django app needs
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django111>=1.8:www/py-django111@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-django-common-helpers/distinfo b/www/py-django-common-helpers/distinfo
new file mode 100644
index 000000000000..b98b78e45a5c
--- /dev/null
+++ b/www/py-django-common-helpers/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1549629858
+SHA256 (django-common-helpers-0.9.2.tar.gz) = 2d56be6fa261d829a6a224f189bf276267b9082a17d613fe5f015dd4d65c17b4
+SIZE (django-common-helpers-0.9.2.tar.gz) = 37792
diff --git a/www/py-django-common-helpers/pkg-descr b/www/py-django-common-helpers/pkg-descr
new file mode 100644
index 000000000000..f177184f0d9f
--- /dev/null
+++ b/www/py-django-common-helpers/pkg-descr
@@ -0,0 +1,23 @@
+py-django-common-helpers consists of the following things:
+
+- Middleware that makes sure a web-app runs either on or without "www" in the
+ domain.
+
+- "SessionManagerBase" base class, that helps in keeping session related code
+ object-oriented and clean.
+
+- "EmailBackend" for authenticating users based on their email, apart from
+ username.
+
+- Custom db fields that can be used in models including a "UniqueHashField"
+ and "RandomHashField".
+
+- Bunch of helpful functions in helper.py
+
+- "render_form_field" template tag that makes rendering form fields easy
+ and DRY.
+
+- Couple of dry response classes: "JsonResponse" and "XMLResponse" in the
+ django_common.http that can be used in views that give json/xml responses.
+
+WWW: https://github.com/tivix/django-common/