aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2012-12-13 11:55:36 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2012-12-13 11:55:36 +0000
commita3bbd50254a94167ef2139fda346873edeef76b5 (patch)
tree71f19f0f4f5b0eb12cb584cabfba171a75496b2e
parent0b1cf879c521dfdf6a471adf581657afb226e015 (diff)
downloadports-a3bbd50254a94167ef2139fda346873edeef76b5.tar.gz
ports-a3bbd50254a94167ef2139fda346873edeef76b5.zip
Notes
-rw-r--r--devel/libthai/Makefile39
-rw-r--r--devel/libthai/pkg-descr19
2 files changed, 26 insertions, 32 deletions
diff --git a/devel/libthai/Makefile b/devel/libthai/Makefile
index c30c4cf76174..8579cbe4ee32 100644
--- a/devel/libthai/Makefile
+++ b/devel/libthai/Makefile
@@ -1,43 +1,38 @@
-# New ports collection makefile for: libthai
-# Date created: 28 March 2006
-# Whom: Thawatchai Piyawat <piyawat@usablelabs.com>
-#
+# Created by: Thawatchai Piyawat <piyawat@usablelabs.com>
# $FreeBSD$
-#
PORTNAME= libthai
PORTVERSION= 0.1.5
PORTREVISION= 4
CATEGORIES= devel
-MASTER_SITES= http://www.usablelabs.com/download/
+MASTER_SITES= http://linux.thai.net/pub/thailinux/software/libthai/
MAINTAINER= ports@FreeBSD.org
COMMENT= Thai language support library
-USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USE_AUTOTOOLS= automake autoconf libtool
-AUTOTOOLSFILES= autogen.sh
-MAKE_JOBS_UNSAFE= yes
+LICENSE= LGPL21
-ALL_TARGET= all check
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtoolize aclocal automake autoconf
+LIBTOOLIZE_ARGS=--copy --force
+ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
+AUTOMAKE_ARGS= --add-missing --copy --force-missing --foreign
+USE_LDCONFIG= yes
+MAKE_JOBS_UNSAFE=yes
MAN3= libthai.3 thctype.3 wtt.3
-post-patch:
- @${REINPLACE_CMD} -E 's,^(pkgconfigdir = ).*$$,\1$$(prefix)/libdata/pkgconfig,' \
- ${WRKSRC}/Makefile.am
- @${REINPLACE_CMD} -e 's,15,-%%AUTOMAKE_VERSION%%,' -e 's,259,-%%AUTOCONF_VERSION%%,' \
- ${WRKSRC}/autogen.sh
-
-pre-configure:
- @cd ${WRKSRC} && ${SH} autogen.sh
-
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64" && ${OSVERSION} > 800000
ALL_TARGET= all
+.else
+ALL_TARGET= all check
.endif
+post-patch:
+ @${REINPLACE_CMD} -e \
+ '/^pkgconfigdir/s|=.*|= $$(prefix)/libdata/pkgconfig|' \
+ ${WRKSRC}/Makefile.am
+
.include <bsd.port.post.mk>
diff --git a/devel/libthai/pkg-descr b/devel/libthai/pkg-descr
index 60765107b893..fe458b067080 100644
--- a/devel/libthai/pkg-descr
+++ b/devel/libthai/pkg-descr
@@ -1,19 +1,18 @@
-LibThai is a set of Thai language support routines aimed to ease
-developers' tasks to incorporate Thai language support in their
-applications. It includes important Thai-specific functions e.g.
-word breaking, input and output methods as well as basic charac-
-ter and string supports. LibThai is an Open Source and collabora-
-tive effort initiated by Thai Linux Working Group and opened for
-all contributors.
+LibThai is a set of Thai language support routines aimed to ease
+developers' tasks to incorporate Thai language support in their
+applications. It includes important Thai-specific functions e.g. word
+breaking, input and output methods as well as basic character and string
+supports. LibThai is an Open Source and collaborative effort initiated
+by Thai Linux Working Group and opened for all contributors.
LibThai includes Thai language support routines:
* Thai character set support: TIS 620, ISO/IEC 10646
* Thai character properties
* Thai string manipulators
-* Thai string collation
-* Thai word breaking
+* Thai string collation
+* Thai word breaking
* Thai input method
* Thai output method
-WWW: http://linux.thai.net/plone/TLWG/libthai/
+WWW: http://linux.thai.net/projects/libthai/