aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2014-03-23 19:50:59 +0000
committerSteve Wills <swills@FreeBSD.org>2014-03-23 19:50:59 +0000
commita47fc04fc388a854e7be10457e22e426b2f86f48 (patch)
tree7d53dcfec563c0429ffae3e45cec46da5c36e32d
parent82047d34ad65486e79f9859b1a7171c0b6e7eda1 (diff)
downloadports-a47fc04fc388a854e7be10457e22e426b2f86f48.tar.gz
ports-a47fc04fc388a854e7be10457e22e426b2f86f48.zip
Notes
-rw-r--r--java/linux-sun-jre16/Makefile11
-rw-r--r--java/linux-sun-jre16/files/pkg-install.in16
2 files changed, 13 insertions, 14 deletions
diff --git a/java/linux-sun-jre16/Makefile b/java/linux-sun-jre16/Makefile
index cd9335dc8c51..5c207af42c42 100644
--- a/java/linux-sun-jre16/Makefile
+++ b/java/linux-sun-jre16/Makefile
@@ -34,7 +34,6 @@ APP_HOME= ${PREFIX}/${PKGNAMEPREFIX}${PORTNAME}${JRE_VERSION}
PACKED_JARS= lib/charsets lib/deploy lib/ext/localedata lib/javaws lib/jsse lib/plugin lib/rt
UNPACK_CMD= ${WRKSRC}/bin/unpack200
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
@@ -56,18 +55,18 @@ do-extract:
post-patch:
${REINPLACE_CMD} -i.orig -e 's:^#!/bin/bash:#!/bin/sh:' ${WRKSRC}/bin/jcontrol
- @${FIND} ${WRKSRC} -name '*.orig' -print | ${XARGS} ${RM} -f
+ @${FIND} ${WRKSRC} -name '*.orig' -delete
# XXX: This is missing a "${BRANDELF} -t Linux <executables>".
do-install:
- ${MKDIR} ${APP_HOME}
+ ${MKDIR} ${STAGEDIR}${APP_HOME}
cd ${WRKSRC} && ${FIND} . -print \
- | ${CPIO} -pdmu -R ${LIBOWN}:${LIBGRP} ${APP_HOME}
+ | ${CPIO} -pdmu -R ${LIBOWN}:${LIBGRP} ${STAGEDIR}${APP_HOME}
post-install:
- ${LOCALBASE}/bin/registervm "${APP_HOME}/bin/java # Linux-Sun-JRE${PORTVERSION}"
- ${SED} -e "s:%%JRE_HOME%%:${APP_HOME}:g" \
+ ${SED} -e "s:%%JRE_HOME%%:${APP_HOME}:g; \
+ s:%%STAGEDIR%%:${STAGEDIR}:" \
< ${FILESDIR}/pkg-install.in > ${PKGINSTALL}
${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
diff --git a/java/linux-sun-jre16/files/pkg-install.in b/java/linux-sun-jre16/files/pkg-install.in
index fa980a9778f0..ed297521cdca 100644
--- a/java/linux-sun-jre16/files/pkg-install.in
+++ b/java/linux-sun-jre16/files/pkg-install.in
@@ -5,15 +5,15 @@ PREFS_LOCATION=%%JRE_HOME%%
# Set up system preferences during post install
if [ "$2" = "POST-INSTALL" ]; then
- if [ ! -d "${PREFS_LOCATION}/.systemPrefs" ] ; then
- mkdir -m 755 "${PREFS_LOCATION}/.systemPrefs"
+ if [ ! -d "%%STAGEDIR%%${PREFS_LOCATION}/.systemPrefs" ] ; then
+ mkdir -m 755 "%%STAGEDIR%%${PREFS_LOCATION}/.systemPrefs"
fi
- if [ ! -f "${PREFS_LOCATION}/.systemPrefs/.system.lock" ] ; then
- touch "${PREFS_LOCATION}/.systemPrefs/.system.lock"
- chmod 644 "${PREFS_LOCATION}/.systemPrefs/.system.lock"
+ if [ ! -f "%%STAGEDIR%%${PREFS_LOCATION}/.systemPrefs/.system.lock" ] ; then
+ touch "%%STAGEDIR%%${PREFS_LOCATION}/.systemPrefs/.system.lock"
+ chmod 644 "%%STAGEDIR%%${PREFS_LOCATION}/.systemPrefs/.system.lock"
fi
- if [ ! -f "${PREFS_LOCATION}/.systemPrefs/.systemRootModFile" ] ; then
- touch "${PREFS_LOCATION}/.systemPrefs/.systemRootModFile"
- chmod 644 "${PREFS_LOCATION}/.systemPrefs/.systemRootModFile"
+ if [ ! -f "%%STAGEDIR%%${PREFS_LOCATION}/.systemPrefs/.systemRootModFile" ] ; then
+ touch "%%STAGEDIR%%${PREFS_LOCATION}/.systemPrefs/.systemRootModFile"
+ chmod 644 "%%STAGEDIR%%${PREFS_LOCATION}/.systemPrefs/.systemRootModFile"
fi
fi