aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-21 14:25:52 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-21 14:25:52 +0000
commita684cc4a9bc26811c8f8dd19cf11bc2bc34e1b03 (patch)
treec9295d721ab7edbc515ad7bcca0c9e4463b58e57
parentb9c97365c2c64078f9f48bf26e47e9dc3bc774b9 (diff)
downloadports-a684cc4a9bc26811c8f8dd19cf11bc2bc34e1b03.tar.gz
ports-a684cc4a9bc26811c8f8dd19cf11bc2bc34e1b03.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-WWW-Google-PageRank/Makefile36
-rw-r--r--www/p5-WWW-Google-PageRank/distinfo3
-rw-r--r--www/p5-WWW-Google-PageRank/pkg-descr9
-rw-r--r--www/p5-WWW-Google-PageRank/pkg-plist7
5 files changed, 56 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index a0e400549b4e..b9f4a366d11e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -764,6 +764,7 @@
SUBDIR += p5-WWW-Dilbert
SUBDIR += p5-WWW-Google-News
SUBDIR += p5-WWW-Google-News-TW
+ SUBDIR += p5-WWW-Google-PageRank
SUBDIR += p5-WWW-Google-Video
SUBDIR += p5-WWW-IMDb
SUBDIR += p5-WWW-Link
diff --git a/www/p5-WWW-Google-PageRank/Makefile b/www/p5-WWW-Google-PageRank/Makefile
new file mode 100644
index 000000000000..26924c203b32
--- /dev/null
+++ b/www/p5-WWW-Google-PageRank/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-WWW-Google-PageRank
+# Date created: 2006-07-19
+# Whom: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-Google-PageRank
+PORTVERSION= 0.12
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WWW
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= snowfly@yuntech.edu.tw
+COMMENT= This's a Perl interface for querying google pagerank
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= WWW::Google::PageRank.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.if ${PERL_LEVEL} < 500601
+BUILD_DEPENDS+= ${SITE_PERL}/base.pm:${PORTSDIR}/devel/p5-Class-Fields
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-WWW-Google-PageRank/distinfo b/www/p5-WWW-Google-PageRank/distinfo
new file mode 100644
index 000000000000..90b384febdd0
--- /dev/null
+++ b/www/p5-WWW-Google-PageRank/distinfo
@@ -0,0 +1,3 @@
+MD5 (WWW-Google-PageRank-0.12.tar.gz) = 5b7822f97fff0d0926f8c5be99beed7c
+SHA256 (WWW-Google-PageRank-0.12.tar.gz) = ddd1cf79442d8f7846a7140e80402a20f70eaea0723363cc370a54b2e46eaa59
+SIZE (WWW-Google-PageRank-0.12.tar.gz) = 4212
diff --git a/www/p5-WWW-Google-PageRank/pkg-descr b/www/p5-WWW-Google-PageRank/pkg-descr
new file mode 100644
index 000000000000..232dccb82194
--- /dev/null
+++ b/www/p5-WWW-Google-PageRank/pkg-descr
@@ -0,0 +1,9 @@
+The WWW::Google::PageRank is a class implementing a interface
+for querying google pagerank.
+To use it, you should create WWW::Google::PageRank object
+and use its method get(), to query page rank of URL.
+It uses LWP::UserAgent for making request to Google.
+
+
+Author: Yuri Karaban <tech@askold.net>
+WWW: http://search.cpan.org/~ykar/WWW-Google-PageRank/
diff --git a/www/p5-WWW-Google-PageRank/pkg-plist b/www/p5-WWW-Google-PageRank/pkg-plist
new file mode 100644
index 000000000000..b7a307cf2ea2
--- /dev/null
+++ b/www/p5-WWW-Google-PageRank/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/WWW/Google/PageRank.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Google/PageRank/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Google/PageRank
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Google
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW
+@dirrmtry %%SITE_PERL%%/WWW/Google
+@dirrmtry %%SITE_PERL%%/WWW