aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2016-03-17 20:27:25 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2016-03-17 20:27:25 +0000
commita6877cf70df95e3775d4ad53a1f51e068990b4ce (patch)
treec457c38615a203c49d451bfcd4d05360acaa101b
parentba6a316e2d6856f3d4d54f92ca08dff60a01fd42 (diff)
downloadports-a6877cf70df95e3775d4ad53a1f51e068990b4ce.tar.gz
ports-a6877cf70df95e3775d4ad53a1f51e068990b4ce.zip
Notes
-rw-r--r--archivers/peazip/Makefile8
-rw-r--r--archivers/peazip/distinfo4
-rw-r--r--archivers/peazip/files/patch-list_utils.pas11
-rw-r--r--archivers/peazip/files/patch-peach.pas54
-rw-r--r--archivers/peazip/files/patch-unit8.pas29
-rw-r--r--archivers/peazip/pkg-plist21
6 files changed, 11 insertions, 116 deletions
diff --git a/archivers/peazip/Makefile b/archivers/peazip/Makefile
index a3e29b89fe94..59213d70e4ea 100644
--- a/archivers/peazip/Makefile
+++ b/archivers/peazip/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= peazip
-PORTVERSION= 5.9.1
+PORTVERSION= 6.0.0
CATEGORIES= archivers
MASTER_SITES= https://github.com/giorgiotani/PeaZip/releases/download/${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
@@ -23,7 +23,7 @@ DOS2UNIX_REGEX= .*\.([txt]|pas|lpi|txt)
LAZARUS_PROJECT_FILES= project_pea.lpi project_peach.lpi project_gwrap.lpi
LAZBUILD_CMD= ${LOCALBASE}/bin/lazbuild -d
LCL_UNITS_DIR= ${LOCALBASE}/share/lazarus-${LAZARUS_VER}/lcl/units/${BUILDNAME}
-LAZARUS_VER= 1.6RC2
+LAZARUS_VER= 1.6.0
LAZARUS_DIR= ${LOCALBASE}/share/lazarus-${LAZARUS_VER}
ARCHIVER_FILES= #
@@ -40,7 +40,7 @@ QT4_DESC= Use qt4 interface
OPTIONS_DEFAULT= GTK2 7Z
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MGTK2}
USE_FPC+= gtk2
@@ -112,4 +112,4 @@ do-install:
${INSTALL_DATA} peazip.png ${STAGEDIR}${PREFIX}/share/pixmaps/
${INSTALL_SCRIPT} ${WRKDIR}/pea ${WRKDIR}/pealauncher ${WRKDIR}/peazip ${STAGEDIR}${PREFIX}/bin/
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/archivers/peazip/distinfo b/archivers/peazip/distinfo
index 0dce76fcc040..dcf60f9538f2 100644
--- a/archivers/peazip/distinfo
+++ b/archivers/peazip/distinfo
@@ -1,2 +1,2 @@
-SHA256 (peazip-5.9.1.src.zip) = f5619179c72582898acf5dcf981b9c12f06646dc2d9039acbbc215af8f66f2ae
-SIZE (peazip-5.9.1.src.zip) = 4081923
+SHA256 (peazip-6.0.0.src.zip) = d585c79c632eac43edbfb133a0b59767424d137f3db75c55d49a793664af7bf2
+SIZE (peazip-6.0.0.src.zip) = 3913063
diff --git a/archivers/peazip/files/patch-list_utils.pas b/archivers/peazip/files/patch-list_utils.pas
deleted file mode 100644
index 8cae5dc79383..000000000000
--- a/archivers/peazip/files/patch-list_utils.pas
+++ /dev/null
@@ -1,11 +0,0 @@
---- list_utils.pas.orig 2016-01-27 13:31:39.038239000 -0500
-+++ list_utils.pas 2016-01-27 13:32:00.045976000 -0500
-@@ -969,7 +969,7 @@
- //name of the dir
- ): integer;
- var
-- s: utf8string;
-+ s: string;
- i, j: integer;
- dirarr: array of utf8string;
- begin
diff --git a/archivers/peazip/files/patch-peach.pas b/archivers/peazip/files/patch-peach.pas
index 7b630a32ad2c..ceb82e41270b 100644
--- a/archivers/peazip/files/patch-peach.pas
+++ b/archivers/peazip/files/patch-peach.pas
@@ -24,57 +24,3 @@
{$ENDIF}
var
-@@ -6526,7 +6529,7 @@
-
- procedure setdescription_advcustedit;
- var
-- s:utf8string;
-+ s:AnsiString;
- sg:TStringGrid;
- begin
- sg:=Form_peach.StringGridCustedit1;
-@@ -6541,7 +6544,7 @@
-
- procedure setdescription_custedit;
- var
-- s:utf8string;
-+ s:AnsiString;
- begin
- s:=Form_peach.StringGridCustedit.Cells[1,Form_peach.StringGridCustedit.Row];
- if InputQuery(txt_description, '', s) then
-@@ -6553,7 +6556,7 @@
-
- procedure editstring1_advcustedit;
- var
-- s:utf8string;
-+ s:AnsiString;
- begin
- s:=Form_peach.StringGridCustedit1.Cells[2,Form_peach.StringGridCustedit1.Row];
- if InputQuery(txt_2_5_strbefore, '', s) then
-@@ -6566,7 +6569,7 @@
-
- procedure editstring2_advcustedit;
- var
-- s:utf8string;
-+ s:AnsiString;
- begin
- s:=Form_peach.StringGridCustedit1.Cells[3,Form_peach.StringGridCustedit1.Row];
- if InputQuery(txt_2_5_strafter, '', s) then
-@@ -6579,7 +6582,7 @@
-
- procedure editstring3_advcustedit;
- var
-- s:utf8string;
-+ s:AnsiString;
- begin
- s:=Form_peach.StringGridCustedit1.Cells[4,Form_peach.StringGridCustedit1.Row];
- if InputQuery(txt_3_3_stralt, '', s) then
-@@ -6592,7 +6595,7 @@
-
- procedure editapp_custedit;
- var
-- s:utf8string;
-+ s:AnsiString;
- begin
- s:=Form_peach.StringGridCustedit.Cells[2,Form_peach.StringGridCustedit.Row];
- if InputQuery(txt_edit, '', s) then
diff --git a/archivers/peazip/files/patch-unit8.pas b/archivers/peazip/files/patch-unit8.pas
deleted file mode 100644
index badf55485b97..000000000000
--- a/archivers/peazip/files/patch-unit8.pas
+++ /dev/null
@@ -1,29 +0,0 @@
---- unit8.pas.orig 2016-01-27 13:11:27.063394000 -0500
-+++ unit8.pas 2016-01-27 13:14:04.758776000 -0500
-@@ -170,7 +170,7 @@
- procedure new_pm;
- var
- i,rc:integer;
-- s:utf8string;
-+ s:AnsiString;
- begin
- if InputQuery(txt_edit+' '+FormPM.mpw.Caption, '', s) then
- begin
-@@ -190,7 +190,7 @@
- end;
-
- procedure editpw_pm;
--var s:utf8string;
-+var s:AnsiString;
- begin
- if FormPM.StringGridPM.Row=0 then
- begin
-@@ -207,7 +207,7 @@
- end;
-
- procedure setdescription_pm;
--var s:utf8string;
-+var s:AnsiString;
- begin
- if FormPM.StringGridPM.Row=0 then
- begin
diff --git a/archivers/peazip/pkg-plist b/archivers/peazip/pkg-plist
index d516b457342d..f0f3a4e83be8 100644
--- a/archivers/peazip/pkg-plist
+++ b/archivers/peazip/pkg-plist
@@ -12,20 +12,6 @@ share/pixmaps/peazip.png
%%DATADIR%%/res/icons/PeaZip_package.ico
%%DATADIR%%/res/icons/PeaZip_rar.ico
%%DATADIR%%/res/icons/PeaZip_zip.ico
-%%DATADIR%%/res/icons/new installer/peazip-256.bmp
-%%DATADIR%%/res/icons/new installer/peazip-icon-green.ico
-%%DATADIR%%/res/icons/new installer/peazip-icon-yellow.ico
-%%DATADIR%%/res/icons/new installer/peazip-installer-green-16.bmp
-%%DATADIR%%/res/icons/new installer/peazip-installer-green-24.bmp
-%%DATADIR%%/res/icons/new installer/peazip-installer-green-256.bmp
-%%DATADIR%%/res/icons/new installer/peazip-installer-green-32.bmp
-%%DATADIR%%/res/icons/new installer/peazip-installer-green-48.bmp
-%%DATADIR%%/res/icons/new installer/peazip-installer-yellow-16.bmp
-%%DATADIR%%/res/icons/new installer/peazip-installer-yellow-24.bmp
-%%DATADIR%%/res/icons/new installer/peazip-installer-yellow-256.bmp
-%%DATADIR%%/res/icons/new installer/peazip-installer-yellow-32.bmp
-%%DATADIR%%/res/icons/new installer/peazip-installer-yellow-48.bmp
-%%DATADIR%%/res/icons/new installer/peazip-installer.png
%%DATADIR%%/res/icons/peazip_seven.icl
%%DATADIR%%/res/lang/ar.txt
%%DATADIR%%/res/lang/bg.txt
@@ -66,12 +52,15 @@ share/pixmaps/peazip.png
%%DATADIR%%/res/lang/vn.txt
%%DATADIR%%/res/pea
%%DATADIR%%/res/pealauncher
+%%DATADIR%%/res/themes/classic.theme.7z
+%%DATADIR%%/res/themes/experience.theme.7z
%%DATADIR%%/res/themes/firecrystal.theme.7z
%%DATADIR%%/res/themes/nographic-embedded/fm-theme.bmp
%%DATADIR%%/res/themes/nographic-embedded/note.readme
-%%DATADIR%%/res/themes/seven-embedded/fm-theme.bmp
-%%DATADIR%%/res/themes/seven-embedded/note.readme
%%DATADIR%%/res/themes/seven.theme.7z
+%%DATADIR%%/res/themes/ten-embedded/fm-theme.bmp
+%%DATADIR%%/res/themes/ten-embedded/note.readme
+%%DATADIR%%/res/themes/ten.theme.7z
%%7Z%%%%DATADIR%%/res/7z/7z
%%ARC%%%%DATADIR%%/res/arc/arc
%%UNACE%%%%DATADIR%%/res/unace/unace