aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2015-02-26 22:44:42 +0000
committerMikhail Teterin <mi@FreeBSD.org>2015-02-26 22:44:42 +0000
commita72dea4fb3c91fff6c2f2a876b0e5bed64f85528 (patch)
tree86dd4993f66f32df427aacda8f0bce18dd27e5d7
parentd27f375ad39f47eb60cc776bba386b6b8b57e095 (diff)
downloadports-a72dea4fb3c91fff6c2f2a876b0e5bed64f85528.tar.gz
ports-a72dea4fb3c91fff6c2f2a876b0e5bed64f85528.zip
Notes
-rw-r--r--sysutils/runwhen/Makefile27
-rw-r--r--sysutils/runwhen/distinfo4
-rw-r--r--sysutils/runwhen/files/patch-compile14
-rw-r--r--sysutils/runwhen/pkg-plist14
4 files changed, 16 insertions, 43 deletions
diff --git a/sysutils/runwhen/Makefile b/sysutils/runwhen/Makefile
index 2145e4259356..e32732023eba 100644
--- a/sysutils/runwhen/Makefile
+++ b/sysutils/runwhen/Makefile
@@ -2,42 +2,43 @@
# $FreeBSD$
PORTNAME= runwhen
-PORTVERSION= 2003.10.31
+PORTVERSION= 2015.02.24
CATEGORIES= sysutils
-MASTER_SITES= http://code.dogmap.org./${PORTNAME}/releases/
+MASTER_SITES= http://code.dogmap.org/runwhen/releases/
MAINTAINER= ports@FreeBSD.org
COMMENT= Tools for running commands at particular times
+LICENSE= GPLv2
+
BUILD_DEPENDS= ${LOCALBASE}/include/skalibs:${PORTSDIR}/devel/skalibs
USES= tar:bzip2
WRKSRC= ${WRKDIR}/admin/${DISTNAME}
-ALL_TARGET= default
-
-DOCS= src/CHANGES src/TODO package/README
-OPTIONS_DEFINE= DOCS
+PLIST_FILES= bin/rw-add bin/rw-match bin/rw-max bin/rw-min \
+ bin/rw-sleep bin/rw-sub bin/rw-touch
-BROKEN= fails to build with skalibs-2.x
+CFLAGS+= -I${LOCALBASE}/include
post-patch:
@${REINPLACE_CMD} -e 's!gcc -O2!${CC} ${CFLAGS}!' \
- ${WRKSRC}/conf-compile/host_compile.sh
+ ${WRKSRC}/conf-compile/defaults/host_compile.sh
@${REINPLACE_CMD} 's!gcc!${CC} ${LDFLAGS} ${LIBS}!' \
- ${WRKSRC}/conf-compile/host_link.sh
+ ${WRKSRC}/conf-compile/defaults/host_link.sh
+ @${REINPLACE_CMD} 's!-lskarnet!-L${LOCALBASE}/lib -lskarnet!' \
+ ${WRKSRC}/package/compile
do-configure:
- ${ECHO_CMD} ${PREFIX} > ${WRKSRC}/conf-compile/package_home
- ${ECHO_CMD} ${LOCALBASE} > ${WRKSRC}/conf-compile/depend_skalibs
+ ${ECHO_CMD} ${PREFIX} > ${WRKSRC}/conf-compile/defaults/package_home
+ ${ECHO_CMD} ${LOCALBASE} > ${WRKSRC}/conf-compile/defaults/depend_skalibs
+ ${ECHO_CMD} ${LOCALBASE}/lib/skalibs/sysdeps > ${WRKSRC}/conf-compile/defaults/depend_skalibs_sysdeps
do-build:
cd ${WRKSRC} && package/compile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/command/* ${STAGEDIR}${PREFIX}/bin
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- (cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>
diff --git a/sysutils/runwhen/distinfo b/sysutils/runwhen/distinfo
index 821604444e70..15a04fd90401 100644
--- a/sysutils/runwhen/distinfo
+++ b/sysutils/runwhen/distinfo
@@ -1,2 +1,2 @@
-SHA256 (runwhen-2003.10.31.tar.bz2) = 28416dcd26685f9295ec9850e65962b13817ddab98a8634571996f3e8270d3ec
-SIZE (runwhen-2003.10.31.tar.bz2) = 23587
+SHA256 (runwhen-2015.02.24.tar.bz2) = 8459fb0f21baf2151162c973146ef9f232f5f3ea40f2637ff884f78bcf12923f
+SIZE (runwhen-2015.02.24.tar.bz2) = 23397
diff --git a/sysutils/runwhen/files/patch-compile b/sysutils/runwhen/files/patch-compile
deleted file mode 100644
index a8a77511f68e..000000000000
--- a/sysutils/runwhen/files/patch-compile
+++ /dev/null
@@ -1,14 +0,0 @@
---- package/compile Thu Oct 30 20:56:44 2003
-+++ package/compile.new Fri Oct 31 16:07:38 2003
-@@ -1426,7 +1426,10 @@
-
- make_37() {
- echo && echo_ Making compile/host/skalibs &&
-- ln -s "$depend_skalibs" compile/move/skalibs
-+ mkdir compile/move/skalibs &&
-+ ln -s "$depend_skalibs/include/skalibs" compile/move/skalibs/include &&
-+ ln -s "$depend_skalibs/lib/skalibs" compile/move/skalibs/library
-+
- }
- find_sums_37() {
- rm -f compile/tmpdir/sums &&
diff --git a/sysutils/runwhen/pkg-plist b/sysutils/runwhen/pkg-plist
deleted file mode 100644
index f052e8c4f036..000000000000
--- a/sysutils/runwhen/pkg-plist
+++ /dev/null
@@ -1,14 +0,0 @@
-bin/caldelay
-bin/delayrun
-bin/maxinterval
-bin/mininterval
-bin/rw-add
-bin/rw-match
-bin/rw-max
-bin/rw-min
-bin/rw-sleep
-bin/rw-sub
-bin/rw-touch
-%%PORTDOCS%%%%DOCSDIR%%/CHANGES
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/TODO