aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@FreeBSD.org>2023-08-07 14:11:06 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-08-09 13:01:15 +0000
commita8c968d1c14439589111420e8a9c8b6fbbcd6976 (patch)
tree2552b5bb3a7ea33ac98de0dc8b84ccff31f9c114
parent96af998c7bff374557fa10236700c94e6171cbb5 (diff)
downloadports-a8c968d1c14439589111420e8a9c8b6fbbcd6976.tar.gz
ports-a8c968d1c14439589111420e8a9c8b6fbbcd6976.zip
archivers/bicom: unbreak fetch
Seems like the original upstream is gone. Retrieve distfile with slightly different checksum from other host. While we are at it, dos2unix-ify port. Reported by: Bryan Baldwin <bryan@katofiad.co.nz>
-rw-r--r--archivers/bicom/Makefile6
-rw-r--r--archivers/bicom/files/patch-bialib_sufftree.h22
2 files changed, 14 insertions, 14 deletions
diff --git a/archivers/bicom/Makefile b/archivers/bicom/Makefile
index efcadf4836cb..8d8d8f9370e2 100644
--- a/archivers/bicom/Makefile
+++ b/archivers/bicom/Makefile
@@ -1,8 +1,7 @@
PORTNAME= bicom
PORTVERSION= 1.01
CATEGORIES= archivers
-MASTER_SITES= http://www3.sympatico.ca/mt0000/bicom/ \
- http://freebsd.nsu.ru/distfiles/
+MASTER_SITES= http://www.mirrorservice.org/pub/minix/distfiles/backup/
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
MAINTAINER= ports@FreeBSD.org
@@ -15,7 +14,8 @@ LICENSE_NAME= bicom
LICENSE_TEXT= Contact author personally regarding commercial use
LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
-USES= zip
+USES= dos2unix zip
+DOS2UNIX_GLOB= *.cpp *.h
NO_WRKSUBDIR= yes
MAKEFILE= ${FILESDIR}/Makefile
diff --git a/archivers/bicom/files/patch-bialib_sufftree.h b/archivers/bicom/files/patch-bialib_sufftree.h
index 2782c4887989..f3eb9d59883a 100644
--- a/archivers/bicom/files/patch-bialib_sufftree.h
+++ b/archivers/bicom/files/patch-bialib_sufftree.h
@@ -1,11 +1,11 @@
---- bialib/sufftree.h.orig 2000-10-26 01:51:04 UTC
-+++ bialib/sufftree.h
-@@ -95,7 +95,7 @@ class SuffixTreeModel : public Arithmeti
- {
- public:
- bool InEdge()
-- {return(r>0);}
-+ {return(r!=NULL);}
- //After Canonize()ing a point, r >0 <=> proj!=0, i.e., point
- //is inside an edge
- INode *ins; //parent of point
+--- bialib/sufftree.h.orig 2000-10-26 01:51:04 UTC
++++ bialib/sufftree.h
+@@ -95,7 +95,7 @@ class SuffixTreeModel : public Arithmeti
+ {
+ public:
+ bool InEdge()
+- {return(r>0);}
++ {return(r!=NULL);}
+ //After Canonize()ing a point, r >0 <=> proj!=0, i.e., point
+ //is inside an edge
+ INode *ins; //parent of point