aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2017-12-12 12:40:15 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2017-12-12 12:40:15 +0000
commita8cc35a10e90f8f79065f49149f25bf73fa3365a (patch)
tree9e9a97b3aab77d2cc63f709a61eb4142ae8b1d83
parentaed3eed595ad638baabb59f48460ea00db3ed680 (diff)
downloadports-a8cc35a10e90f8f79065f49149f25bf73fa3365a.tar.gz
ports-a8cc35a10e90f8f79065f49149f25bf73fa3365a.zip
Notes
-rw-r--r--games/thudboard/Makefile4
-rw-r--r--games/twitch/Makefile2
-rw-r--r--graphics/exact-image/Makefile2
-rw-r--r--graphics/imgv/Makefile6
-rw-r--r--mail/pysieved/Makefile2
-rw-r--r--misc/xdg-menu/Makefile6
-rw-r--r--net-mgmt/py-yapsnmp/Makefile2
-rw-r--r--net/glusterfs/Makefile2
-rw-r--r--net/libproxy-python/Makefile2
-rw-r--r--net/ntlmaps/Makefile2
-rw-r--r--net/polyorb/Makefile2
-rw-r--r--net/py-gntp/Makefile2
-rw-r--r--print/scribus/Makefile6
-rw-r--r--science/ncs/Makefile7
-rw-r--r--security/fsh/Makefile2
-rw-r--r--security/py-trustedpickle/Makefile2
-rw-r--r--sysutils/ganglia-monitor-core/Makefile2
-rw-r--r--sysutils/heartbeat/Makefile2
-rw-r--r--sysutils/isomd5sum/Makefile2
-rw-r--r--sysutils/xen-tools/Makefile2
-rw-r--r--textproc/py-asv/Makefile2
-rw-r--r--x11-fm/gnome-commander2/Makefile2
-rw-r--r--x11/cinnamon/Makefile8
23 files changed, 35 insertions, 36 deletions
diff --git a/games/thudboard/Makefile b/games/thudboard/Makefile
index 327866c4e2c1..0f46e45d7b34 100644
--- a/games/thudboard/Makefile
+++ b/games/thudboard/Makefile
@@ -10,10 +10,10 @@ MASTER_SITES= http://www.million.nl/file/
MAINTAINER= lme@FreeBSD.org
COMMENT= The Discworld Boardgame Board
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR}
NO_WRKSUBDIR= yes
-USES= python
+USES= python:2.7
SUB_FILES= thudboard
diff --git a/games/twitch/Makefile b/games/twitch/Makefile
index 4906e0ae4f83..19cd3a2d1133 100644
--- a/games/twitch/Makefile
+++ b/games/twitch/Makefile
@@ -19,7 +19,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYGAME}
-USES= python
+USES= python:2.7
PORTDOCS= AUTHORS BUGS README
OPTIONS_DEFINE= DOCS
diff --git a/graphics/exact-image/Makefile b/graphics/exact-image/Makefile
index 6a65795e8a92..1a03071151c3 100644
--- a/graphics/exact-image/Makefile
+++ b/graphics/exact-image/Makefile
@@ -29,7 +29,7 @@ BROKEN_armv7= fails to configure: C++ compiler is not installed or does not wor
#hack to get custom exactcode configure script to enable tiff support with
#broken headers on c++ in base system:
CPPFLAGS+= -fpermissive -I${LOCALBASE}/include
-USES= gmake jpeg perl5 pkgconfig python tar:bzip2
+USES= gmake jpeg perl5 pkgconfig python:2.7 tar:bzip2
USE_XORG= x11
HAS_CONFIGURE= yes
INSTALL_WRKSRC= ${WRKSRC}/objdir
diff --git a/graphics/imgv/Makefile b/graphics/imgv/Makefile
index 552b15d997b8..b0d03a4f6f2b 100644
--- a/graphics/imgv/Makefile
+++ b/graphics/imgv/Makefile
@@ -13,15 +13,15 @@ COMMENT= Unique and feature rich Image Viewer
LICENSE= GPLv2
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}game>0:devel/py-game \
- ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow
+RUN_DEPENDS= ${PYGAME} \
+ ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
NO_ARCH= yes
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USES= python:run shebangfix
+USES= python:2.7 shebangfix
SHEBANG_FILES= imgv.py
post-patch:
diff --git a/mail/pysieved/Makefile b/mail/pysieved/Makefile
index 7224dc6a8fe8..ff5a2718b441 100644
--- a/mail/pysieved/Makefile
+++ b/mail/pysieved/Makefile
@@ -14,7 +14,7 @@ COMMENT= Python Managesieve Server
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= python tar:bzip2
+USES= python:2.7 tar:bzip2
USE_RC_SUBR= ${PORTNAME}
NO_ARCH= yes
diff --git a/misc/xdg-menu/Makefile b/misc/xdg-menu/Makefile
index 62364810613d..c348cdb49406 100644
--- a/misc/xdg-menu/Makefile
+++ b/misc/xdg-menu/Makefile
@@ -19,13 +19,13 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/Help/COPYING
RUN_DEPENDS= ${LOCALBASE}/bin/rox:x11-fm/rox-filer \
- ${PYTHON_PKGNAMEPREFIX}xdg>=0:devel/py-xdg \
- ${PYTHON_PKGNAMEPREFIX}dbus>=0:devel/py-dbus
+ ${PYTHON_PKGNAMEPREFIX}xdg>=0:devel/py-xdg@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dbus>=0:devel/py-dbus@${PY_FLAVOR}
WRKSRC= ${WRKDIR}/XDG-Menu
DATADIR= ${PREFIX}/apps/XDG-Menu
-USES= python shebangfix
+USES= python:2.7 shebangfix
SHEBANG_FILES= AppRun AppletRun
INSTALLS_ICONS= yes
NO_ARCH= yes
diff --git a/net-mgmt/py-yapsnmp/Makefile b/net-mgmt/py-yapsnmp/Makefile
index 6f9e39588d75..51c27bdabd76 100644
--- a/net-mgmt/py-yapsnmp/Makefile
+++ b/net-mgmt/py-yapsnmp/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libnetsnmp.so:net-mgmt/net-snmp
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gmake libtool python
+USES= gmake libtool python:2.7
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include -I${PYTHON_INCLUDEDIR}
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/net/glusterfs/Makefile b/net/glusterfs/Makefile
index 21fc7aa2d7e8..5448b9301ca3 100644
--- a/net/glusterfs/Makefile
+++ b/net/glusterfs/Makefile
@@ -14,7 +14,7 @@ LICENSE_COMB= dual
LIB_DEPENDS= libargp.so:devel/argp-standalone liburcu-bp.so:sysutils/liburcu
-USES= bison gettext libtool pkgconfig python readline shebangfix \
+USES= bison gettext libtool pkgconfig python:2.7 readline shebangfix \
sqlite ssl
BROKEN_SSL= libressl
diff --git a/net/libproxy-python/Makefile b/net/libproxy-python/Makefile
index bbd404c8e800..4e04222ac4bc 100644
--- a/net/libproxy-python/Makefile
+++ b/net/libproxy-python/Makefile
@@ -18,7 +18,7 @@ PLIST= ${.CURDIR}/pkg-plist
INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}/bindings/python
NO_ARCH= yes
NO_BUILD= yes
-USES= python
+USES= python:2.7
LIBPROXY_SLAVE= python
diff --git a/net/ntlmaps/Makefile b/net/ntlmaps/Makefile
index e22698450d1d..e85c35c10317 100644
--- a/net/ntlmaps/Makefile
+++ b/net/ntlmaps/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= kevlo@FreeBSD.org
COMMENT= Proxy that authenticates the user using the NTLM protocol
-USES= dos2unix python
+USES= dos2unix python:2.7
DOCS= COPYING Install.txt changelog.txt readme.txt research.txt
diff --git a/net/polyorb/Makefile b/net/polyorb/Makefile
index afda8424df4b..3e7076f62ca1 100644
--- a/net/polyorb/Makefile
+++ b/net/polyorb/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv3
BUILD_DEPENDS= xmlada>=3.2:textproc/xmlada
-USES= ada gmake python:build shebangfix
+USES= ada gmake python:2.7,build shebangfix
GNU_CONFIGURE= yes
NO_MTREE= yes
YEAR= 2014
diff --git a/net/py-gntp/Makefile b/net/py-gntp/Makefile
index f832cc549407..1b7daba758f0 100644
--- a/net/py-gntp/Makefile
+++ b/net/py-gntp/Makefile
@@ -23,7 +23,7 @@ USE_PYTHON= distutils autoplist
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MDOCS}
-BUILD_DEPENDS+= sphinx-build:textproc/py-sphinx
+BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sphinx>=0:textproc/py-sphinx@${FLAVOR}
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
PYDISTUTILS_BUILD_TARGET+= build_sphinx
diff --git a/print/scribus/Makefile b/print/scribus/Makefile
index c8fff6bda1b5..394ae9cfb36a 100644
--- a/print/scribus/Makefile
+++ b/print/scribus/Makefile
@@ -24,13 +24,13 @@ LIB_DEPENDS= liblcms.so:graphics/lcms \
libcairo.so:graphics/cairo \
libhyphen.so:textproc/hyphen \
libfontconfig.so:x11-fonts/fontconfig
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter \
- ${PYTHON_SITELIBDIR}/PIL/_imaging.so:graphics/py-pillow
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow@${PY_FLAVOR}
USE_QT4= corelib gui linguist_build moc_build qmake_build rcc_build uic_build xml network
USE_GNOME= libartlgpl2 libxml2
USES= cmake:outsource desktop-file-utils ghostscript:run jpeg \
- pkgconfig python shared-mime-info tar:xz
+ pkgconfig python:2.7 shared-mime-info tar:xz
USE_LDCONFIG= yes
CMAKE_ARGS+= -DWANT_HUNSPELL=YES -Wno-ferror-limit
diff --git a/science/ncs/Makefile b/science/ncs/Makefile
index a4d0bba911d5..a7bd7c710452 100644
--- a/science/ncs/Makefile
+++ b/science/ncs/Makefile
@@ -12,8 +12,7 @@ COMMENT= Code_Saturne Kernel
LICENSE= GPLv2
-BUILD_DEPENDS= cs_preprocess:science/ecs \
- pyrcc4:textproc/py-qt4-xml
+BUILD_DEPENDS= cs_preprocess:science/ecs
LIB_DEPENDS= libfvm.so:science/fvm \
libmei.so:science/mei
RUN_DEPENDS= xmgrace:math/grace \
@@ -21,9 +20,9 @@ RUN_DEPENDS= xmgrace:math/grace \
xterm:x11/xterm \
cs_preprocess:science/ecs
-USES= fortran gettext gmake iconv libtool pyqt:4 python shebangfix
+USES= fortran gettext gmake iconv libtool pyqt:4 python:2.7 shebangfix
USE_GNOME= libxml2
-USE_PYQT= core
+USE_PYQT= core xml_build
SHEBANG_FILES= bin/runcase.in
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libxml2
GNU_CONFIGURE= yes
diff --git a/security/fsh/Makefile b/security/fsh/Makefile
index 9f22b1a3aa78..884a186875d5 100644
--- a/security/fsh/Makefile
+++ b/security/fsh/Makefile
@@ -12,7 +12,7 @@ MASTER_SITES= http://www.lysator.liu.se/fsh/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Fast remote command execution
-USES= python
+USES= python:2.7
GNU_CONFIGURE= yes
INFO= fsh
diff --git a/security/py-trustedpickle/Makefile b/security/py-trustedpickle/Makefile
index e5cd66ba4f90..aababad72e46 100644
--- a/security/py-trustedpickle/Makefile
+++ b/security/py-trustedpickle/Makefile
@@ -13,7 +13,7 @@ COMMENT= TrustedPickle is a Python (de)Pickler with a way to verify the data
LICENSE= BSD2CLAUSE
-USES= dos2unix python tar:tgz
+USES= dos2unix python:2.7 tar:tgz
NO_ARCH= yes
PLIST_FILES= %%PYTHON_SITELIBDIR%%/TrustedPickle.py \
diff --git a/sysutils/ganglia-monitor-core/Makefile b/sysutils/ganglia-monitor-core/Makefile
index b2c78f0b3b55..44f7ae1e6818 100644
--- a/sysutils/ganglia-monitor-core/Makefile
+++ b/sysutils/ganglia-monitor-core/Makefile
@@ -25,7 +25,7 @@ OPTIONS_DEFINE= GMETAD
OPTIONS_DEFAULT= GMETAD
GMETAD_DESC= include gmetad
-USES= libtool pkgconfig python
+USES= libtool pkgconfig python:2.7
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-setuid=ganglia --enable-setgid=ganglia \
diff --git a/sysutils/heartbeat/Makefile b/sysutils/heartbeat/Makefile
index 3b6641bfcaf2..8d817ab0790b 100644
--- a/sysutils/heartbeat/Makefile
+++ b/sysutils/heartbeat/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= libltdl.so:devel/libltdl \
libxml2.so:textproc/libxml2
BUILD_DEPENDS= bison:devel/bison
-USES= autoreconf cpe gettext gmake libtool perl5 pkgconfig python tar:bzip2 \
+USES= autoreconf cpe gettext gmake libtool perl5 pkgconfig python:2.7 tar:bzip2 \
shebangfix
SHEBANG_FILES= ldirectord/ldirectord.in \
lib/plugins/stonith/external/ibmrsa-telnet \
diff --git a/sysutils/isomd5sum/Makefile b/sysutils/isomd5sum/Makefile
index 42a398b660fc..cb49f9bd9081 100644
--- a/sysutils/isomd5sum/Makefile
+++ b/sysutils/isomd5sum/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libpopt.so:devel/popt
-USES= gmake python
+USES= gmake python:2.7
USE_GITHUB= yes
GH_ACCOUNT= rhinstaller
diff --git a/sysutils/xen-tools/Makefile b/sysutils/xen-tools/Makefile
index 52ce43c51ccf..4b394dd62062 100644
--- a/sysutils/xen-tools/Makefile
+++ b/sysutils/xen-tools/Makefile
@@ -29,7 +29,7 @@ ONLY_FOR_ARCHS= amd64
ONLY_FOR_ARCHS_REASON= "not yet ported to anything other than amd64"
USES= cpe gettext gmake libtool localbase:ldflags perl5 pkgconfig \
- python shebangfix
+ python:2.7 shebangfix
USE_GNOME= glib20
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/textproc/py-asv/Makefile b/textproc/py-asv/Makefile
index e947516b43f3..4e3802c99150 100644
--- a/textproc/py-asv/Makefile
+++ b/textproc/py-asv/Makefile
@@ -13,7 +13,7 @@ COMMENT= Extensible Python module to parse simple text file formats like CSV
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= python
+USES= python:2.7
NO_ARCH= yes
PORTDOCS= README THANKS
diff --git a/x11-fm/gnome-commander2/Makefile b/x11-fm/gnome-commander2/Makefile
index 094d999a39e8..d673fcc845e6 100644
--- a/x11-fm/gnome-commander2/Makefile
+++ b/x11-fm/gnome-commander2/Makefile
@@ -25,7 +25,7 @@ RUN_DEPENDS= meld:textproc/meld \
yelp:x11/yelp
USES= compiler:c++11-lang gettext gmake libtool localbase:ldflags pathfix \
- pkgconfig python tar:xz
+ pkgconfig python:2.7 tar:xz
USE_GNOME= cairo gdkpixbuf2 gnomedocutils gnomeprefix gnomevfs2 intltool libgnomeui
USE_XORG= ice sm
GNU_CONFIGURE= yes
diff --git a/x11/cinnamon/Makefile b/x11/cinnamon/Makefile
index 94f51d211f80..745bdfad9131 100644
--- a/x11/cinnamon/Makefile
+++ b/x11/cinnamon/Makefile
@@ -25,18 +25,18 @@ LIB_DEPENDS= libstartup-notification-1.so:x11/startup-notification \
libcjs.so:lang/cjs \
libcinnamon-menu-3.so:x11/cinnamon-menus \
libaccountsservice.so:sysutils/accountsservice
-RUN_DEPENDS= py*-dbus>=0:devel/py-dbus \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0:devel/py-dbus@${PY_FLAVOR} \
ca_root_nss>=0:security/ca_root_nss \
gnome-themes-standard>=3.0.0:x11-themes/gnome-themes-standard \
cinnamon-control-center:sysutils/cinnamon-control-center \
cinnamon-translations>=0:misc/cinnamon-translations \
cinnamon-screensaver:x11/cinnamon-screensaver \
nemo:x11-fm/nemo \
- py*-pillow>=0:graphics/py-pillow \
- py*-lxml>=0:devel/py-lxml
+ ${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml@${PY_FLAVOR}
USES= autoreconf compiler:c11 gettext gmake libtool \
- pathfix pkgconfig python shebangfix
+ pathfix pkgconfig python:2.7 shebangfix
USE_GNOME= evolutiondataserver3 gconf2 gnomedesktop3 \
gnomeprefix gtk30 intlhack introspection:build