aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-10-07 10:11:57 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-10-07 10:11:57 +0000
commita9b6ccfa273b4ee82c30f2cec099c84304361902 (patch)
tree22a947eb2833ff03b5bdbb7f737f06ba514bbf20
parent8236e4cf2b28ced2dd4f1bee7ab706e26a78f442 (diff)
downloadports-a9b6ccfa273b4ee82c30f2cec099c84304361902.tar.gz
ports-a9b6ccfa273b4ee82c30f2cec099c84304361902.zip
Notes
-rw-r--r--www/qupzilla/Makefile16
-rw-r--r--www/qupzilla/distinfo4
-rw-r--r--www/qupzilla/files/patch-src__lib__3rdparty__processinfo.h12
-rw-r--r--www/qupzilla/files/patch-src__main__main.pro11
-rw-r--r--www/qupzilla/pkg-plist135
5 files changed, 81 insertions, 97 deletions
diff --git a/www/qupzilla/Makefile b/www/qupzilla/Makefile
index 66e6b2dc78ac..f5089e401c09 100644
--- a/www/qupzilla/Makefile
+++ b/www/qupzilla/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= qupzilla
-PORTVERSION= 1.6.6
-PORTREVISION= 1
+PORTVERSION= 1.8.0
CATEGORIES= www
MASTER_SITES= https://github.com/QupZilla/${PORTNAME}/releases/download/v${PORTVERSION}/
DISTNAME= QupZilla-${PORTVERSION}
@@ -16,13 +15,14 @@ LIB_DEPENDS= libhunspell-1.3.so:${PORTSDIR}/textproc/hunspell \
libexecinfo.so:${PORTSDIR}/devel/libexecinfo
USES= desktop-file-utils pkgconfig qmake tar:xz
-USE_QT4= gui moc_build rcc_build uic_build webkit \
- dbus xml script sql network imageformats_run linguist_build
+USE_QT4= corelib gui moc_build rcc_build uic_build webkit \
+ xml script sql network imageformats_run linguist_build
QMAKE_ENV= QUPZILLA_PREFIX=${PREFIX}/
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
-OPTIONS_DEFINE= GNOMEKEYRING KWALLET
+OPTIONS_DEFINE= DBUS GNOMEKEYRING KWALLET
+OPTIONS_DEFAULT=DBUS
OPTIONS_SUB= yes
.include <bsd.port.options.mk>
@@ -37,6 +37,12 @@ LIB_DEPENDS+= libkdeui.so:${PORTSDIR}/x11/kdelibs4
QMAKE_ENV+= KDE_INTEGRATION="true"
.endif
+.if ${PORT_OPTIONS:MDBUS}
+USE_QT4+= dbus
+.else
+QMAKE_ENV+= DISABLE_DBUS="true"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr|${LOCALBASE}|g' \
${WRKSRC}/tests/autotests/qztoolstest.cpp \
diff --git a/www/qupzilla/distinfo b/www/qupzilla/distinfo
index 099ed6479253..d3e0e558d11f 100644
--- a/www/qupzilla/distinfo
+++ b/www/qupzilla/distinfo
@@ -1,2 +1,2 @@
-SHA256 (QupZilla-1.6.6.tar.xz) = 82597a18fff789ddb92bdf21fb46a1f85c0003813f89c7462269c6aa11ef0fc9
-SIZE (QupZilla-1.6.6.tar.xz) = 3162916
+SHA256 (QupZilla-1.8.0.tar.xz) = c4089d14254e87b58a5f2bfb0e393cd6bae0b2bd508da19a92c12989b7e90908
+SIZE (QupZilla-1.8.0.tar.xz) = 3092300
diff --git a/www/qupzilla/files/patch-src__lib__3rdparty__processinfo.h b/www/qupzilla/files/patch-src__lib__3rdparty__processinfo.h
index 12c8d38cf089..1960ad34c8f2 100644
--- a/www/qupzilla/files/patch-src__lib__3rdparty__processinfo.h
+++ b/www/qupzilla/files/patch-src__lib__3rdparty__processinfo.h
@@ -1,11 +1,11 @@
---- ./src/lib/3rdparty/processinfo.h.orig 2014-01-26 19:04:16.000000000 +0330
-+++ ./src/lib/3rdparty/processinfo.h 2014-01-26 19:04:33.000000000 +0330
+--- src/lib/3rdparty/processinfo.h.orig 2014-09-26 12:35:35.000000000 +0400
++++ src/lib/3rdparty/processinfo.h 2014-09-26 23:04:10.000000000 +0400
@@ -18,6 +18,8 @@
#ifndef PROCESSINFO_H
#define PROCESSINFO_H
-+#include <unistd.h>
++#include <QtGlobal>
+
- #include <QString>
-
- #include "qz_namespace.h"
+ #if defined(Q_OS_UNIX) && !defined(Q_OS_MAC)
+ #include <sys/types.h>
+ #endif
diff --git a/www/qupzilla/files/patch-src__main__main.pro b/www/qupzilla/files/patch-src__main__main.pro
deleted file mode 100644
index 7c5497547126..000000000000
--- a/www/qupzilla/files/patch-src__main__main.pro
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/main/main.pro.orig 2014-01-26 16:37:39.000000000 +0330
-+++ ./src/main/main.pro 2014-01-26 16:38:07.000000000 +0330
-@@ -10,7 +10,7 @@
- TEMPLATE = app
-
- !unix|mac: LIBS += -L../../bin -lQupZilla
--!mac:unix: LIBS += ../../bin/libQupZilla.so
-+!mac:unix: LIBS += ../../bin/libQupZilla.so -lexecinfo
-
- include(../defines.pri)
- include(../install.pri)
diff --git a/www/qupzilla/pkg-plist b/www/qupzilla/pkg-plist
index 841a1bee0a69..2dcb3e76a2a4 100644
--- a/www/qupzilla/pkg-plist
+++ b/www/qupzilla/pkg-plist
@@ -1,8 +1,8 @@
bin/qupzilla
lib/libQupZilla.so
lib/libQupZilla.so.1
-lib/libQupZilla.so.1.6
-lib/libQupZilla.so.1.6.6
+lib/libQupZilla.so.1.8
+lib/libQupZilla.so.1.8.0
lib/qupzilla/libAccessKeysNavigation.so
lib/qupzilla/libAutoScroll.so
%%GNOMEKEYRING%%lib/qupzilla/libGnomeKeyringPasswords.so
@@ -11,6 +11,7 @@ lib/qupzilla/libGreaseMonkey.so
lib/qupzilla/libMouseGestures.so
lib/qupzilla/libPIM.so
lib/qupzilla/libStatusBarIcons.so
+share/appdata/qupzilla.appdata.xml
share/applications/qupzilla.desktop
share/bash-completion/completions/qupzilla
share/icons/hicolor/128x128/apps/qupzilla.png
@@ -31,9 +32,11 @@ share/pixmaps/qupzilla.png
%%DATADIR%%/locale/es_VE.qm
%%DATADIR%%/locale/eu_ES.qm
%%DATADIR%%/locale/fa_IR.qm
+%%DATADIR%%/locale/fi_FI.qm
%%DATADIR%%/locale/fr_FR.qm
%%DATADIR%%/locale/gl_ES.qm
%%DATADIR%%/locale/he_IL.qm
+%%DATADIR%%/locale/hr_HR.qm
%%DATADIR%%/locale/hu_HU.qm
%%DATADIR%%/locale/id_ID.qm
%%DATADIR%%/locale/it_IT.qm
@@ -46,48 +49,67 @@ share/pixmaps/qupzilla.png
%%DATADIR%%/locale/pl_PL.qm
%%DATADIR%%/locale/pt_BR.qm
%%DATADIR%%/locale/pt_PT.qm
-%%DATADIR%%/locale/qt_ar.qm
%%DATADIR%%/locale/qt_ca.qm
-%%DATADIR%%/locale/qt_cs.qm
-%%DATADIR%%/locale/qt_da.qm
-%%DATADIR%%/locale/qt_de.qm
%%DATADIR%%/locale/qt_el.qm
-%%DATADIR%%/locale/qt_es.qm
-%%DATADIR%%/locale/qt_eu.qm
-%%DATADIR%%/locale/qt_fa.qm
-%%DATADIR%%/locale/qt_fr.qm
-%%DATADIR%%/locale/qt_gl.qm
-%%DATADIR%%/locale/qt_he.qm
-%%DATADIR%%/locale/qt_hu.qm
-%%DATADIR%%/locale/qt_it.qm
-%%DATADIR%%/locale/qt_ja.qm
%%DATADIR%%/locale/qt_nl.qm
-%%DATADIR%%/locale/qt_pl.qm
-%%DATADIR%%/locale/qt_pt.qm
-%%DATADIR%%/locale/qt_ru.qm
-%%DATADIR%%/locale/qt_sk.qm
-%%DATADIR%%/locale/qt_sr_BA.qm
-%%DATADIR%%/locale/qt_sr_BA@latin.qm
-%%DATADIR%%/locale/qt_sr_RS.qm
-%%DATADIR%%/locale/qt_sr_RS@latin.qm
-%%DATADIR%%/locale/qt_sv.qm
-%%DATADIR%%/locale/qt_uk.qm
-%%DATADIR%%/locale/qt_zh_CN.qm
-%%DATADIR%%/locale/qt_zh_TW.qm
+%%DATADIR%%/locale/qt_sr.qm
+%%DATADIR%%/locale/qt_sr@ijekavian.qm
+%%DATADIR%%/locale/qt_sr@ijekavianlatin.qm
+%%DATADIR%%/locale/qt_sr@latin.qm
%%DATADIR%%/locale/ro_RO.qm
%%DATADIR%%/locale/ru_RU.qm
%%DATADIR%%/locale/sk_SK.qm
-%%DATADIR%%/locale/sr_BA.qm
-%%DATADIR%%/locale/sr_BA@latin.qm
-%%DATADIR%%/locale/sr_RS.qm
-%%DATADIR%%/locale/sr_RS@latin.qm
+%%DATADIR%%/locale/sr.qm
+%%DATADIR%%/locale/sr@ijekavian.qm
+%%DATADIR%%/locale/sr@ijekavianlatin.qm
+%%DATADIR%%/locale/sr@latin.qm
%%DATADIR%%/locale/sv_SE.qm
+%%DATADIR%%/locale/tr_TR.qm
%%DATADIR%%/locale/uk_UA.qm
%%DATADIR%%/locale/uz@Latn.qm
%%DATADIR%%/locale/zh_CN.qm
%%DATADIR%%/locale/zh_TW.qm
-%%DATADIR%%/themes/chrome/images/blankbutton-a.png
-%%DATADIR%%/themes/chrome/images/blankbutton-h.png
+%%DATADIR%%/themes/breathe/images/add.png
+%%DATADIR%%/themes/breathe/images/find.png
+%%DATADIR%%/themes/breathe/images/flash.png
+%%DATADIR%%/themes/breathe/images/flashstart.png
+%%DATADIR%%/themes/breathe/images/goto.png
+%%DATADIR%%/themes/breathe/images/home.png
+%%DATADIR%%/themes/breathe/images/library-bg-left.png
+%%DATADIR%%/themes/breathe/images/library-bg-top-right.png
+%%DATADIR%%/themes/breathe/images/library-bg-top.png
+%%DATADIR%%/themes/breathe/images/library-search-bg.png
+%%DATADIR%%/themes/breathe/images/lineedit-bg.png
+%%DATADIR%%/themes/breathe/images/login.png
+%%DATADIR%%/themes/breathe/images/menu.png
+%%DATADIR%%/themes/breathe/images/navigation-dropdown.png
+%%DATADIR%%/themes/breathe/images/next.png
+%%DATADIR%%/themes/breathe/images/previous.png
+%%DATADIR%%/themes/breathe/images/reload.png
+%%DATADIR%%/themes/breathe/images/restore.png
+%%DATADIR%%/themes/breathe/images/rss.png
+%%DATADIR%%/themes/breathe/images/semi-transp.png
+%%DATADIR%%/themes/breathe/images/siteicon-bg-a.png
+%%DATADIR%%/themes/breathe/images/siteicon-bg-h.png
+%%DATADIR%%/themes/breathe/images/siteicon-bg.png
+%%DATADIR%%/themes/breathe/images/siteicon-secure-bg-a.png
+%%DATADIR%%/themes/breathe/images/siteicon-secure-bg-h.png
+%%DATADIR%%/themes/breathe/images/siteicon-secure-bg.png
+%%DATADIR%%/themes/breathe/images/star-a.png
+%%DATADIR%%/themes/breathe/images/star.png
+%%DATADIR%%/themes/breathe/images/stop.png
+%%DATADIR%%/themes/breathe/images/tab-left.png
+%%DATADIR%%/themes/breathe/images/tab-right.png
+%%DATADIR%%/themes/breathe/images/tabs-list.png
+%%DATADIR%%/themes/breathe/images/transp.png
+%%DATADIR%%/themes/breathe/images/trash.png
+%%DATADIR%%/themes/breathe/images/websearch-bg-a.png
+%%DATADIR%%/themes/breathe/images/websearch-bg-h.png
+%%DATADIR%%/themes/breathe/images/websearch-bg.png
+%%DATADIR%%/themes/breathe/main.css
+%%DATADIR%%/themes/breathe/rtl.css
+%%DATADIR%%/themes/breathe/theme.info
+%%DATADIR%%/themes/breathe/theme.png
%%DATADIR%%/themes/chrome/images/flash.png
%%DATADIR%%/themes/chrome/images/flashstart.png
%%DATADIR%%/themes/chrome/images/gotoaddress.png
@@ -119,7 +141,9 @@ share/pixmaps/qupzilla.png
%%DATADIR%%/themes/chrome/images/tabs-bg.png
%%DATADIR%%/themes/chrome/images/tabs-list-button.png
%%DATADIR%%/themes/chrome/images/toolbar-bg.png
-%%DATADIR%%/themes/chrome/images/transp.png
+%%DATADIR%%/themes/chrome/images/toolbutton-a.png
+%%DATADIR%%/themes/chrome/images/toolbutton-h.png
+%%DATADIR%%/themes/chrome/images/toolbutton.png
%%DATADIR%%/themes/chrome/linux.css
%%DATADIR%%/themes/chrome/main.css
%%DATADIR%%/themes/chrome/rtl.css
@@ -155,27 +179,21 @@ share/pixmaps/qupzilla.png
%%DATADIR%%/themes/default/images/tab-right-arrow.png
%%DATADIR%%/themes/default/images/tabs-list-button.png
%%DATADIR%%/themes/default/images/transp.png
+%%DATADIR%%/themes/default/images/websearchbar-bg.png
%%DATADIR%%/themes/default/main.css
%%DATADIR%%/themes/default/rtl.css
%%DATADIR%%/themes/default/theme.info
%%DATADIR%%/themes/default/theme.png
%%DATADIR%%/themes/default/windows.css
-%%DATADIR%%/themes/linux/images/edit-find.png
%%DATADIR%%/themes/linux/images/flash.png
%%DATADIR%%/themes/linux/images/flashstart.png
-%%DATADIR%%/themes/linux/images/go-home.png
-%%DATADIR%%/themes/linux/images/go-next.png
-%%DATADIR%%/themes/linux/images/go-previous.png
-%%DATADIR%%/themes/linux/images/gotoaddress.png
%%DATADIR%%/themes/linux/images/key.png
%%DATADIR%%/themes/linux/images/library-bg-left.png
%%DATADIR%%/themes/linux/images/library-bg-top-right.png
%%DATADIR%%/themes/linux/images/library-bg-top.png
%%DATADIR%%/themes/linux/images/library-search-bg.png
-%%DATADIR%%/themes/linux/images/list-add.png
+%%DATADIR%%/themes/linux/images/menu.png
%%DATADIR%%/themes/linux/images/navigation-dropdown.png
-%%DATADIR%%/themes/linux/images/preferences-desktop.png
-%%DATADIR%%/themes/linux/images/process-stop.png
%%DATADIR%%/themes/linux/images/rss.png
%%DATADIR%%/themes/linux/images/semi-transp.png
%%DATADIR%%/themes/linux/images/star-a.png
@@ -184,7 +202,6 @@ share/pixmaps/qupzilla.png
%%DATADIR%%/themes/linux/images/tab-right-arrow.png
%%DATADIR%%/themes/linux/images/tabs-list-button.png
%%DATADIR%%/themes/linux/images/transp.png
-%%DATADIR%%/themes/linux/images/view-refresh.png
%%DATADIR%%/themes/linux/images/websearch-bg.png
%%DATADIR%%/themes/linux/main.css
%%DATADIR%%/themes/linux/rtl.css
@@ -224,6 +241,7 @@ share/pixmaps/qupzilla.png
%%DATADIR%%/themes/mac/images/tabs-list-button_rtl.png
%%DATADIR%%/themes/mac/images/toolbar-bg.png
%%DATADIR%%/themes/mac/images/transp.png
+%%DATADIR%%/themes/mac/images/user-trash-full.png
%%DATADIR%%/themes/mac/linux.css
%%DATADIR%%/themes/mac/main.css
%%DATADIR%%/themes/mac/rtl.css
@@ -268,6 +286,7 @@ share/pixmaps/qupzilla.png
%%DATADIR%%/themes/windows/images/tabs-list-button.png
%%DATADIR%%/themes/windows/images/toolbar-bg.png
%%DATADIR%%/themes/windows/images/transp.png
+%%DATADIR%%/themes/windows/images/user-trash-full.png
%%DATADIR%%/themes/windows/linux.css
%%DATADIR%%/themes/windows/main.css
%%DATADIR%%/themes/windows/rtl.css
@@ -275,33 +294,3 @@ share/pixmaps/qupzilla.png
%%DATADIR%%/themes/windows/theme.license
%%DATADIR%%/themes/windows/theme.png
%%DATADIR%%/themes/windows/windows.css
-@dirrmtry %%DATADIR%%/themes/windows/images
-@dirrmtry %%DATADIR%%/themes/windows
-@dirrmtry %%DATADIR%%/themes/mac/images
-@dirrmtry %%DATADIR%%/themes/mac
-@dirrmtry %%DATADIR%%/themes/linux/images
-@dirrmtry %%DATADIR%%/themes/linux
-@dirrmtry %%DATADIR%%/themes/default/images
-@dirrmtry %%DATADIR%%/themes/default
-@dirrmtry %%DATADIR%%/themes/chrome/images
-@dirrmtry %%DATADIR%%/themes/chrome
-@dirrmtry %%DATADIR%%/themes
-@dirrmtry %%DATADIR%%/locale
-@dirrmtry %%DATADIR%%
-@dirrmtry share/icons/hicolor/64x64/apps
-@dirrmtry share/icons/hicolor/64x64
-@dirrmtry share/icons/hicolor/48x48/apps
-@dirrmtry share/icons/hicolor/48x48
-@dirrmtry share/icons/hicolor/32x32/apps
-@dirrmtry share/icons/hicolor/32x32
-@dirrmtry share/icons/hicolor/256x256/apps
-@dirrmtry share/icons/hicolor/256x256
-@dirrmtry share/icons/hicolor/16x16/apps
-@dirrmtry share/icons/hicolor/16x16
-@dirrmtry share/icons/hicolor/128x128/apps
-@dirrmtry share/icons/hicolor/128x128
-@dirrmtry share/icons/hicolor
-@dirrmtry share/icons
-@dirrmtry share/bash-completion/completions
-@dirrmtry share/bash-completion
-@dirrmtry lib/qupzilla