aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2017-05-29 13:50:20 +0000
committerBen Woods <woodsb02@FreeBSD.org>2017-05-29 13:50:20 +0000
commitaac5c98a377cf554d3bc524199b084963b24a75f (patch)
tree21312f2bf8cfa7324c7eb7fda287ac9ed077cd33
parentaf93c1cae32e0ab946518f14ff9ccc132e081e4d (diff)
Notes
-rw-r--r--misc/mc/Makefile12
-rw-r--r--misc/mc/files/extra-patch-src_diffviewer_ydiff.c11
2 files changed, 21 insertions, 2 deletions
diff --git a/misc/mc/Makefile b/misc/mc/Makefile
index 45ba5d63d039..2c1cbe9d313d 100644
--- a/misc/mc/Makefile
+++ b/misc/mc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mc
PORTVERSION= 4.8.19
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc shells
MASTER_SITES= http://ftp.midnight-commander.org/ \
http://ftp.osuosl.org/pub/midnightcommander/
@@ -20,6 +20,7 @@ SHEBANG_FILES= misc/mcedit.menu.in configure configure.ac \
${WRKSRC}/src/vfs/extfs/helpers/Makefile.in \
${WRKSRC}/src/vfs/extfs/helpers/s3+.in \
${WRKSRC}/src/vfs/extfs/helpers/uc1541.in
+python_CMD= ${LOCALBASE}/bin/python2
python_OLD_CMD= @PYTHON@
USE_GNOME= glib20
GNU_CONFIGURE= yes
@@ -90,4 +91,11 @@ post-install-X11-on:
${STAGEDIR}${PREFIX}/share/pixmaps/
${INSTALL_DATA} ${FILESDIR}/${PORTNAME}.desktop ${STAGEDIR}${DESKTOPDIR}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200030
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-src_diffviewer_ydiff.c
+RUN_DEPENDS= gdiff:textproc/diffutils
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/misc/mc/files/extra-patch-src_diffviewer_ydiff.c b/misc/mc/files/extra-patch-src_diffviewer_ydiff.c
new file mode 100644
index 000000000000..988d45e447a5
--- /dev/null
+++ b/misc/mc/files/extra-patch-src_diffviewer_ydiff.c
@@ -0,0 +1,11 @@
+--- src/diffviewer/ydiff.c.orig 2017-03-04 20:51:38 UTC
++++ src/diffviewer/ydiff.c
+@@ -816,7 +816,7 @@ dff_execute (const char *args, const char *extra, cons
+ /* escape potential $ to avoid shell variable substitutions in popen() */
+ file1_esc = strutils_shell_escape (file1);
+ file2_esc = strutils_shell_escape (file2);
+- cmd = g_strdup_printf ("diff %s %s %s %s %s", args, extra, opt, file1_esc, file2_esc);
++ cmd = g_strdup_printf ("gdiff %s %s %s %s %s", args, extra, opt, file1_esc, file2_esc);
+ g_free (file1_esc);
+ g_free (file2_esc);
+