aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-03-02 22:50:29 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-03-02 22:50:29 +0000
commitab03a81b568ef78076607365d1c2a81f7174d82a (patch)
treecacc7430cd0c3b2e1483c01ea2efb8c9bfe62599
parente69948e6a5a295ec483b967c65051896d3b8d2a5 (diff)
Notes
-rw-r--r--net-p2p/transmission-cli/Makefile64
-rw-r--r--net-p2p/transmission-cli/distinfo4
-rw-r--r--net-p2p/transmission-cli/files/patch-fix_without_ipv614
-rw-r--r--net-p2p/transmission-cli/files/patch-libtransmission_upnp.c18
-rw-r--r--net-p2p/transmission-cli/files/patch-qt-app-h4
-rw-r--r--net-p2p/transmission-cli/files/patch-qt-mainwin.cc24
-rw-r--r--net-p2p/transmission-cli/files/patch-qt_qtr_pro8
-rw-r--r--net-p2p/transmission-daemon/Makefile2
-rw-r--r--net-p2p/transmission-gtk/Makefile2
-rw-r--r--net-p2p/transmission-qt4/Makefile6
-rw-r--r--www/transmission-web/Makefile1
11 files changed, 53 insertions, 94 deletions
diff --git a/net-p2p/transmission-cli/Makefile b/net-p2p/transmission-cli/Makefile
index af820e2906b1..61396206ef7f 100644
--- a/net-p2p/transmission-cli/Makefile
+++ b/net-p2p/transmission-cli/Makefile
@@ -1,14 +1,14 @@
# $FreeBSD$
PORTNAME= transmission
-PORTVERSION= 2.84
-PORTREVISION?= 4
+PORTVERSION= 2.90
+PORTREVISION?= 0
CATEGORIES?= net-p2p
#MASTER_SITES= http://download.m0k.org/${PORTNAME}/files/
MASTER_SITES= http://transmission.cachefly.net/
PKGNAMESUFFIX?= -cli
-MAINTAINER?= jbeich@FreeBSD.org
+MAINTAINER?= crees@FreeBSD.org
COMMENT?= Lightweight CLI (command line) BitTorrent client and utilities
SLAVEPORT?= cli
@@ -25,14 +25,14 @@ CPE_VENDOR= transmissionbt
CONFLICTS_INSTALL= ${PORTNAME}${PKGNAMESUFFIX}-2.5*
-OPTIONS_DEFINE= LITE DOCS
EXTRACT_AFTER_ARGS=--no-same-owner --no-same-permissions --exclude third-party
.if ${SLAVEPORT} != web
LIB_DEPENDS?= ${GEN_LIB_DEPENDS}
# General dependencies
-GEN_LIB_DEPENDS=libcurl.so:${PORTSDIR}/ftp/curl \
+GEN_LIB_DEPENDS=libb64.so:${PORTSDIR}/converters/libb64 \
+ libcurl.so:${PORTSDIR}/ftp/curl \
libdht.so:${PORTSDIR}/devel/jech-dht \
libminiupnpc.so:${PORTSDIR}/net/miniupnpc \
libnatpmp.so:${PORTSDIR}/net/libnatpmp \
@@ -42,22 +42,15 @@ GEN_RUN_DEPENDS=${LOCALBASE}/share/transmission/web/index.html:${PORTSDIR}/www/t
# This is master port of transmission-*, so don't override USES definition
USES+= gmake iconv libtool localbase pkgconfig
-USE_OPENSSL= yes
GNU_CONFIGURE= yes
-CPPFLAGS+= -DWITH_UTP=1
LIBS+= ${ICONV_LIB}
-CONFIGURE_ARGS=--with-zlib=/usr \
- --without-inotify \
- --disable-utp \
- --enable-external-natpmp \
+CONFIGURE_ENV= ZLIB_CFLAGS=" " ZLIB_LIBS="-lz" \
+ ${ICONV_LIB:C@.+@ac_cv_func_iconv=yes@}
+CONFIGURE_ARGS= --without-inotify \
+ --enable-external-b64 \
+ --enable-external-dht \
+ --enable-external-natpmp \
${EXTRA_CONF_ARGS}
-CONFIGURE_ENV= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
- OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto" \
- DHT_CFLAGS=" " \
- DHT_LIBS="-ldht" \
- LIBUTP_CFLAGS=" " \
- LIBUTP_LIBS="-lutp" \
- LIBUTP_LIBS_QT="-lutp"
EXTRA_CONF_ARGS?=--enable-cli \
--disable-daemon \
@@ -65,20 +58,31 @@ EXTRA_CONF_ARGS?=--enable-cli \
--disable-mac \
--disable-nls
+EXTRA_PATCHES= ${PATCHDIR}/disable-web
+
+OPTIONS_DEFINE+= DOCS LITE
+OPTIONS_DEFAULT+= OPENSSL
+OPTIONS_SINGLE+= SSL
+OPTIONS_SINGLE_SSL+= OPENSSL POLARSSL WOLFSSL
+
LITE_CONFIGURE_ENABLE= lightweight
-EXTRA_PATCHES= ${PATCHDIR}/disable-web
+OPENSSL_USE= OPENSSL=yes
+OPENSSL_CONFIGURE_ENV= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
+ OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto"
+OPENSSL_CONFIGURE_ON= --with-crypto=openssl
+
+POLARSSL_LIB_DEPENDS= libpolarssl.so:${PORTSDIR}/security/polarssl13
+POLARSSL_CONFIGURE_ON= --with-crypto=polarssl
+
+WOLFSSL_LIB_DEPENDS= libwolfssl.so:${PORTSDIR}/security/wolfssl
+WOLFSSL_CONFIGURE_ON= --with-crypto=cyassl
+WOLFSSL_BROKEN= Requires security/wolfssl built with --enable-arc4
.endif
DOCS= AUTHORS NEWS README
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
-.include <bsd.port.pre.mk>
-
-.if !empty(ICONV_LIB)
-CONFIGURE_ARGS+=ac_cv_func_iconv_open=yes
-.endif
-
general-patch:
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
's|noinst_PROGRAMS = |noinst_PROGRAMS = #|g'
@@ -99,20 +103,18 @@ general-patch:
# Don't conflict with patches but force system libraries
@${REINPLACE_CMD} -e 's|third-party \\|\\|g' \
${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -Ee '/^DHT_(CFLAGS|LIBS)=/d' \
+ @${REINPLACE_CMD} \
-e 's|third-party/[^ ]*Makefile||g' \
${WRKSRC}/configure
- @${REINPLACE_CMD} \
- -e 's,TRANSMISSION_TOP}/third-party/dht/libdht.a,DHT_LIBS},' \
- ${WRKSRC}/qt/qtr.pro
- @${ECHO_CMD} 'DHT_LIBS = @DHT_LIBS@' >>${WRKSRC}/qt/config.pri.in
post-patch: general-patch
general-install:
+.if ${SLAVEPORT} != web
(cd ${WRKSRC} && ${COPYTREE_SHARE} \
"${DOCS}" ${STAGEDIR}${DOCSDIR})
+.endif
post-install: general-install
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-p2p/transmission-cli/distinfo b/net-p2p/transmission-cli/distinfo
index 0aca3372c13f..9a02231a8ba9 100644
--- a/net-p2p/transmission-cli/distinfo
+++ b/net-p2p/transmission-cli/distinfo
@@ -1,2 +1,2 @@
-SHA256 (transmission-2.84.tar.xz) = a9fc1936b4ee414acc732ada04e84339d6755cd0d097bcbd11ba2cfc540db9eb
-SIZE (transmission-2.84.tar.xz) = 3077836
+SHA256 (transmission-2.90.tar.xz) = 69ff8caf81684155926f437f46bf7df1b1fb304f52c7809f546257e8923f2fd2
+SIZE (transmission-2.90.tar.xz) = 3377720
diff --git a/net-p2p/transmission-cli/files/patch-fix_without_ipv6 b/net-p2p/transmission-cli/files/patch-fix_without_ipv6
index 13fe62b6e7cf..fac20ad9a6b6 100644
--- a/net-p2p/transmission-cli/files/patch-fix_without_ipv6
+++ b/net-p2p/transmission-cli/files/patch-fix_without_ipv6
@@ -1,11 +1,11 @@
---- libtransmission/fdlimit.c.orig 2013-06-26 05:35:25.603458000 +0300
-+++ libtransmission/fdlimit.c 2013-06-30 10:01:10.000000000 +0300
-@@ -668,7 +668,7 @@
+--- libtransmission/fdlimit.c.orig 2015-07-01 00:54:41 UTC
++++ libtransmission/fdlimit.c
+@@ -517,7 +517,7 @@ tr_fdSocketCreate (tr_session * session,
if (gFd->peerCount < session->peerLimit)
- if ((s = socket (domain, type, 0)) < 0)
+ if ((s = socket (domain, type, 0)) == TR_BAD_SOCKET)
- if (sockerrno != EAFNOSUPPORT)
+ if (sockerrno != EPROTONOSUPPORT)
- tr_logAddError (_("Couldn't create socket: %s"), tr_strerror (sockerrno));
-
- if (s > -1)
+ {
+ char err_buf[512];
+ tr_logAddError (_("Couldn't create socket: %s"),
diff --git a/net-p2p/transmission-cli/files/patch-libtransmission_upnp.c b/net-p2p/transmission-cli/files/patch-libtransmission_upnp.c
deleted file mode 100644
index 17ce1bea3aa0..000000000000
--- a/net-p2p/transmission-cli/files/patch-libtransmission_upnp.c
+++ /dev/null
@@ -1,18 +0,0 @@
-https://trac.transmissionbt.com/ticket/6003
-
-Index: libtransmission/upnp.c
-===================================================================
---- libtransmission/upnp.c (revision 14564)
-+++ libtransmission/upnp.c (revision 14565)
-@@ -88,7 +88,11 @@ tr_upnpDiscover (int msec)
-
- #if (MINIUPNPC_API_VERSION >= 8) /* adds ipv6 and error args */
- int err = UPNPDISCOVER_SUCCESS;
-+ #if (MINIUPNPC_API_VERSION >= 14) /* adds ttl */
-+ ret = upnpDiscover (msec, NULL, NULL, 0, 0, 2, &err);
-+ #else
- ret = upnpDiscover (msec, NULL, NULL, 0, 0, &err);
-+ #endif
- have_err = err != UPNPDISCOVER_SUCCESS;
- #else
- ret = upnpDiscover (msec, NULL, NULL, 0);
diff --git a/net-p2p/transmission-cli/files/patch-qt-app-h b/net-p2p/transmission-cli/files/patch-qt-app-h
index dfe755e738f9..76dc92dc0262 100644
--- a/net-p2p/transmission-cli/files/patch-qt-app-h
+++ b/net-p2p/transmission-cli/files/patch-qt-app-h
@@ -1,5 +1,5 @@
---- qt/app.h.orig 2013-11-13 20:00:41.000000000 +0100
-+++ qt/app.h 2013-11-13 20:00:51.000000000 +0100
+--- qt/Application.h.orig 2013-11-13 20:00:41.000000000 +0100
++++ qt/Application.h 2013-11-13 20:00:51.000000000 +0100
@@ -13,6 +13,7 @@
#ifndef QTR_APP_H
#define QTR_APP_H
diff --git a/net-p2p/transmission-cli/files/patch-qt-mainwin.cc b/net-p2p/transmission-cli/files/patch-qt-mainwin.cc
deleted file mode 100644
index 4df00031615a..000000000000
--- a/net-p2p/transmission-cli/files/patch-qt-mainwin.cc
+++ /dev/null
@@ -1,24 +0,0 @@
---- qt/mainwin.cc.orig 2014-07-01 17:09:14 UTC
-+++ qt/mainwin.cc
-@@ -1165,8 +1165,8 @@ TrMainWindow :: openTorrent ()
- QCheckBox * b = new QCheckBox (tr ("Show &options dialog"));
- b->setChecked (myPrefs.getBool (Prefs::OPTIONS_PROMPT));
- b->setObjectName (SHOW_OPTIONS_CHECKBOX_NAME);
-- auto l = dynamic_cast<QGridLayout*> (d->layout ());
-- if (l == nullptr)
-+ auto QGridLayout * l = dynamic_cast<QGridLayout*> (d->layout ());
-+ if (l == NULL)
- {
- l = new QGridLayout;
- d->setLayout (l);
-@@ -1313,8 +1313,8 @@ TrMainWindow :: removeTorrents (const bo
- msgBox.setDefaultButton (QMessageBox::Cancel);
- msgBox.setIcon (QMessageBox::Question);
- // hack needed to keep the dialog from being too narrow
-- auto layout = dynamic_cast<QGridLayout*>(msgBox.layout());
-- if (layout == nullptr)
-+ auto QGridLayout * layout = dynamic_cast<QGridLayout*>(msgBox.layout());
-+ if (layout == NULL)
- {
- layout = new QGridLayout;
- msgBox.setLayout (layout);
diff --git a/net-p2p/transmission-cli/files/patch-qt_qtr_pro b/net-p2p/transmission-cli/files/patch-qt_qtr_pro
index 76a8a66a6882..e45d21405a03 100644
--- a/net-p2p/transmission-cli/files/patch-qt_qtr_pro
+++ b/net-p2p/transmission-cli/files/patch-qt_qtr_pro
@@ -9,13 +9,13 @@ $OpenBSD: patch-qt_qtr_pro,v 1.4 2012/04/07 10:55:04 naddy Exp $
+man.path = /man/man1/
man.files = transmission-qt.1
- CONFIG += qt thread debug link_pkgconfig
-@@ -26,7 +26,7 @@ LIBS += $${LIBUTP_LIBS}
- LIBS += $${TRANSMISSION_TOP}/third-party/dht/libdht.a
+ CONFIG += qt thread debug link_pkgconfig c++11 warn_on
+@@ -34,7 +34,7 @@ LIBS += $${DHT_LIBS}
+ LIBS += $${LIBB64_LIBS}
LIBS += $${LIBUPNP_LIBS}
LIBS += $${LIBNATPMP_LIBS}
-unix: LIBS += -L$${EVENT_TOP}/lib -lz -lrt
+unix: LIBS += -L$${EVENT_TOP}/lib -lz -levent_core -levent_extra
- win32:DEFINES += QT_DBUS
win32:LIBS += -levent-2.0 -lws2_32 -lintl
win32:LIBS += -lidn -liconv -lwldap32 -liphlpapi
+
diff --git a/net-p2p/transmission-daemon/Makefile b/net-p2p/transmission-daemon/Makefile
index 1973e2ef9aeb..4ccb83373052 100644
--- a/net-p2p/transmission-daemon/Makefile
+++ b/net-p2p/transmission-daemon/Makefile
@@ -1,6 +1,6 @@
# $FreeBSD$
-PORTREVISION= 3
+PORTREVISION= 0
PKGNAMESUFFIX= -daemon
MAINTAINER= crees@FreeBSD.org
diff --git a/net-p2p/transmission-gtk/Makefile b/net-p2p/transmission-gtk/Makefile
index 4e139d33349f..cf622e3a3152 100644
--- a/net-p2p/transmission-gtk/Makefile
+++ b/net-p2p/transmission-gtk/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
+PORTREVISION= 0
PKGNAMESUFFIX= -gtk
-PORTREVISION= 5
MAINTAINER= crees@FreeBSD.org
COMMENT= Fast and lightweight GTK+3 BitTorrent client
diff --git a/net-p2p/transmission-qt4/Makefile b/net-p2p/transmission-qt4/Makefile
index 2f59606a130e..6efbdf511aab 100644
--- a/net-p2p/transmission-qt4/Makefile
+++ b/net-p2p/transmission-qt4/Makefile
@@ -1,6 +1,6 @@
# $FreeBSD$
-PORTREVISION= 2
+PORTREVISION= 0
PKGNAMESUFFIX= -qt4
MAINTAINER= crees@FreeBSD.org
@@ -16,7 +16,7 @@ SLAVEPORT= qt4
QT_NONSTANDARD= yes
USE_QT4= moc_build qmake_build rcc_build uic_build gui dbus network
-USES= desktop-file-utils
+USES= compiler:c++11-lib desktop-file-utils
EXTRA_CONF_ARGS=--disable-cli \
--disable-daemon \
@@ -27,7 +27,7 @@ EXTRA_CONF_ARGS=--disable-cli \
post-patch: general-patch
@${REINPLACE_CMD} -e 's|/share/man|/man|g ; /PKGCONFIG/s| openssl||g' \
${WRKSRC}/qt/qtr.pro
- @${ECHO_CMD} 'LIBS += -lcrypto' >> ${WRKSRC}/qt/qtr.pro
+ @${ECHO_CMD} 'LIBS += -l${PORT_OPTIONS:M*SSL:tl}' >>${WRKSRC}/qt/qtr.pro
post-build:
@(cd ${WRKSRC}/qt && ${QMAKE} ${QMAKE_ARGS} qtr.pro && ${MAKE_CMD})
diff --git a/www/transmission-web/Makefile b/www/transmission-web/Makefile
index 55363d620351..b97595a4075c 100644
--- a/www/transmission-web/Makefile
+++ b/www/transmission-web/Makefile
@@ -13,7 +13,6 @@ PLIST= ${NONEXISTENT}
SLAVEPORT= web
PORTDATA= web
-PORTDOCS= *
NO_BUILD= yes