aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2006-06-12 09:18:27 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2006-06-12 09:18:27 +0000
commitab55f8a2cb8a7a456606279b084af0e93ac13ac3 (patch)
tree6938e21ccb678f428d4c8b656318ef1174817137
parent1e9b84629b907055aff376d8bd097d2b2ee516a1 (diff)
downloadports-ab55f8a2cb8a7a456606279b084af0e93ac13ac3.tar.gz
ports-ab55f8a2cb8a7a456606279b084af0e93ac13ac3.zip
Notes
-rw-r--r--audio/ices/Makefile2
-rw-r--r--audio/ices0/Makefile62
-rw-r--r--audio/ices0/files/ices0.sh.in31
-rw-r--r--audio/ices0/files/message-bin.in12
-rw-r--r--audio/ices0/files/message.in6
-rw-r--r--audio/ices0/pkg-descr5
-rw-r--r--audio/ices0/pkg-plist2
7 files changed, 106 insertions, 14 deletions
diff --git a/audio/ices/Makefile b/audio/ices/Makefile
index cbb1c59935cb..e27dfe77e3b9 100644
--- a/audio/ices/Makefile
+++ b/audio/ices/Makefile
@@ -13,7 +13,7 @@ CATEGORIES= audio net
MASTER_SITES= http://svn.xiph.org/releases/ices/
MAINTAINER= lofi@freebsd.org
-COMMENT= A streaming source client for icecast 2
+COMMENT= A vorbis streaming source client for icecast 2
LIB_DEPENDS= shout.5:${PORTSDIR}/audio/libshout2 \
vorbis.3:${PORTSDIR}/audio/libvorbis \
diff --git a/audio/ices0/Makefile b/audio/ices0/Makefile
index 6a0a13314208..f3d5f4720e79 100644
--- a/audio/ices0/Makefile
+++ b/audio/ices0/Makefile
@@ -7,28 +7,70 @@
PORTNAME= ices
PORTVERSION= 0.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio net
MASTER_SITES= http://svn.xiph.org/releases/ices/
MAINTAINER= lofi@freebsd.org
-COMMENT= A streaming source client for icecast 2
+COMMENT= An mp3 streaming source client for icecast 2
-LIB_DEPENDS= FLAC.7:${PORTSDIR}/audio/flac \
- faad:${PORTSDIR}/audio/faad \
- mp3lame:${PORTSDIR}/audio/lame \
- shout.5:${PORTSDIR}/audio/libshout2 \
- vorbis.3:${PORTSDIR}/audio/libvorbis \
+LIB_DEPENDS= shout.5:${PORTSDIR}/audio/libshout2 \
xml2.5:${PORTSDIR}/textproc/libxml2
+OPTIONS= FLAC "Enable flac transcoding support" Off \
+ FAAD "Enable mpep4 transcoding support" Off \
+ VORBIS "Enable ogg/vorbis transcoding support" Off \
+ PYTHON "Enable Python scripting" On
+
CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib"
USE_PERL5= yes
-USE_PYTHON= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
LATEST_LINK= ices0
+USE_RC_SUBR= ices0.sh
+SUB_FILES+= message message-bin
+CONFIGURE_ARGS+=--program-suffix=0
+
+.if !defined(PACKAGE_BUILDING)
+PKGMESSAGE= ${WRKDIR}/message
+.else
+PKGMESSAGE= ${WRKDIR}/message-bin
+.endif
+
+MAN1= ices0.1
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITH_FLAC)
+CONFIGURE_ARGS+=--without-flac --without-lame
+.else
+LIB_DEPENDS+= FLAC.7:${PORTSDIR}/audio/flac \
+ mp3lame:${PORTSDIR}/audio/lame
+.endif
+
+.if !defined(WITH_FAAD)
+CONFIGURE_ARGS+=--without-faad --without-lame
+.else
+LIB_DEPENDS+= faad:${PORTSDIR}/audio/faad \
+ mp3lame:${PORTSDIR}/audio/lame
+.endif
+
+.if defined(WITH_PYTHON)
+BUILD_DEPENDS+= python:${PORTSDIR}/lang/python
+RUN_DEPENDS+= python:${PORTSDIR}/lang/python
+.else
+CONFIGURE_ARGS+=--without-python
+.endif
+
+.if !defined(WITH_VORBIS)
+CONFIGURE_ARGS+=--without-vorbis --without-lame
+.else
+LIB_DEPENDS+= vorbis:${PORTSDIR}/audio/libvorbis \
+ mp3lame:${PORTSDIR}/audio/lame
+.endif
-MAN1= ices.1
+post-install:
+ @${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/ices0/files/ices0.sh.in b/audio/ices0/files/ices0.sh.in
new file mode 100644
index 000000000000..05d3416e73d7
--- /dev/null
+++ b/audio/ices0/files/ices0.sh.in
@@ -0,0 +1,31 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: ices0
+# REQUIRE: DAEMON
+# BEFORE: login
+# KEYWORD: FreeBSD shutdown
+
+# Add the following line to /etc/rc.conf to enable `ices0':
+#
+#ices0_enable="YES"
+#ices0_flags=""
+#
+
+. "/etc/rc.subr"
+
+name="ices0"
+rcvar=`set_rcvar`
+
+command="%%PREFIX%%/bin/$name"
+command_args="1>/dev/null 2>&1"
+required_files="%%PREFIX%%/etc/ices.conf"
+
+# read configuration and set defaults
+load_rc_config "$name"
+: ${ices0_enable="NO"}
+: ${ices0_flags=""}
+
+run_rc_command "$1"
diff --git a/audio/ices0/files/message-bin.in b/audio/ices0/files/message-bin.in
new file mode 100644
index 000000000000..07816f0a253f
--- /dev/null
+++ b/audio/ices0/files/message-bin.in
@@ -0,0 +1,12 @@
+To start ices at system boot, copy %%PREFIX%%/etc/ices.conf.dist to
+%%PREFIX%%/etc/ices.conf, modify it to suit your environment and add:
+
+ices0_enable="YES"
+
+to /etc/rc.conf.
+
+
+ATTENTION: Due to mp3 licensing restrictions, this binary package of
+ ices0 does not feature transcoding support. If you want
+ support for transcoding FLAC, mp4 and vorbis data to mp3
+ on-the-fly, you need to compile the audio/ices0 port.
diff --git a/audio/ices0/files/message.in b/audio/ices0/files/message.in
new file mode 100644
index 000000000000..fed7d2b3aac3
--- /dev/null
+++ b/audio/ices0/files/message.in
@@ -0,0 +1,6 @@
+To start ices at system boot, copy %%PREFIX%%/etc/ices.conf.dist to
+%%PREFIX%%/etc/ices.conf, modify it to suit your environment and add:
+
+ices0_enable="YES"
+
+to /etc/rc.conf.
diff --git a/audio/ices0/pkg-descr b/audio/ices0/pkg-descr
index 4a8c0da0fc9b..4eb3e2d5a336 100644
--- a/audio/ices0/pkg-descr
+++ b/audio/ices0/pkg-descr
@@ -1,4 +1,5 @@
-IceS is a streaming source client for icecast 2 servers. It provides flexible
-and powerful static and live streaming capabilities for various stream formats.
+IceS0 is an mp3 streaming source client for icecast 2 servers. It provides
+flexible and powerful static and live streaming capabilities and can transcode
+various audio formats to mp3 on-the-fly.
WWW: http://www.icecast.org/
diff --git a/audio/ices0/pkg-plist b/audio/ices0/pkg-plist
index 762e04484340..6c47428a4cf0 100644
--- a/audio/ices0/pkg-plist
+++ b/audio/ices0/pkg-plist
@@ -1,4 +1,4 @@
-bin/ices
+bin/ices0
doc/ices/icesmanual.html
etc/ices.conf.dist
etc/modules/ices.pm.dist