aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-03-04 06:24:27 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-03-04 06:24:27 +0000
commitac1dcf7a32ae5ab97dd53d20dacded1b0e8d1203 (patch)
treec95349708c2a25cb755a57be84e80b6f38f280fe
parentac239c2b833c56dad70863d1d04445df443cc818 (diff)
Notes
-rw-r--r--devel/pecl-svn/Makefile8
-rw-r--r--devel/pecl-svn/files/patch-svn.c54
2 files changed, 55 insertions, 7 deletions
diff --git a/devel/pecl-svn/Makefile b/devel/pecl-svn/Makefile
index d730eac92564..9e0df9e3f1fb 100644
--- a/devel/pecl-svn/Makefile
+++ b/devel/pecl-svn/Makefile
@@ -7,22 +7,20 @@
PORTNAME= svn
PORTVERSION= 1.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel pear
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
-DISTNAME= svn-${PORTVERSION}
EXTRACT_SUFX= .tgz
DIST_SUBDIR= PECL
MAINTAINER= miwi@FreeBSD.org
COMMENT= A PECL extension to the libsvn library
-LIB_DEPENDS= svn_client-1:${PORTSDIR}/devel/subversion16
+LICENSE= PHP301
-CONFLICTS_BUILD=subversion-1.7.[0-9]*
+LIB_DEPENDS= svn_client-1:${PORTSDIR}/devel/subversion16
-LICENSE= PHP301
USE_PHP= yes
USE_PHPEXT= yes
diff --git a/devel/pecl-svn/files/patch-svn.c b/devel/pecl-svn/files/patch-svn.c
index a8ed0e946921..a656a0d61fc4 100644
--- a/devel/pecl-svn/files/patch-svn.c
+++ b/devel/pecl-svn/files/patch-svn.c
@@ -1,5 +1,5 @@
---- ./svn.c.orig 2009-08-21 08:38:26.000000000 -0400
-+++ ./svn.c 2009-08-21 08:38:33.000000000 -0400
+--- svn.c.orig 2010-12-09 04:30:16.000000000 +0100
++++ svn.c 2012-02-28 09:46:50.877059221 +0100
@@ -34,6 +34,7 @@
#include "apr_version.h"
@@ -8,3 +8,53 @@
#include "svn_sorts.h"
#include "svn_config.h"
#include "svn_auth.h"
+@@ -43,6 +44,7 @@
+ #include "svn_utf.h"
+ #include "svn_time.h"
+ #include "svn_props.h"
++#include "svn_version.h"
+
+ ZEND_DECLARE_MODULE_GLOBALS(svn)
+
+@@ -96,7 +98,13 @@
+ static ZEND_RSRC_DTOR_FUNC(php_svn_repos_dtor)
+ {
+ struct php_svn_repos *r = rsrc->ptr;
+- svn_pool_destroy(r->pool);
++ /*
++ * If root pool doesn't exist, then this resource's pool was already
++ * destroyed
++ */
++ if (SVN_G(pool)) {
++ svn_pool_destroy(r->pool);
++ }
+ efree(r);
+ }
+
+@@ -123,7 +131,7 @@
+
+ #define SVN_STATIC_ME(name) ZEND_FENTRY(name, ZEND_FN(svn_ ## name), NULL, ZEND_ACC_PUBLIC | ZEND_ACC_STATIC)
+ /** Fixme = this list needs padding out... */
+-static function_entry svn_methods[] = {
++static zend_function_entry svn_methods[] = {
+ SVN_STATIC_ME(cat)
+ SVN_STATIC_ME(checkout)
+ SVN_STATIC_ME(log)
+@@ -134,7 +142,7 @@
+
+
+ /* {{{ svn_functions[] */
+-function_entry svn_functions[] = {
++zend_function_entry svn_functions[] = {
+ PHP_FE(svn_checkout, NULL)
+ PHP_FE(svn_cat, NULL)
+ PHP_FE(svn_ls, NULL)
+@@ -270,7 +278,7 @@
+
+ smart_str_appendl(&s, "\n", 1);
+ smart_str_0(&s);
+- php_error_docref(NULL TSRMLS_CC, E_WARNING, s.c);
++ php_error_docref(NULL TSRMLS_CC, E_WARNING, "%s", s.c);
+ smart_str_free(&s);
+ }
+