aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-12-21 09:31:25 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-12-21 09:31:25 +0000
commitad371d6d2f28edb06ce269758f8a48dd2a830059 (patch)
treea9846ae0fefe9b6a1c249fec1396d587456b79d5
parentb1b7d0d33dc0b7fff82f31aff49976b4b45c7f86 (diff)
downloadports-ad371d6d2f28edb06ce269758f8a48dd2a830059.tar.gz
ports-ad371d6d2f28edb06ce269758f8a48dd2a830059.zip
Notes
-rw-r--r--devel/pire/Makefile6
-rw-r--r--net-p2p/bitcoin-daemon/Makefile4
-rw-r--r--net-p2p/bitcoin-utils/Makefile6
-rw-r--r--security/p5-Net-SinFP/Makefile6
4 files changed, 11 insertions, 11 deletions
diff --git a/devel/pire/Makefile b/devel/pire/Makefile
index f70b66936793..e50fffa3c368 100644
--- a/devel/pire/Makefile
+++ b/devel/pire/Makefile
@@ -13,6 +13,9 @@ COMMENT= Perl Incompatible Regular Expressions library
LICENSE= LGPL3+
LICENSE_FILE= ${WRKSRC}/COPYING
+NOT_FOR_ARCHS= powerpc powerpc64 sparc64
+NOT_FOR_ARCHS_REASON= does not support big-endian architectures
+
USE_GITHUB= yes
GH_ACCOUNT= dprokoptsev
@@ -22,7 +25,4 @@ USES= autoreconf bison libtool
USE_LDCONFIG= yes
TEST_TARGET= check
-ONLY_FOR_ARCHS= amd64 i386
-ONLY_FOR_ARCHS_REASON= not yet ported to big-endian platforms
-
.include <bsd.port.mk>
diff --git a/net-p2p/bitcoin-daemon/Makefile b/net-p2p/bitcoin-daemon/Makefile
index 3045aaf97f41..050de2f78d18 100644
--- a/net-p2p/bitcoin-daemon/Makefile
+++ b/net-p2p/bitcoin-daemon/Makefile
@@ -8,8 +8,8 @@ COMMENT= Virtual Peer-to-Peer Currency (Daemon)
SLAVE_PORT= yes
-ONLY_FOR_ARCHS= amd64 i386
-ONLY_FOR_ARCHS_REASON= does not support big-endian architectures
+NOT_FOR_ARCHS= powerpc powerpc64 sparc64
+NOT_FOR_ARCHS_REASON= does not support big-endian architectures
OPTIONS_DEFINE= DEBUG HARDENING TESTS UPNP WALLET ZMQ
OPTIONS_DEFAULT= HARDENING UPNP WALLET
diff --git a/net-p2p/bitcoin-utils/Makefile b/net-p2p/bitcoin-utils/Makefile
index f63ad4f33914..3830afccd4fe 100644
--- a/net-p2p/bitcoin-utils/Makefile
+++ b/net-p2p/bitcoin-utils/Makefile
@@ -6,12 +6,12 @@ PKGNAMESUFFIX= -utils
COMMENT= Virtual Peer-to-Peer Currency (CLI and Utilities)
SLAVE_PORT= yes
+NOT_FOR_ARCHS= powerpc powerpc64 sparc64
+NOT_FOR_ARCHS_REASON= does not support big-endian architectures
+
OPTIONS_DEFINE= DEBUG HARDENING TESTS
OPTIONS_DEFAULT= HARDENING TESTS
-ONLY_FOR_ARCHS= amd64 i386
-ONLY_FOR_ARCHS_REASON= does not support big-endian architectures
-
CONFIGURE_ARGS= --without-daemon \
--without-gui \
--without-libs \
diff --git a/security/p5-Net-SinFP/Makefile b/security/p5-Net-SinFP/Makefile
index 5dbfe08d05d7..827a69429433 100644
--- a/security/p5-Net-SinFP/Makefile
+++ b/security/p5-Net-SinFP/Makefile
@@ -27,6 +27,9 @@ COMMENT= Full operating system stack fingerprinting suite
LICENSE= ART10
LICENSE_FILE= ${WRKSRC}/LICENSE
+NOT_FOR_ARCHS= powerpc powerpc64 sparc64
+NOT_FOR_ARCHS_REASON= does not support big-endian architectures
+
.if ${PORTNAME} == "Net-SinFP"
PKGNAMEPREFIX= p5-
@@ -44,7 +47,4 @@ post-patch:
@${REINPLACE_CMD} -e 's/.*EXE_FILES.*//' ${WRKSRC}/${CONFIGURE_SCRIPT}
.endif
-ONLY_FOR_ARCHS= i386 amd64
-ONLY_FOR_ARCHS_REASON= Big endian architectures not supported yet
-
.include <bsd.port.mk>