aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2020-10-01 17:19:57 +0000
committerStefan Eßer <se@FreeBSD.org>2020-10-01 17:19:57 +0000
commitae3db00711508ff2ee2fd42347b97cb6d94b6a03 (patch)
treea8ec0bb988cd74864122bcb17125456d519fb85b
parent3db9ed2c2dd38e097b57c66ef23fc60064f07487 (diff)
downloadports-ae3db00711508ff2ee2fd42347b97cb6d94b6a03.tar.gz
ports-ae3db00711508ff2ee2fd42347b97cb6d94b6a03.zip
Notes
-rw-r--r--graphics/ida/Makefile1
-rw-r--r--graphics/ida/files/patch-idaconfig.h11
-rw-r--r--graphics/ida/files/patch-viewer.c11
3 files changed, 23 insertions, 0 deletions
diff --git a/graphics/ida/Makefile b/graphics/ida/Makefile
index 4ba94e301b04..3b9cecfd2410 100644
--- a/graphics/ida/Makefile
+++ b/graphics/ida/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ida
PORTVERSION= 2.14
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= https://www.kraxel.org/releases/fbida/
DISTNAME= fbida-${PORTVERSION}
diff --git a/graphics/ida/files/patch-idaconfig.h b/graphics/ida/files/patch-idaconfig.h
new file mode 100644
index 000000000000..d91ff27559f6
--- /dev/null
+++ b/graphics/ida/files/patch-idaconfig.h
@@ -0,0 +1,11 @@
+--- idaconfig.h.orig 2017-08-30 10:48:03 UTC
++++ idaconfig.h
+@@ -17,7 +17,7 @@
+
+ /* -------------------------------------------------------------------------- */
+
+-char *ida_lists;
++extern char *ida_lists;
+
+ void ida_init_config(void);
+ void ida_read_config(void);
diff --git a/graphics/ida/files/patch-viewer.c b/graphics/ida/files/patch-viewer.c
new file mode 100644
index 000000000000..58d83de85b09
--- /dev/null
+++ b/graphics/ida/files/patch-viewer.c
@@ -0,0 +1,11 @@
+--- viewer.c.orig 2017-08-30 10:48:03 UTC
++++ viewer.c
+@@ -39,7 +39,7 @@
+
+ #define PROCESS_LINES 16
+
+-int debug;
++extern int debug;
+ Cursor ptrs[POINTER_COUNT];
+
+ /* ----------------------------------------------------------------------- */