aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2007-07-10 20:24:59 +0000
committerJuergen Lock <nox@FreeBSD.org>2007-07-10 20:24:59 +0000
commitaf3dea9281329fef94ebd55596672bcdad3c0ded (patch)
tree43c37a4b84a30725c2ede1087f0c110715c9adec
parent8904a74b060ebbf02fe3857d45bc01c4e37e51ea (diff)
downloadports-af3dea9281329fef94ebd55596672bcdad3c0ded.tar.gz
ports-af3dea9281329fef94ebd55596672bcdad3c0ded.zip
Notes
-rw-r--r--emulators/qemu-devel/Makefile5
-rw-r--r--emulators/qemu-devel/distinfo6
-rw-r--r--emulators/qemu-devel/files/patch-90_security40
-rw-r--r--emulators/qemu-devel/files/patch-bsdusb.patch6
-rw-r--r--emulators/qemu-devel/files/patch-bt12
-rw-r--r--emulators/qemu-devel/files/patch-vl.c43
-rw-r--r--emulators/qemu-devel/files/patch-vl.c-ppbus11
-rw-r--r--emulators/qemu-devel/pkg-descr2
8 files changed, 47 insertions, 78 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index 2b9a23a6cf7e..b538e9aeb682 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= qemu
-PORTVERSION= 0.9.0s.20070526
+PORTVERSION= 0.9.0s.20070702
CATEGORIES= emulators
MASTER_SITES= http://qemu.org/:release \
http://qemu-forum.ipi.fi/qemu-snapshots/:snapshot \
@@ -15,7 +15,7 @@ MASTER_SITES= http://qemu.org/:release \
http://people.brandeis.edu/~jcoiner/qemu_idedma/:idedma \
http://people.freebsd.org/~maho/qemu/:misc
PKGNAMESUFFIX= -devel
-DISTNAME= ${PORTNAME}-snapshot-2007-05-26_05
+DISTNAME= ${PORTNAME}-snapshot-2007-07-02_05
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:snapshot
DIST_SUBDIR= qemu
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
@@ -45,6 +45,7 @@ OPTIONS= KQEMU "Build with (alpha!) accelerator module" Off \
.include <bsd.port.pre.mk>
WITHOUT_CPU_CFLAGS=yes #to avoid problems with register allocation
+CFLAGS:= ${CFLAGS:C/-fno-tree-vrp//}
CONFIGURE_ARGS+= --prefix=${PREFIX} --cc=${CC}
.if defined(WITHOUT_SDL)
diff --git a/emulators/qemu-devel/distinfo b/emulators/qemu-devel/distinfo
index 990b2eb5db27..9f7a2d9fac62 100644
--- a/emulators/qemu-devel/distinfo
+++ b/emulators/qemu-devel/distinfo
@@ -1,6 +1,6 @@
-MD5 (qemu/qemu-snapshot-2007-05-26_05.tar.bz2) = 3fe2cf8c5cb26431499056bd08bb5be8
-SHA256 (qemu/qemu-snapshot-2007-05-26_05.tar.bz2) = 55e73f0593c5d31ba3483e8034542c5ab33217cc3048995dd94edf9640e8411e
-SIZE (qemu/qemu-snapshot-2007-05-26_05.tar.bz2) = 1964534
+MD5 (qemu/qemu-snapshot-2007-07-02_05.tar.bz2) = 624b513bbd86e0c7529344584639fba1
+SHA256 (qemu/qemu-snapshot-2007-07-02_05.tar.bz2) = 62474848fda0dacb1c6238b33b6b272e49dfa3821352ec57f38388246e0aa8c2
+SIZE (qemu/qemu-snapshot-2007-07-02_05.tar.bz2) = 2003505
MD5 (qemu/patch3_cirrus) = ebe7ed9fce804c49e024bc93bfdfc810
SHA256 (qemu/patch3_cirrus) = e862371834b7d895a896fbdb84fd9f70d17b5729a6f6789a48a61504fc941e11
SIZE (qemu/patch3_cirrus) = 8817
diff --git a/emulators/qemu-devel/files/patch-90_security b/emulators/qemu-devel/files/patch-90_security
index 6bf6a711dcdd..b075556cb2f2 100644
--- a/emulators/qemu-devel/files/patch-90_security
+++ b/emulators/qemu-devel/files/patch-90_security
@@ -185,32 +185,6 @@ Index: qemu-0.8.2/hw/fdc.c
}
}
retval = fdctrl->fifo[pos];
-Index: qemu-0.8.2/hw/ne2000.c
-===================================================================
---- qemu-0.8.2.orig/hw/ne2000.c 2007-04-20 06:05:59.000000000 +0300
-+++ qemu-0.8.2/hw/ne2000.c 2007-04-20 06:05:59.000000000 +0300
-@@ -230,7 +230,7 @@ static void ne2000_receive(void *opaque,
- {
- NE2000State *s = opaque;
- uint8_t *p;
-- int total_len, next, avail, len, index, mcast_idx;
-+ unsigned int total_len, next, avail, len, index, mcast_idx;
- uint8_t buf1[60];
- static const uint8_t broadcast_macaddr[6] =
- { 0xff, 0xff, 0xff, 0xff, 0xff, 0xff };
-@@ -299,7 +299,11 @@ static void ne2000_receive(void *opaque,
-
- /* write packet data */
- while (size > 0) {
-- avail = s->stop - index;
-+ /* taviso: this can wrap, so check its okay. */
-+ if (index <= s->stop)
-+ avail = s->stop - index;
-+ else
-+ avail = 0;
- len = size;
- if (len > avail)
- len = avail;
Index: qemu-0.8.2/hw/pc.c
===================================================================
--- qemu-0.8.2.orig/hw/pc.c 2007-04-20 06:05:58.000000000 +0300
@@ -272,20 +246,6 @@ Index: qemu-0.8.2/target-i386/translate.c
===================================================================
--- qemu-0.8.2.orig/target-i386/translate.c 2006-07-22 20:23:34.000000000 +0300
+++ qemu-0.8.2/target-i386/translate.c 2007-04-20 06:05:59.000000000 +0300
-@@ -5244,7 +5244,12 @@ static target_ulong disas_insn(DisasCont
- if (CODE64(s))
- goto illegal_op;
- val = ldub_code(s->pc++);
-- gen_op_aam(val);
-+ /* taviso: operand can be zero */
-+ if (val) {
-+ gen_op_aam(val);
-+ } else {
-+ gen_exception(s, EXCP00_DIVZ, s->pc - s->cs_base);
-+ }
- s->cc_op = CC_OP_LOGICB;
- break;
- case 0xd5: /* aad */
@@ -5292,6 +5297,7 @@ static target_ulong disas_insn(DisasCont
gen_jmp_im(pc_start - s->cs_base);
gen_op_into(s->pc - pc_start);
diff --git a/emulators/qemu-devel/files/patch-bsdusb.patch b/emulators/qemu-devel/files/patch-bsdusb.patch
index ce1686004eaa..b7cabe25d428 100644
--- a/emulators/qemu-devel/files/patch-bsdusb.patch
+++ b/emulators/qemu-devel/files/patch-bsdusb.patch
@@ -36,15 +36,15 @@ Index: qemu/configure
for target in $target_list; do
target_dir="$target"
Index: qemu/Makefile.target
-@@ -329,7 +329,7 @@
+@@ -408,7 +408,7 @@
VL_OBJS+= scsi-disk.o cdrom.o lsi53c895a.o
# USB layer
-VL_OBJS+= usb.o usb-hub.o usb-linux.o usb-hid.o usb-ohci.o usb-msd.o
+VL_OBJS+= usb.o usb-hub.o usb-$(HOST_USB).o usb-hid.o usb-ohci.o usb-msd.o
+ VL_OBJS+= usb-wacom.o
- # PCI network cards
- VL_OBJS+= ne2000.o rtl8139.o pcnet.o
+ # EEPROM emulation
Index: qemu/usb-stub.c
@@ -0,0 +1,11 @@
+#include "vl.h"
diff --git a/emulators/qemu-devel/files/patch-bt b/emulators/qemu-devel/files/patch-bt
index 62e8924722b3..2a51b7d00a8f 100644
--- a/emulators/qemu-devel/files/patch-bt
+++ b/emulators/qemu-devel/files/patch-bt
@@ -1,14 +1,14 @@
Index: qemu/vl.c
-@@ -43,6 +43,9 @@
- #ifndef __APPLE__
- #include <libutil.h>
+@@ -76,6 +76,9 @@
+ #endif
+ #endif
#endif
+#ifdef __FreeBSD__
+#include <sys/module.h>
+#endif
- #else
- #include <linux/if.h>
- #include <linux/if_tun.h>
+
+ #if defined(CONFIG_SLIRP)
+ #include "libslirp.h"
@@ -1059,6 +1062,34 @@
#endif /* CONFIG_SLIRP */
diff --git a/emulators/qemu-devel/files/patch-vl.c b/emulators/qemu-devel/files/patch-vl.c
index 44c3c64cb468..3d23a23d855e 100644
--- a/emulators/qemu-devel/files/patch-vl.c
+++ b/emulators/qemu-devel/files/patch-vl.c
@@ -1,21 +1,4 @@
Index: qemu/vl.c
-@@ -1510,7 +1510,7 @@
- return chr;
- }
-
--#if defined(__linux__)
-+#if defined(__linux__) || defined(__FreeBSD__)
- static CharDriverState *qemu_chr_open_pty(void)
- {
- struct termios tty;
-@@ -1904,6 +1907,7 @@
- return chr;
- }
-
-+#if defined(__linux__)
- typedef struct {
- int fd;
- int mode;
@@ -1727,6 +1728,7 @@
chr->chr_ioctl = pp_ioctl;
return chr;
@@ -24,3 +7,29 @@ Index: qemu/vl.c
#else
CharDriverState *qemu_chr_open_pty(void)
+@@ -1771,14 +1771,14 @@
+ return chr;
+ }
+
+-#if defined(__linux__) || defined(__sun__)
++#if defined(__linux__) || defined(__sun__) || defined(__FreeBSD__)
+ static CharDriverState *qemu_chr_open_pty(void)
+ {
+ struct termios tty;
+ char slave_name[1024];
+ int master_fd, slave_fd;
+
+-#if defined(__linux__)
++#if defined(__linux__) || defined(__FreeBSD__)
+ /* Not satisfying */
+ if (openpty(&master_fd, &slave_fd, slave_name, NULL, NULL) < 0) {
+ return NULL;
+@@ -3036,7 +3036,7 @@
+ return qemu_chr_open_pp(filename);
+ } else
+ #endif
+-#if defined(__linux__) || defined(__sun__)
++#if defined(__linux__) || defined(__sun__) || defined(__FreeBSD__)
+ if (strstart(filename, "/dev/", NULL)) {
+ return qemu_chr_open_tty(filename);
+ } else
diff --git a/emulators/qemu-devel/files/patch-vl.c-ppbus b/emulators/qemu-devel/files/patch-vl.c-ppbus
index d0b46abcbcb4..11ce2a60382c 100644
--- a/emulators/qemu-devel/files/patch-vl.c-ppbus
+++ b/emulators/qemu-devel/files/patch-vl.c-ppbus
@@ -1,20 +1,19 @@
---- vl.c.orig Mon Aug 21 23:06:11 2006
-+++ vl.c Mon Aug 21 23:04:49 2006
-@@ -48,6 +48,8 @@
+Index: qemu/vl.c
+@@ -78,6 +78,8 @@
#endif
#ifdef __FreeBSD__
#include <sys/module.h>
+#include <dev/ppbus/ppi.h>
+#include <dev/ppbus/ppbconf.h>
#endif
- #else
- #ifndef __sun__
+
+ #if defined(CONFIG_SLIRP)
@@ -1728,7 +1730,64 @@
chr->chr_ioctl = pp_ioctl;
return chr;
}
-#endif /* defined(__linux__) */
-+#elif defined(__FreeBSD__)
++#if defined(__FreeBSD__)
+static int pp_ioctl(CharDriverState *chr, int cmd, void *arg)
+{
+ int fd = (int)chr->opaque;
diff --git a/emulators/qemu-devel/pkg-descr b/emulators/qemu-devel/pkg-descr
index d1cb289e746f..8bb68c91816c 100644
--- a/emulators/qemu-devel/pkg-descr
+++ b/emulators/qemu-devel/pkg-descr
@@ -17,4 +17,4 @@ As QEMU requires no host kernel patches to run, it is very safe and easy to use.
See also the preconfigured system images on http://oszoo.org/
Many live cd isos also work.
-WWW: http://qemu.org/
+WWW: http://fabrice.bellard.free.fr/qemu/