aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2024-05-16 09:35:14 +0000
committerJan Beich <jbeich@FreeBSD.org>2024-05-16 09:59:47 +0000
commitaf7cc316047047a00c52908f721fb655b5e005f2 (patch)
tree90ff8b0e4b9a4e3af6ae18eef2c54fdc6a1edb9a
parentc77ac5e76f83cc8cc83fb42920d05408c7d4595e (diff)
downloadports-af7cc316047047a00c52908f721fb655b5e005f2.tar.gz
ports-af7cc316047047a00c52908f721fb655b5e005f2.zip
x11/wl-kbptr: add new port
wl-kbptr -- short for Wayland Keyboard Pointer -- is a utility to help move the mouse pointer with the keyboard. It works in two phases: the screen is first in mapped with three letter labels and then the selected area is refined by bisecting it. At any point the cursor can be moved at the location marked by the red marker by pressing Enter or Space. A left, right and middle click can be made by pressing the g, h and b keys respectively. Note, your compositor needs to support the wlr-layer-shell-unstable-v1 and wlr-virtual-pointer-unstable-v1 protocols. https://github.com/moverest/wl-kbptr
-rw-r--r--x11/Makefile1
-rw-r--r--x11/wl-kbptr/Makefile23
-rw-r--r--x11/wl-kbptr/distinfo3
-rw-r--r--x11/wl-kbptr/pkg-descr11
4 files changed, 38 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index c3a9429521b5..a8b6b5868eef 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -466,6 +466,7 @@
SUBDIR += wf-shell
SUBDIR += windowtolayer
SUBDIR += wl-clipboard
+ SUBDIR += wl-kbptr
SUBDIR += wl-mirror
SUBDIR += wlogout
SUBDIR += wlopm
diff --git a/x11/wl-kbptr/Makefile b/x11/wl-kbptr/Makefile
new file mode 100644
index 000000000000..858428fb7a08
--- /dev/null
+++ b/x11/wl-kbptr/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= wl-kbptr
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.2.0
+CATEGORIES= x11 wayland
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Control the mouse pointer with the keyboard on Wayland
+WWW= https://github.com/moverest/wl-kbptr
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= wayland-protocols>0:graphics/wayland-protocols
+LIB_DEPENDS= libwayland-client.so:graphics/wayland \
+ libxkbcommon.so:x11/libxkbcommon
+
+USES= compiler:c11 gnome meson pkgconfig
+USE_GITHUB= yes
+USE_GNOME= cairo
+GH_ACCOUNT= moverest
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/x11/wl-kbptr/distinfo b/x11/wl-kbptr/distinfo
new file mode 100644
index 000000000000..f5a4453c3102
--- /dev/null
+++ b/x11/wl-kbptr/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1693353722
+SHA256 (moverest-wl-kbptr-v0.2.0_GH0.tar.gz) = 5d92d3217e7c77050fdd95f6602ffee3ae384f374400d95167adc721c37eba98
+SIZE (moverest-wl-kbptr-v0.2.0_GH0.tar.gz) = 36384
diff --git a/x11/wl-kbptr/pkg-descr b/x11/wl-kbptr/pkg-descr
new file mode 100644
index 000000000000..c446432fd179
--- /dev/null
+++ b/x11/wl-kbptr/pkg-descr
@@ -0,0 +1,11 @@
+wl-kbptr -- short for Wayland Keyboard Pointer -- is a utility to help
+move the mouse pointer with the keyboard.
+
+It works in two phases: the screen is first in mapped with three
+letter labels and then the selected area is refined by bisecting
+it. At any point the cursor can be moved at the location marked by the
+red marker by pressing Enter or Space. A left, right and middle click
+can be made by pressing the g, h and b keys respectively.
+
+Note, your compositor needs to support the wlr-layer-shell-unstable-v1
+and wlr-virtual-pointer-unstable-v1 protocols.