aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-12-26 01:37:29 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-12-26 01:37:29 +0000
commitafc1b99921fdd4acbddf9e1fefd202e3550d4fe6 (patch)
tree5bc0d48b0cf22f183045fa088ffb9d692a682a51
parent2dcafdb9958caf73a7893a5bff72f85ac1a9aee2 (diff)
downloadports-afc1b99921fdd4acbddf9e1fefd202e3550d4fe6.tar.gz
ports-afc1b99921fdd4acbddf9e1fefd202e3550d4fe6.zip
Notes
-rw-r--r--sysutils/pdumpfs-rsync/Makefile1
-rw-r--r--sysutils/pdumpfs-rsync/files/patch-pdumpfs-rsync26
2 files changed, 25 insertions, 2 deletions
diff --git a/sysutils/pdumpfs-rsync/Makefile b/sysutils/pdumpfs-rsync/Makefile
index 2d6ca3a243de..bddae627181e 100644
--- a/sysutils/pdumpfs-rsync/Makefile
+++ b/sysutils/pdumpfs-rsync/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pdumpfs-rsync
PORTVERSION= 0.8.1
+PORTREVISION= 1
CATEGORIES= sysutils net
MASTER_SITES= http://tach.arege.net/software/pdumpfs-rsync/
DISTFILES= ${PROG}
diff --git a/sysutils/pdumpfs-rsync/files/patch-pdumpfs-rsync b/sysutils/pdumpfs-rsync/files/patch-pdumpfs-rsync
index f9d7ece54685..bae6b030c3a2 100644
--- a/sysutils/pdumpfs-rsync/files/patch-pdumpfs-rsync
+++ b/sysutils/pdumpfs-rsync/files/patch-pdumpfs-rsync
@@ -1,5 +1,5 @@
---- pdumpfs-rsync.orig Sat May 29 03:00:00 2004
-+++ pdumpfs-rsync Sat May 29 03:01:57 2004
+--- pdumpfs-rsync.orig Mon Dec 26 12:31:35 2005
++++ pdumpfs-rsync Mon Dec 26 12:33:21 2005
@@ -15,7 +15,7 @@
# the GNU General Public License version 2.
#
@@ -9,3 +9,25 @@
require 'ftools'
require 'getoptlong'
+@@ -128,8 +128,10 @@
+ end
+ end
+
+- latest = latest_snapshot(src, dest, base)
+- today = File.join(dest, datedir(Date.today), base)
++ start_time = Time.now
++ pdumpfs = Pdumpfs::Pdumpfs.new(opts)
++ latest = pdumpfs.latest_snapshot(start_time, src, dest, base)
++ today = File.join(dest, pdumpfs.datedir(Date.today), base)
+ rsync_array = rsync_array + rsync_opts
+ rsync_array.push(ARGV[0].sub(%r!/+$!, '') + '/')
+ rsync_array.push(src + '/')
+@@ -141,7 +143,7 @@
+ if ( $? >> 8 != 0 )
+ STDERR.print "WARNING: rsync failed: #{ARGV[0]}; exit value: #{$? >> 8}\n"
+ end
+- update_snapshot(src, src, today, matcher)
++ pdumpfs.update_snapshot(src, src, today, matcher)
+ else
+ STDERR.print "rsync failed: #{ARGV[0]}; exit value: #{$? >> 8}\n"
+ exit $? >> 8