aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Pizzamiglio <pizzamig@FreeBSD.org>2018-01-09 16:54:30 +0000
committerLuca Pizzamiglio <pizzamig@FreeBSD.org>2018-01-09 16:54:30 +0000
commitafde71aeece41a2aee803d7280263f8c0814352d (patch)
tree56c49ec3ea78265764ded9b57b990046e4452d22
parent34998a4e86721265f716a7cebf5b7496de6c2f34 (diff)
downloadports-afde71aeece41a2aee803d7280263f8c0814352d.tar.gz
ports-afde71aeece41a2aee803d7280263f8c0814352d.zip
Notes
-rw-r--r--security/Makefile1
-rw-r--r--security/pecl-mcrypt/Makefile19
-rw-r--r--security/pecl-mcrypt/distinfo3
-rw-r--r--security/pecl-mcrypt/pkg-descr5
4 files changed, 28 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 2b8e9f7d18d5..a3763af1de04 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -803,6 +803,7 @@
SUBDIR += pecl-gnupg
SUBDIR += pecl-krb5
SUBDIR += pecl-libsodium
+ SUBDIR += pecl-mcrypt
SUBDIR += pecl-pam
SUBDIR += pecl-scrypt
SUBDIR += pecl-ssh2
diff --git a/security/pecl-mcrypt/Makefile b/security/pecl-mcrypt/Makefile
new file mode 100644
index 000000000000..5e89384238d0
--- /dev/null
+++ b/security/pecl-mcrypt/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= mcrypt
+PORTVERSION= 1.0.1
+CATEGORIES= security pear
+
+MAINTAINER= pizzamig@FreeBSD.org
+COMMENT= PHP extension for mcrypt, removed in PHP 7.2
+
+LICENSE= PHP301
+
+IGNORE_WITH_PHP= 56 70 71
+
+LIB_DEPENDS= libltdl.so:devel/libltdl \
+ libmcrypt.so:security/libmcrypt
+
+USES= php:pecl
+
+.include <bsd.port.mk>
diff --git a/security/pecl-mcrypt/distinfo b/security/pecl-mcrypt/distinfo
new file mode 100644
index 000000000000..8fb4753bd322
--- /dev/null
+++ b/security/pecl-mcrypt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1515329356
+SHA256 (PECL/mcrypt-1.0.1.tgz) = a3b0e5493b5cd209ab780ee54733667293d369e6b7052b4a7dab9dd0def46ac6
+SIZE (PECL/mcrypt-1.0.1.tgz) = 33782
diff --git a/security/pecl-mcrypt/pkg-descr b/security/pecl-mcrypt/pkg-descr
new file mode 100644
index 000000000000..f0e4fa12d666
--- /dev/null
+++ b/security/pecl-mcrypt/pkg-descr
@@ -0,0 +1,5 @@
+Bindings for the libmcrypt library
+
+Pecl package available only for PHP 7.2
+
+WWW: https://pecl.php.net/package/mcrypt