aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2013-07-04 22:46:33 +0000
committerFlorian Smeets <flo@FreeBSD.org>2013-07-04 22:46:33 +0000
commitb003ca6d3472473cf343e05755f41df06ba4ab50 (patch)
tree4a254539bcb88ee266436d7c7d286930a8315b3a
parent42da4e24d41ef057e5113b2bcbcf6c85cb6952ca (diff)
downloadports-b003ca6d3472473cf343e05755f41df06ba4ab50.tar.gz
ports-b003ca6d3472473cf343e05755f41df06ba4ab50.zip
Notes
-rw-r--r--net/asterisk/Makefile6
-rw-r--r--net/asterisk/files/patch-main::utils.c2
-rw-r--r--net/asterisk/pkg-plist8
-rw-r--r--net/asterisk10/Makefile6
-rw-r--r--net/asterisk10/files/patch-main::utils.c2
-rw-r--r--net/asterisk10/pkg-plist8
6 files changed, 16 insertions, 16 deletions
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index 3b27308d03e7..34a53f506d76 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -3,7 +3,7 @@
PORTNAME= asterisk
PORTVERSION= 1.8.22.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/ \
http://downloads.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -26,7 +26,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gsm=${LOCALBASE}
LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/openh323
-USE_GCC= any
+USE_CSTD= gnu89
USE_GMAKE= yes
USE_GNOME= libxml2
USES= bison
@@ -286,7 +286,7 @@ post-patch:
${REINPLACE_CMD} -e 's|/var/lib|${PREFIX}/share|g' ${WRKSRC}/configs/musiconhold.conf.sample
post-configure:
- @cd ${WRKSRC} && gmake menuselect.makeopts
+ @cd ${WRKSRC} && ${GMAKE} menuselect.makeopts
@cd ${WRKSRC} && ./menuselect/menuselect --disable res_timing_kqueue menuselect.makeopts
.if ${PORT_OPTIONS:MMYSQL}
@cd ${WRKSRC} && ./menuselect/menuselect --enable res_config_mysql menuselect.makeopts
diff --git a/net/asterisk/files/patch-main::utils.c b/net/asterisk/files/patch-main::utils.c
index 7440848a1521..8b6e268d1cb9 100644
--- a/net/asterisk/files/patch-main::utils.c
+++ b/net/asterisk/files/patch-main::utils.c
@@ -6,7 +6,7 @@
-#ifdef __linux__
- /* On Linux, pthread_attr_init() defaults to PTHREAD_EXPLICIT_SCHED,
-+#ifdef __linux__ || defined(__FreeBSD__)
++#if defined(__linux__) || defined(__FreeBSD__)
+ /* On Linux and FreeBSD, pthread_attr_init() defaults to PTHREAD_EXPLICIT_SCHED,
which is kind of useless. Change this here to
PTHREAD_INHERIT_SCHED; that way the -p option to set realtime
diff --git a/net/asterisk/pkg-plist b/net/asterisk/pkg-plist
index 7174e108f1d7..732e179f9636 100644
--- a/net/asterisk/pkg-plist
+++ b/net/asterisk/pkg-plist
@@ -1240,8 +1240,8 @@ spool/asterisk/voicemail/default/1234/en/unavail.gsm
@dirrm spool/asterisk/voicemail
@dirrm spool/asterisk/tmp
@dirrm spool/asterisk
-@dirrm log/asterisk/cdr-csv
-@dirrm log/asterisk/cdr-custom
-@dirrm log/asterisk/cel-custom
-@dirrm log/asterisk
+@dirrmtry log/asterisk/cdr-csv
+@dirrmtry log/asterisk/cdr-custom
+@dirrmtry log/asterisk/cel-custom
+@dirrmtry log/asterisk
@dirrmtry db/asterisk
diff --git a/net/asterisk10/Makefile b/net/asterisk10/Makefile
index 976bd839ebcc..97a88ce19406 100644
--- a/net/asterisk10/Makefile
+++ b/net/asterisk10/Makefile
@@ -3,7 +3,7 @@
PORTNAME= asterisk
PORTVERSION= 10.12.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/ \
http://downloads.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -24,7 +24,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gsm=${LOCALBASE}
LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/openh323
-USE_GCC= any
+USE_CSTD= gnu89
USE_GMAKE= yes
USE_GNOME= libxml2
USES= bison
@@ -279,7 +279,7 @@ post-patch:
post-configure:
.if !empty(PORT_OPTIONS:MMYSQL) || !empty(PORT_OPTIONS:MNEWG711) || !empty(PORT_OPTIONS:MOOH323) || !empty(PORT_OPTIONS:MH323)
- @cd ${WRKSRC} && gmake menuselect.makeopts
+ @cd ${WRKSRC} && ${GMAKE} menuselect.makeopts
.if ${PORT_OPTIONS:MMYSQL}
@cd ${WRKSRC} && ./menuselect/menuselect --enable res_config_mysql menuselect.makeopts
@cd ${WRKSRC} && ./menuselect/menuselect --enable app_mysql menuselect.makeopts
diff --git a/net/asterisk10/files/patch-main::utils.c b/net/asterisk10/files/patch-main::utils.c
index 7440848a1521..8b6e268d1cb9 100644
--- a/net/asterisk10/files/patch-main::utils.c
+++ b/net/asterisk10/files/patch-main::utils.c
@@ -6,7 +6,7 @@
-#ifdef __linux__
- /* On Linux, pthread_attr_init() defaults to PTHREAD_EXPLICIT_SCHED,
-+#ifdef __linux__ || defined(__FreeBSD__)
++#if defined(__linux__) || defined(__FreeBSD__)
+ /* On Linux and FreeBSD, pthread_attr_init() defaults to PTHREAD_EXPLICIT_SCHED,
which is kind of useless. Change this here to
PTHREAD_INHERIT_SCHED; that way the -p option to set realtime
diff --git a/net/asterisk10/pkg-plist b/net/asterisk10/pkg-plist
index b30986b0043f..98d1c4f6eaa2 100644
--- a/net/asterisk10/pkg-plist
+++ b/net/asterisk10/pkg-plist
@@ -1245,8 +1245,8 @@ spool/asterisk/voicemail/default/1234/en/unavail.gsm
@dirrm spool/asterisk/voicemail
@dirrm spool/asterisk/tmp
@dirrm spool/asterisk
-@dirrm log/asterisk/cdr-csv
-@dirrm log/asterisk/cdr-custom
-@dirrm log/asterisk/cel-custom
-@dirrm log/asterisk
+@dirrmtry log/asterisk/cdr-csv
+@dirrmtry log/asterisk/cdr-custom
+@dirrmtry log/asterisk/cel-custom
+@dirrmtry log/asterisk
@dirrmtry db/asterisk