aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2012-02-18 16:19:56 +0000
committerGabor Pali <pgj@FreeBSD.org>2012-02-18 16:19:56 +0000
commitb00b470facc8c032ab8ae9d13aa131a1017b16ba (patch)
tree41d798f2790a76bdea44fdfc970523fce0df96ac
parent50dfbf8bd43d39e8f8df37080d8ae3ee5c6a27de (diff)
downloadports-b00b470facc8c032ab8ae9d13aa131a1017b16ba.tar.gz
ports-b00b470facc8c032ab8ae9d13aa131a1017b16ba.zip
Notes
-rw-r--r--lang/ghc/bsd.hackage.mk1
-rw-r--r--security/Makefile1
-rw-r--r--security/hs-certificate/Makefile34
-rw-r--r--security/hs-certificate/distinfo2
-rw-r--r--security/hs-certificate/pkg-descr5
5 files changed, 43 insertions, 0 deletions
diff --git a/lang/ghc/bsd.hackage.mk b/lang/ghc/bsd.hackage.mk
index 779d6cf0fabf..a780ed52f762 100644
--- a/lang/ghc/bsd.hackage.mk
+++ b/lang/ghc/bsd.hackage.mk
@@ -43,6 +43,7 @@ cereal_port= devel/hs-cereal
cairo_port= graphics/hs-cairo
case-insensitive_port= textproc/hs-case-insensitive
categories_port= math/hs-categories
+certificate_port= security/hs-certificate
cgi_port= www/hs-cgi
checkers_port= devel/hs-checkers
citeproc-hs_port= textproc/hs-citeproc-hs
diff --git a/security/Makefile b/security/Makefile
index 453b7aac945c..19d392e62502 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -187,6 +187,7 @@
SUBDIR += hs-Crypto
SUBDIR += hs-RSA
SUBDIR += hs-SHA
+ SUBDIR += hs-certificate
SUBDIR += hs-clientsession
SUBDIR += hs-cprng-aes
SUBDIR += hs-crypto-api
diff --git a/security/hs-certificate/Makefile b/security/hs-certificate/Makefile
new file mode 100644
index 000000000000..a165df21ccb7
--- /dev/null
+++ b/security/hs-certificate/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: hs-certificate
+# Date created: December 26, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= certificate
+PORTVERSION= 1.0.1
+CATEGORIES= security haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Certificates and Key Reader/Writer
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+USE_CABAL= asn1-data>=0.6.1 base64-bytestring crypto-pubkey-types mtl
+
+OPTIONS= EXECUTABLE "Build the executable" off
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
+.include <bsd.port.options.mk>
+
+.if defined(WITH_EXECUTABLE)
+CONFIGURE_ARGS+= --flags="executable"
+USE_CABAL+= cmdargs text>=0.11 cryptohash cryptocipher>=0.3.0
+EXECUTABLE+= certificate
+.else
+CONFIGURE_ARGS+= --flags="-executable"
+.endif
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/security/hs-certificate/distinfo b/security/hs-certificate/distinfo
new file mode 100644
index 000000000000..1847ddecf778
--- /dev/null
+++ b/security/hs-certificate/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/certificate-1.0.1.tar.gz) = 2028b8c9241b89afcff6f6fa7dc2b079d1fb4d928e495bf637e85913867e6967
+SIZE (cabal/certificate-1.0.1.tar.gz) = 13705
diff --git a/security/hs-certificate/pkg-descr b/security/hs-certificate/pkg-descr
new file mode 100644
index 000000000000..1aa954888f16
--- /dev/null
+++ b/security/hs-certificate/pkg-descr
@@ -0,0 +1,5 @@
+Certificates and Key reader/writer. At the moment only X509 certificate
+and unencrypted private key are supported, but will include PGP
+certificate and pkcs8 private keys.
+
+WWW: http://github.com/vincenthz/hs-certificate