aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2007-04-11 06:05:51 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2007-04-11 06:05:51 +0000
commitb04066cf2829068f1440fd3ab9794c8ed3cc93b4 (patch)
tree627d4f73926e6032ad6e428a3cb98762d012264d
parent47dba761ddbfeadba587d80d4ec285426b699635 (diff)
downloadports-b04066cf2829068f1440fd3ab9794c8ed3cc93b4.tar.gz
ports-b04066cf2829068f1440fd3ab9794c8ed3cc93b4.zip
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/daemonlogger/Makefile23
-rw-r--r--net/daemonlogger/distinfo3
-rw-r--r--net/daemonlogger/files/daemonlogger.sh.in26
-rw-r--r--net/daemonlogger/pkg-descr9
5 files changed, 62 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 18912e2b752b..454a571ce229 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -85,6 +85,7 @@
SUBDIR += cvsupchk
SUBDIR += cvsync
SUBDIR += cyphesis
+ SUBDIR += daemonlogger
SUBDIR += danamics
SUBDIR += dante
SUBDIR += datapipe
diff --git a/net/daemonlogger/Makefile b/net/daemonlogger/Makefile
new file mode 100644
index 000000000000..b5edde5b5765
--- /dev/null
+++ b/net/daemonlogger/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: daemonlogger
+# Date created: 10 April 2007
+# Whom: Wesley Shields <wxs@atarininja.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= daemonlogger
+PORTVERSION= 0.9
+CATEGORIES= net
+MASTER_SITES= http://www.snort.org/dl/daemonlogger/
+
+MAINTAINER= wxs@atarininja.org
+COMMENT= A packet sniffer capable of running as a daemon and as a software tap
+
+LIB_DEPENDS= dnet.1:${PORTSDIR}/net/libdnet
+
+GNU_CONFIGURE= yes
+USE_RC_SUBR= daemonlogger.sh
+
+PLIST_FILES= bin/daemonlogger
+
+.include <bsd.port.mk>
diff --git a/net/daemonlogger/distinfo b/net/daemonlogger/distinfo
new file mode 100644
index 000000000000..cbdd865bf19f
--- /dev/null
+++ b/net/daemonlogger/distinfo
@@ -0,0 +1,3 @@
+MD5 (daemonlogger-0.9.tar.gz) = 1cd38b25bf597a0fbf797f0a48ff0122
+SHA256 (daemonlogger-0.9.tar.gz) = 4f58284026f1df19457b365d9088976a00ccf188bb193bfd3567325dc6b41b46
+SIZE (daemonlogger-0.9.tar.gz) = 107994
diff --git a/net/daemonlogger/files/daemonlogger.sh.in b/net/daemonlogger/files/daemonlogger.sh.in
new file mode 100644
index 000000000000..62cbe985a17f
--- /dev/null
+++ b/net/daemonlogger/files/daemonlogger.sh.in
@@ -0,0 +1,26 @@
+#!/bin/sh
+
+# PROVIDE: daemonlogger
+# REQUIRE: NETWORKING
+
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf to enable daemonlogger:
+# daemonlogger_enable (bool): Set to "NO" by default.
+# Set it to "YES" to enable daemonlogger
+# daemonlogger_flags (string): Set to "-d -l" by default.
+
+. %%RC_SUBR%%
+
+name="daemonlogger"
+rcvar=`set_rcvar`
+
+command_args=" > /dev/null 2>&1"
+
+load_rc_config $name
+
+: ${daemonlogger_enable:="NO"}
+: ${daemonlogger_flags:="-d -l /var/log"}
+
+command=%%PREFIX%%/bin/daemonlogger
+
+run_rc_command "$1"
diff --git a/net/daemonlogger/pkg-descr b/net/daemonlogger/pkg-descr
new file mode 100644
index 000000000000..2af968af384c
--- /dev/null
+++ b/net/daemonlogger/pkg-descr
@@ -0,0 +1,9 @@
+A packet sniffer designed to run as a daemon with automatic log rotation.
+It will also act as a software tap injecting packets onto a second
+interface if configured as such.
+
+WWW: http://www.snort.org/dl/daemonlogger/
+
+-- WXS
+Wesley Shields
+wxs@csh.rit.edu