aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarlo Strub <cs@FreeBSD.org>2013-01-14 22:48:21 +0000
committerCarlo Strub <cs@FreeBSD.org>2013-01-14 22:48:21 +0000
commitb0a6e12de7cb399c0313719f0f8cb7292e1b18ee (patch)
treebd30d0edf3ebf44522cbf7eefc2b91911df8d1fc
parentcce2aa21fd821509e6945829c7f9e4c964cb1b35 (diff)
downloadports-b0a6e12de7cb399c0313719f0f8cb7292e1b18ee.tar.gz
ports-b0a6e12de7cb399c0313719f0f8cb7292e1b18ee.zip
- Update to 8.7
- Important change: php-fcgi removed
Notes
Notes: svn path=/head/; revision=310415
-rw-r--r--UPDATING8
-rw-r--r--www/hiawatha/Makefile16
-rw-r--r--www/hiawatha/distinfo4
-rw-r--r--www/hiawatha/files/php-fcgi.in34
-rw-r--r--www/hiawatha/files/pkg-message.in3
-rw-r--r--www/hiawatha/pkg-plist6
6 files changed, 18 insertions, 53 deletions
diff --git a/UPDATING b/UPDATING
index b752a9c6b45e..3c96df182d8f 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,14 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20130114:
+ AFFECTS: users of www/hiawatha
+ AUTHOR: cs@FreeBSD.org
+
+ php-fcgi has been removed upstream from hiawatha and is not supported anymore.
+ It is recommended to move to another FastCGI implementation, e.g. PHP-FPM
+ (lang/php5).
+
20130113:
AFFECTS: users of security/openvpn*
AUTHOR: mandree@FreeBSD.org
diff --git a/www/hiawatha/Makefile b/www/hiawatha/Makefile
index f7a11a7c5afb..83db471ad5cb 100644
--- a/www/hiawatha/Makefile
+++ b/www/hiawatha/Makefile
@@ -3,7 +3,7 @@
#
PORTNAME= hiawatha
-PORTVERSION= 8.6
+PORTVERSION= 8.7
CATEGORIES= www
MASTER_SITES= http://www.hiawatha-webserver.org/files/ \
http://www.c-s.li/ports/
@@ -14,16 +14,16 @@ COMMENT= Advanced and secure webserver for Unix
LICENSE= GPLv2
PORTDOCS= AUTHORS ChangeLog INSTALL
-CONFIG_FILES= hiawatha.conf mimetype.conf cgi-wrapper.conf php-fcgi.conf \
- toolkit.conf index.xslt
+CONFIG_FILES= hiawatha.conf mimetype.conf cgi-wrapper.conf toolkit.conf \
+ index.xslt
-MAN1= cgi-wrapper.1 hiawatha.1 php-fcgi.1 ssi-cgi.1 wigwam.1
+MAN1= cgi-wrapper.1 hiawatha.1 ssi-cgi.1 wigwam.1
MAKE_JOBS_SAFE= yes
SUB_FILES= pkg-message
USE_CMAKE= yes
USE_LDCONFIG= yes
-USE_RC_SUBR= hiawatha php-fcgi
+USE_RC_SUBR= hiawatha
WANT_GNOME= yes
CMAKE_ARGS+= -DCMAKE_INSTALL_BINDIR=${PREFIX}/bin \
@@ -128,12 +128,10 @@ PLIST_SUB+= ECHO_MSG=${ECHO_MSG}
post-patch:
@${REINPLACE_CMD} -e 's|/usr|${PREFIX}|g' \
${WRKSRC}/man/hiawatha.1.in ${WRKSRC}/man/cgi-wrapper.1.in \
- ${WRKSRC}/man/php-fcgi.1.in ${WRKSRC}/config/cgi-wrapper.conf \
- ${WRKSRC}/config/hiawatha.conf.in ${WRKSRC}/config/php-fcgi.conf.in
+ ${WRKSRC}/config/cgi-wrapper.conf ${WRKSRC}/config/hiawatha.conf.in
@${REINPLACE_CMD} -e 's|/etc/hiawatha|${ETCDIR}|g' \
- ${WRKSRC}/man/hiawatha.1.in ${WRKSRC}/man/cgi-wrapper.1.in \
- ${WRKSRC}/man/php-fcgi.1.in
+ ${WRKSRC}/man/hiawatha.1.in ${WRKSRC}/man/cgi-wrapper.1.in
post-install:
.if ${PORT_OPTIONS:MDOCS}
diff --git a/www/hiawatha/distinfo b/www/hiawatha/distinfo
index ebd8baeb0562..523f6bcc4f32 100644
--- a/www/hiawatha/distinfo
+++ b/www/hiawatha/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hiawatha-8.6.tar.gz) = 1a7fa98ce66beb54fc8490cc787461d719a98cb0e4a81caedfa18ac8b5ba3b3b
-SIZE (hiawatha-8.6.tar.gz) = 656420
+SHA256 (hiawatha-8.7.tar.gz) = c35e1e975962e1105d7914f74901e304ba90681985c94236c113eaca502b5e34
+SIZE (hiawatha-8.7.tar.gz) = 656403
diff --git a/www/hiawatha/files/php-fcgi.in b/www/hiawatha/files/php-fcgi.in
deleted file mode 100644
index 2e12f94b7e56..000000000000
--- a/www/hiawatha/files/php-fcgi.in
+++ /dev/null
@@ -1,34 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-# PROVIDE: php_fcgi
-# REQUIRE: LOGIN
-# KEYWORD: shutdown
-
-# Add the following line(s) to /etc/rc.conf:
-# php_fcgi_enable (bool): Set to "NO" by default, set it
-# to "YES" to enable php_fcgi.
-
-. /etc/rc.subr
-
-name="php_fcgi"
-rcvar=php_fcgi_enable
-
-load_rc_config $name
-
-: ${php_fcgi_enable="NO"}
-
-command="%%PREFIX%%/sbin/php-fcgi"
-pidfile=${php_fcgi_pidfile="/var/run/php-fcgi.pid"}
-procname=${php_fcgi_app="%%LOCALBASE%%/bin/php-cgi"}
-
-stop_postcmd="${name}_stop_postcmd"
-
-php_fcgi_stop_postcmd()
-{
- rm -f ${pidfile}
-}
-
-run_rc_command "$1"
diff --git a/www/hiawatha/files/pkg-message.in b/www/hiawatha/files/pkg-message.in
index cc06ab8ae12a..8910cecef72b 100644
--- a/www/hiawatha/files/pkg-message.in
+++ b/www/hiawatha/files/pkg-message.in
@@ -7,9 +7,6 @@ Edit the configuration files in %%ETCDIR%% to suit your needs.
Add hiawatha_enable="YES" to rc.conf and start Hiawatha by running:
%%PREFIX%%/etc/rc.d/hiawatha start
-To use php-fcgi, add php_fcgi_enable="YES" to rc.conf and start it by running:
-%%PREFIX%%/etc/rc.d/php-fcgi start
-
If you configured Hiawatha with Monitor, download and install the respective
files needed to monitor your webserver:
http://www.hiawatha-webserver.org/monitor
diff --git a/www/hiawatha/pkg-plist b/www/hiawatha/pkg-plist
index 1bbb7d13974c..4e5257c8aa70 100644
--- a/www/hiawatha/pkg-plist
+++ b/www/hiawatha/pkg-plist
@@ -1,7 +1,6 @@
bin/ssi-cgi
sbin/cgi-wrapper
sbin/hiawatha
-sbin/php-fcgi
sbin/wigwam
@unexec if cmp -s %D/etc/hiawatha/cgi-wrapper.conf.sample %D/etc/hiawatha/cgi-wrapper.conf ; then rm -f %D/etc/hiawatha/cgi-wrapper.conf; fi
%%ETCDIR%%/cgi-wrapper.conf.sample
@@ -15,9 +14,6 @@ sbin/wigwam
@unexec if cmp -s %D/etc/hiawatha/mimetype.conf.sample %D/etc/hiawatha/mimetype.conf ; then rm -f %D/etc/hiawatha/mimetype.conf; fi
%%ETCDIR%%/mimetype.conf.sample
@exec if [ ! -f %D/etc/hiawatha/mimetype.conf.sample ] ; then cp -p %D/%F %%ETCDIR%%/mimetype.conf; fi
-@unexec if cmp -s %D/etc/hiawatha/php-fcgi.conf.sample %D/etc/hiawatha/php-fcgi.conf ; then rm -f %D/etc/hiawatha/php-fcgi.conf; fi
-%%ETCDIR%%/php-fcgi.conf.sample
-@exec if [ ! -f %D/etc/hiawatha/php-fcgi.conf.sample ] ; then cp -p %D/%F %%ETCDIR%%/php-fcgi.conf; fi
@unexec if cmp -s %D/etc/hiawatha/toolkit.conf.sample %D/etc/hiawatha/toolkit.conf ; then rm -f %D/etc/hiawatha/toolkit.conf; fi
%%ETCDIR%%/toolkit.conf.sample
@exec if [ ! -f %D/etc/hiawatha/toolkit.conf.sample ] ; then cp -p %D/%F %%ETCDIR%%/toolkit.conf; fi
@@ -29,5 +25,5 @@ sbin/wigwam
@unexec t=`/bin/ls %D/www/hiawatha`; if [ -z "$t" ]; then %%ECHO_MSG%% "===> WWW directory is empty, removing it."; rmdir %D/www/hiawatha; fi;
lib/hiawatha/libpolarssl.so
lib/hiawatha/libpolarssl.so.2
-lib/hiawatha/libpolarssl.so.1.2.0
+lib/hiawatha/libpolarssl.so.1.2.3
@dirrm lib/hiawatha