aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Zhilin <mizhka@FreeBSD.org>2024-04-19 18:46:43 +0000
committerMichael Zhilin <mizhka@FreeBSD.org>2024-05-05 18:05:29 +0000
commitb107d06a6a22b120cb96d8febb00f8c4d56f7749 (patch)
tree8df7aec64627ec6cd0a4d88feabb7f077fd831d9
parent73ee97964dbcc116d77173ae970b6044bd420991 (diff)
downloadports-b107d06a6a22b120cb96d8febb00f8c4d56f7749.tar.gz
ports-b107d06a6a22b120cb96d8febb00f8c4d56f7749.zip
java/eclipse-yaml-editor: new port to work with YAML in Eclipse IDE
-rw-r--r--java/Makefile1
-rw-r--r--java/eclipse-yaml-editor/Makefile29
-rw-r--r--java/eclipse-yaml-editor/distinfo3
-rw-r--r--java/eclipse-yaml-editor/pkg-descr2
-rw-r--r--java/eclipse-yaml-editor/pkg-plist4
5 files changed, 39 insertions, 0 deletions
diff --git a/java/Makefile b/java/Makefile
index f0df61383329..6230375f2549 100644
--- a/java/Makefile
+++ b/java/Makefile
@@ -31,6 +31,7 @@
SUBDIR += eclipse-findbugs
SUBDIR += eclipse-pydev
SUBDIR += eclipse-shelled
+ SUBDIR += eclipse-yaml-editor
SUBDIR += hamcrest
SUBDIR += icedtea-web
SUBDIR += infobus
diff --git a/java/eclipse-yaml-editor/Makefile b/java/eclipse-yaml-editor/Makefile
new file mode 100644
index 000000000000..08fa70aac718
--- /dev/null
+++ b/java/eclipse-yaml-editor/Makefile
@@ -0,0 +1,29 @@
+PORTNAME= eclipse-yaml-editor
+PORTVERSION= 1.9.0
+CATEGORIES= java devel
+
+MAINTAINER= mizhka@FreeBSD.org
+COMMENT= Eclipse plugin for YAML editing
+WWW= https://github.com/de-jcup/eclipse-yaml-editor/wiki
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= ${LOCALBASE}/bin/eclipse:java/eclipse
+
+USE_GITHUB= YES
+GH_TUPLE= de-jcup:update-site-${PORTNAME}:99ea8dc
+
+NO_ARCH= YES
+NO_BUILD= YES
+
+PLUGINDIR= share/eclipse/dropins/${PORTNAME}/eclipse
+
+PLIST_SUB= PORTVERSION=${PORTVERSION}
+
+do-install:
+ @(cd ${WRKSRC}/update-site/ && \
+ ${COPYTREE_SHARE} "features plugins" ${STAGEDIR}${PREFIX}/${PLUGINDIR})
+ @(${FIND} ${STAGEDIR}${PREFIX}/${PLUGINDIR} -type f \
+ ! -name "*${PORTVERSION}*" -delete)
+
+.include <bsd.port.mk>
diff --git a/java/eclipse-yaml-editor/distinfo b/java/eclipse-yaml-editor/distinfo
new file mode 100644
index 000000000000..a3bedf2ed4c1
--- /dev/null
+++ b/java/eclipse-yaml-editor/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1713551622
+SHA256 (de-jcup-update-site-eclipse-yaml-editor-1.9.0-99ea8dc_GH0.tar.gz) = 546a10086a6c3a826ca2c66f89f90b6a1e4a6e78bc73e1b24ab44d91bfcdf22f
+SIZE (de-jcup-update-site-eclipse-yaml-editor-1.9.0-99ea8dc_GH0.tar.gz) = 2542822
diff --git a/java/eclipse-yaml-editor/pkg-descr b/java/eclipse-yaml-editor/pkg-descr
new file mode 100644
index 000000000000..6afe56de04ec
--- /dev/null
+++ b/java/eclipse-yaml-editor/pkg-descr
@@ -0,0 +1,2 @@
+Just a YAML editor, a plugin for Eclipse with plenty of features like
+formatting, syntax highlighting and analysis, autocompletion, outline and etc.
diff --git a/java/eclipse-yaml-editor/pkg-plist b/java/eclipse-yaml-editor/pkg-plist
new file mode 100644
index 000000000000..660186201f14
--- /dev/null
+++ b/java/eclipse-yaml-editor/pkg-plist
@@ -0,0 +1,4 @@
+share/eclipse/dropins/eclipse-yaml-editor/eclipse/features/de.jcup.yamleditor_%%PORTVERSION%%.jar
+share/eclipse/dropins/eclipse-yaml-editor/eclipse/features/de.jcup.yamleditor_%%PORTVERSION%%.jar.sha256
+share/eclipse/dropins/eclipse-yaml-editor/eclipse/plugins/de.jcup.yamleditor_%%PORTVERSION%%.jar
+share/eclipse/dropins/eclipse-yaml-editor/eclipse/plugins/de.jcup.yamleditor_%%PORTVERSION%%.jar.sha256