aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-07-17 06:35:36 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-07-17 06:35:36 +0000
commitb10905379b924baabd8b7451b2387ec549d70aaa (patch)
tree10f265882e0dca26f3c108eee83b2701c675dace
parent5374d2bc438016773ad3ae806a41217b3563b94a (diff)
Notes
-rw-r--r--audio/rubberband/Makefile27
-rw-r--r--audio/rubberband/distinfo7
-rw-r--r--audio/rubberband/files/patch-Makefile.in11
-rw-r--r--audio/rubberband/files/patch-src_StretcherImpl.cpp11
-rw-r--r--audio/rubberband/files/patch-src_StretcherProcess.cpp12
-rw-r--r--audio/rubberband/files/patch-src_system_sysutils.h12
-rw-r--r--audio/rubberband/pkg-descr2
-rw-r--r--audio/rubberband/pkg-plist2
8 files changed, 28 insertions, 56 deletions
diff --git a/audio/rubberband/Makefile b/audio/rubberband/Makefile
index a0fc1d8239b4..a476247f4a32 100644
--- a/audio/rubberband/Makefile
+++ b/audio/rubberband/Makefile
@@ -2,35 +2,28 @@
# $FreeBSD$
PORTNAME= rubberband
-PORTVERSION= 1.8.1
-PORTREVISION= 2
+DISTVERSION= 1.8.2
CATEGORIES= audio
-MASTER_SITES= http://breakfastquay.com/files/releases/23/
+MASTER_SITES= https://breakfastquay.com/files/releases/
+
+PATCH_SITES= https://github.com/breakfastquay/${PORTNAME}/commit/
+PATCHFILES= 03202fa4749c0b4e264f2115bb49028267e2a572.patch:-p1
MAINTAINER= ports@FreeBSD.org
-COMMENT= Vamp audio analysis plugin SDK
+COMMENT= Audio time-stretching and pitch-shifting library and utility program
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:audio/ladspa
+BUILD_DEPENDS= ladspa>0:audio/ladspa \
+ lv2>0:audio/lv2
LIB_DEPENDS= libsndfile.so:audio/libsndfile \
libsamplerate.so:audio/libsamplerate \
libvamp-sdk.so:audio/vamp-plugin-sdk \
libfftw3.so:math/fftw3
-RUN_DEPENDS= ${LOCALBASE}/include/ladspa.h:audio/ladspa
-USES= gmake pathfix pkgconfig tar:bzip2
+USES= gmake pkgconfig tar:bzip2
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CFLAGS+= -I${LOCALBASE}/include
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
-post-install:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/rubberband
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/librubberband.so.[0-9].*
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/ladspa/*.so
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/vamp/*.so
-
.include <bsd.port.mk>
diff --git a/audio/rubberband/distinfo b/audio/rubberband/distinfo
index 8d5c3fbcb9e6..591d34c42065 100644
--- a/audio/rubberband/distinfo
+++ b/audio/rubberband/distinfo
@@ -1,2 +1,5 @@
-SHA256 (rubberband-1.8.1.tar.bz2) = ff0c63b0b5ce41f937a8a3bc560f27918c5fe0b90c6bc1cb70829b86ada82b75
-SIZE (rubberband-1.8.1.tar.bz2) = 177501
+TIMESTAMP = 1531808940
+SHA256 (rubberband-1.8.2.tar.bz2) = 86bed06b7115b64441d32ae53634fcc0539a50b9b648ef87443f936782f6c3ca
+SIZE (rubberband-1.8.2.tar.bz2) = 182232
+SHA256 (03202fa4749c0b4e264f2115bb49028267e2a572.patch) = ec24ae424a5815aecfa3a5106163d922bc4933e77cd7948299d24c4c4451bb93
+SIZE (03202fa4749c0b4e264f2115bb49028267e2a572.patch) = 1304
diff --git a/audio/rubberband/files/patch-Makefile.in b/audio/rubberband/files/patch-Makefile.in
new file mode 100644
index 000000000000..c4346d6c4f80
--- /dev/null
+++ b/audio/rubberband/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2018-05-15 17:43:39 UTC
++++ Makefile.in
+@@ -183,7 +183,7 @@ install: all
+ cp $(DYNAMIC_TARGET) $(DESTDIR)$(INSTALL_LIBDIR)/$(LIBNAME)$(DYNAMIC_EXTENSION).$(DYNAMIC_FULL_VERSION)
+ ln -s $(LIBNAME)$(DYNAMIC_EXTENSION).$(DYNAMIC_FULL_VERSION) $(DESTDIR)$(INSTALL_LIBDIR)/$(LIBNAME)$(DYNAMIC_EXTENSION).$(DYNAMIC_ABI_VERSION)
+ ln -s $(LIBNAME)$(DYNAMIC_EXTENSION).$(DYNAMIC_FULL_VERSION) $(DESTDIR)$(INSTALL_LIBDIR)/$(LIBNAME)$(DYNAMIC_EXTENSION)
+- cp -f $(JNI_TARGET) $(DESTDIR)$(INSTALL_LIBDIR)/$(JNINAME)$(DYNAMIC_EXTENSION)
++ #cp -f $(JNI_TARGET) $(DESTDIR)$(INSTALL_LIBDIR)/$(JNINAME)$(DYNAMIC_EXTENSION)
+ cp $(VAMP_TARGET) $(DESTDIR)$(INSTALL_VAMPDIR)
+ cp vamp/vamp-rubberband.cat $(DESTDIR)$(INSTALL_VAMPDIR)
+ cp $(LADSPA_TARGET) $(DESTDIR)$(INSTALL_LADSPADIR)
diff --git a/audio/rubberband/files/patch-src_StretcherImpl.cpp b/audio/rubberband/files/patch-src_StretcherImpl.cpp
deleted file mode 100644
index c8bef0eabb74..000000000000
--- a/audio/rubberband/files/patch-src_StretcherImpl.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/StretcherImpl.cpp.orig 2012-10-28 10:30:09 UTC
-+++ src/StretcherImpl.cpp
-@@ -38,7 +38,7 @@
- #include "base/Profiler.h"
-
- #ifndef _WIN32
--#include <alloca.h>
-+#include <stdlib.h>
- #endif
-
- #include <cassert>
diff --git a/audio/rubberband/files/patch-src_StretcherProcess.cpp b/audio/rubberband/files/patch-src_StretcherProcess.cpp
deleted file mode 100644
index 871854ade33e..000000000000
--- a/audio/rubberband/files/patch-src_StretcherProcess.cpp
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/StretcherProcess.cpp.orig 2012-10-28 10:30:09 UTC
-+++ src/StretcherProcess.cpp
-@@ -35,7 +35,8 @@
- #include "system/VectorOps.h"
-
- #ifndef _WIN32
--#include <alloca.h>
-+/* linux stdlib include alloca.h */
-+#include <stdlib.h>
- #endif
-
- #include <cassert>
diff --git a/audio/rubberband/files/patch-src_system_sysutils.h b/audio/rubberband/files/patch-src_system_sysutils.h
deleted file mode 100644
index ef3ef41d6e40..000000000000
--- a/audio/rubberband/files/patch-src_system_sysutils.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/system/sysutils.h.orig 2012-10-28 10:30:09 UTC
-+++ src/system/sysutils.h
-@@ -41,7 +41,8 @@
- #include <malloc.h>
- #else
- #ifndef __MSVC__
--#include <alloca.h>
-+/* linux stdlib also includes alloca.h */
-+#include <stdlib.h>
- #endif
- #endif
-
diff --git a/audio/rubberband/pkg-descr b/audio/rubberband/pkg-descr
index e57dcc6facda..2962525f4fd8 100644
--- a/audio/rubberband/pkg-descr
+++ b/audio/rubberband/pkg-descr
@@ -3,4 +3,4 @@ time-stretching and pitch-shifting. It permits you to change the tempo
and pitch of an audio stream or recording dynamically and independently
of one another.
-WWW: http://breakfastquay.com/rubberband/
+WWW: https://breakfastquay.com/rubberband/
diff --git a/audio/rubberband/pkg-plist b/audio/rubberband/pkg-plist
index 3939f6bc38ed..13b5ef8ff096 100644
--- a/audio/rubberband/pkg-plist
+++ b/audio/rubberband/pkg-plist
@@ -6,7 +6,7 @@ lib/ladspa/ladspa-rubberband.so
lib/librubberband.a
lib/librubberband.so
lib/librubberband.so.2
-lib/librubberband.so.2.1.0
+lib/librubberband.so.2.1.1
lib/vamp/vamp-rubberband.cat
lib/vamp/vamp-rubberband.so
libdata/pkgconfig/rubberband.pc