aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-07-19 07:23:20 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-07-19 07:23:20 +0000
commitb124da0367609dcb91bd9ddc68e3db452678c66f (patch)
tree4db86dc34c768bd7fd390d476015597605f9cd8e
parent993768b304c545e0b2784552278066ca831015ff (diff)
downloadports-b124da0367609dcb91bd9ddc68e3db452678c66f.tar.gz
ports-b124da0367609dcb91bd9ddc68e3db452678c66f.zip
Notes
-rw-r--r--print/pecl-panda/Makefile11
-rw-r--r--print/pecl-panda/pkg-message8
-rw-r--r--print/pecl-panda/pkg-plist2
-rw-r--r--print/pecl-pdflib/Makefile15
-rw-r--r--print/pecl-pdflib/pkg-message8
-rw-r--r--print/pecl-pdflib/pkg-plist2
6 files changed, 7 insertions, 39 deletions
diff --git a/print/pecl-panda/Makefile b/print/pecl-panda/Makefile
index 4fa03b137d00..6d9edb313e77 100644
--- a/print/pecl-panda/Makefile
+++ b/print/pecl-panda/Makefile
@@ -7,6 +7,7 @@
PORTNAME= panda
PORTVERSION= 0.1.0
+PORTREVISION= 1
CATEGORIES= print pear
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
@@ -19,16 +20,8 @@ COMMENT= A PECL extension to create PDF documents
LIB_DEPENDS= panda.0:${PORTSDIR}/print/panda
USE_PHP= yes
-USE_PHPIZE= yes
+USE_PHPEXT= yes
CONFIGURE_ARGS= --with-panda=${LOCALBASE}
-do-install:
- @${MKDIR} ${PREFIX}/lib/php/${PHP_EXT_DIR}
- @${INSTALL_DATA} ${WRKSRC}/modules/panda.so \
- ${PREFIX}/lib/php/${PHP_EXT_DIR}
-
-post-install:
- @${CAT} ${PKGMESSAGE}
-
.include <bsd.port.mk>
diff --git a/print/pecl-panda/pkg-message b/print/pecl-panda/pkg-message
deleted file mode 100644
index e531d3bdf0b2..000000000000
--- a/print/pecl-panda/pkg-message
+++ /dev/null
@@ -1,8 +0,0 @@
-*****************************************************************************
-
-To automatically load the installed extension add the following line to
-your php.ini configuration file:
-
-extension="panda.so"
-
-*****************************************************************************
diff --git a/print/pecl-panda/pkg-plist b/print/pecl-panda/pkg-plist
deleted file mode 100644
index 57f7243c6695..000000000000
--- a/print/pecl-panda/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-lib/php/%%PHP_EXT_DIR%%/panda.so
-@unexec rmdir %D/lib/php/%%PHP_EXT_DIR%% 2> /dev/null || true
diff --git a/print/pecl-pdflib/Makefile b/print/pecl-pdflib/Makefile
index c0a2c9094931..54ec889fd588 100644
--- a/print/pecl-pdflib/Makefile
+++ b/print/pecl-pdflib/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pdflib
PORTVERSION= 2.0
+PORTREVISION= 1
CATEGORIES= print pear
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
@@ -18,17 +19,11 @@ COMMENT= A PECL extension to create PDF on the fly
LIB_DEPENDS= pdf.7:${PORTSDIR}/print/pdflib
-USE_PHP= yes
-USE_PHPIZE= yes
+USE_PHP= gd
+USE_PHP_BUILD= yes
+USE_PHPEXT= yes
+PHP_MODNAME= pdf
CONFIGURE_ARGS= --with-pdflib=${LOCALBASE}
-do-install:
- @${MKDIR} ${PREFIX}/lib/php/${PHP_EXT_DIR}
- @${INSTALL_DATA} ${WRKSRC}/modules/pdf.so \
- ${PREFIX}/lib/php/${PHP_EXT_DIR}
-
-post-install:
- @${CAT} ${PKGMESSAGE}
-
.include <bsd.port.mk>
diff --git a/print/pecl-pdflib/pkg-message b/print/pecl-pdflib/pkg-message
deleted file mode 100644
index 0e8cd931fe91..000000000000
--- a/print/pecl-pdflib/pkg-message
+++ /dev/null
@@ -1,8 +0,0 @@
-*****************************************************************************
-
-To automatically load the installed extension add the following line to
-your php.ini configuration file:
-
-extension="pdf.so"
-
-*****************************************************************************
diff --git a/print/pecl-pdflib/pkg-plist b/print/pecl-pdflib/pkg-plist
deleted file mode 100644
index e353e45ff43f..000000000000
--- a/print/pecl-pdflib/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-lib/php/%%PHP_EXT_DIR%%/pdf.so
-@unexec rmdir %D/lib/php/%%PHP_EXT_DIR%% 2> /dev/null || true