aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2018-04-05 14:26:33 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2018-04-05 14:26:33 +0000
commitb13b99a093ca686122f259f7b5b3dd2ac80109d5 (patch)
tree2458dce22317cd31478b63c10f5d4c934dd7dff1
parentf0566514273aac2430ee5d0be5b1fc94b85bea23 (diff)
downloadports-b13b99a093ca686122f259f7b5b3dd2ac80109d5.tar.gz
ports-b13b99a093ca686122f259f7b5b3dd2ac80109d5.zip
Notes
-rw-r--r--math/qtiplot/Makefile9
-rw-r--r--math/qtiplot/files/patch-qtiplot_qtiplotrc.py14
-rw-r--r--math/qtiplot/files/patch-qtiplot_src_table_Table.cpp18
-rw-r--r--math/qtiplot/files/patch-sip-4.19.631
4 files changed, 34 insertions, 38 deletions
diff --git a/math/qtiplot/Makefile b/math/qtiplot/Makefile
index 22e8ae96c502..41e70cbd6ff8 100644
--- a/math/qtiplot/Makefile
+++ b/math/qtiplot/Makefile
@@ -3,11 +3,11 @@
PORTNAME= qtiplot
DISTVERSION= 0.9.8.9
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= math science
MASTER_SITES= BERLIOS http://soft.proindependent.com/src/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= makc@FreeBSD.org
COMMENT= Data analysis and scientific plotting
LIB_DEPENDS= libgsl.so:math/gsl \
@@ -57,11 +57,6 @@ post-patch:
${REINPLACE_CMD} -e '/^system($$$$LUPDATE/d; /^system($$$$LRELEASE/d' \
${WRKSRC}/${PORTNAME}/qtiplot.pro
-post-patch-PYTHON-on:
- ${REINPLACE_CMD} -e \
- '/^sys.path.append/s|"\."|"${DATADIR}"|' \
- ${WRKSRC}/${PORTNAME}/qtiplotrc.py
-
post-patch-PYTHON-off:
${REINPLACE_CMD} -e \
"s/SCRIPTING_LANGS.*Python//" \
diff --git a/math/qtiplot/files/patch-qtiplot_qtiplotrc.py b/math/qtiplot/files/patch-qtiplot_qtiplotrc.py
new file mode 100644
index 000000000000..4caaedb8283e
--- /dev/null
+++ b/math/qtiplot/files/patch-qtiplot_qtiplotrc.py
@@ -0,0 +1,14 @@
+--- qtiplot/qtiplotrc.py.orig 2011-07-06 06:37:50 UTC
++++ qtiplot/qtiplotrc.py
+@@ -37,7 +37,10 @@ def import_to_global(modname, attrs=None
+ """
+ import sys
+ import os
+- sys.path.append(os.path.dirname(__file__))
++ try:
++ sys.path.append(os.path.dirname(__file__))
++ except:
++ pass
+ mod = __import__(modname)
+ for submod in modname.split(".")[1:]:
+ mod = getattr(mod, submod)
diff --git a/math/qtiplot/files/patch-qtiplot_src_table_Table.cpp b/math/qtiplot/files/patch-qtiplot_src_table_Table.cpp
new file mode 100644
index 000000000000..64e8352532e3
--- /dev/null
+++ b/math/qtiplot/files/patch-qtiplot_src_table_Table.cpp
@@ -0,0 +1,18 @@
+Description: if you don't initialize the "i" variable, or initialize it to 0.0
+ qtiplot won't let you set the column values using muparser.
+Author: Scott Howard <showard@debian.org>
+Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=707736
+
+Index: qtiplot/qtiplot/src/table/Table.cpp
+===================================================================
+--- qtiplot/src/table/Table.cpp.orig 2011-09-13 11:20:29 UTC
++++ qtiplot/src/table/Table.cpp
+@@ -564,7 +564,7 @@ bool Table::muParserCalculate(int col, i
+ QApplication::setOverrideCursor(QCursor(Qt::WaitCursor));
+
+ muParserScript *mup = new muParserScript(scriptEnv, cmd, this, QString("<%1>").arg(colName(col)));
+- double *r = mup->defineVariable("i");
++ double *r = mup->defineVariable("i",startRow + 1.0);
+ mup->defineVariable("j", (double)col);
+ mup->defineVariable("sr", startRow + 1.0);
+ mup->defineVariable("er", endRow + 1.0);
diff --git a/math/qtiplot/files/patch-sip-4.19.6 b/math/qtiplot/files/patch-sip-4.19.6
index 774fb89ced43..412cf9b76578 100644
--- a/math/qtiplot/files/patch-sip-4.19.6
+++ b/math/qtiplot/files/patch-sip-4.19.6
@@ -1,35 +1,4 @@
-The patch name is an approximation; something changed between SIP 4.19.2 and
-SIP 4.19.6 that causes the build to fail and sipAPI.qti.h is no longer
-generated.
-
-Obtained from: https://anonscm.debian.org/git/debian-science/packages/qtiplot.git/tree/debian/patches/20_fix_FTBFS_sip4.19.patch
Obtained from: https://bugs.gentoo.org/641514#c2
---- qtiplot/src/scripting/PythonScripting.cpp.orig 2018-01-02 11:37:07 UTC
-+++ qtiplot/src/scripting/PythonScripting.cpp
-@@ -58,7 +58,7 @@ typedef struct _traceback {
- #include <QMessageBox>
-
- // includes sip.h, which undefines Qt's "slots" macro since SIP 4.6
--#include "sipAPIqti.h"
-+#include "sip.h"
- extern "C" void initqti();
-
- const char* PythonScripting::langName = "Python";
-@@ -359,10 +359,11 @@ bool PythonScripting::setQObject(QObject *val, const c
- if(!val) return false;
- PyObject *pyobj=NULL;
-
-- PyGILState_STATE state = PyGILState_Ensure();
-+ sipAPIDef sip_API;
-
-- sipWrapperType * klass = sipFindClass(val->className());
-- if (klass) pyobj = sipConvertFromInstance(val, klass, NULL);
-+ PyGILState_STATE state = PyGILState_Ensure();
-+ const auto klass = sip_API.api_find_class(val->className());
-+ if (klass) pyobj = sip_API.api_convert_from_type(val, klass->wt_td, NULL);
-
- if (pyobj) {
- if (dict)
--- qtiplot/src/scripting/qti.sip.orig 2018-01-02 11:37:07 UTC
+++ qtiplot/src/scripting/qti.sip
@@ -3243,11 +3243,11 @@ class FFT : Filter (public)