aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2015-12-30 22:48:15 +0000
committerPawel Pekala <pawel@FreeBSD.org>2015-12-30 22:48:15 +0000
commitb1d1b3082420cef3b9da82a6de829e1062275043 (patch)
tree4d73473c5ac1e3c25fd12b5922323b19759fb1f2
parentbfde8c03da7abd46af65ba2196e890d075549277 (diff)
downloadports-b1d1b3082420cef3b9da82a6de829e1062275043.tar.gz
ports-b1d1b3082420cef3b9da82a6de829e1062275043.zip
Notes
-rw-r--r--net-mgmt/zabbix2-frontend/Makefile1
-rw-r--r--net-mgmt/zabbix2-server/Makefile7
-rw-r--r--net-mgmt/zabbix22-frontend/Makefile1
-rw-r--r--net-mgmt/zabbix22-server/Makefile7
-rw-r--r--net-mgmt/zabbix24-frontend/Makefile1
-rw-r--r--net-mgmt/zabbix24-server/Makefile7
6 files changed, 18 insertions, 6 deletions
diff --git a/net-mgmt/zabbix2-frontend/Makefile b/net-mgmt/zabbix2-frontend/Makefile
index 0796a67114a2..abe5f3cfe5b2 100644
--- a/net-mgmt/zabbix2-frontend/Makefile
+++ b/net-mgmt/zabbix2-frontend/Makefile
@@ -8,6 +8,7 @@ CATEGORIES= net-mgmt
MASTERDIR= ${.CURDIR}/../zabbix2-server
NO_BUILD= yes
+NO_ARCH= yes
PATCHDIR=
PLIST= ${PKGDIR}/pkg-plist.frontend
diff --git a/net-mgmt/zabbix2-server/Makefile b/net-mgmt/zabbix2-server/Makefile
index 1711911a331f..9dd39bd62b19 100644
--- a/net-mgmt/zabbix2-server/Makefile
+++ b/net-mgmt/zabbix2-server/Makefile
@@ -58,8 +58,11 @@ CONFIGURE_ARGS+= --enable-${ZABBIX_BUILD} \
--datadir=${ETCDIR}
.if ${ZABBIX_BUILD} != "agent"
-LIB_DEPENDS= libnetsnmp.so:${PORTSDIR}/net-mgmt/net-snmp \
- libexecinfo.so:${PORTSDIR}/devel/libexecinfo
+LIB_DEPENDS= libnetsnmp.so:${PORTSDIR}/net-mgmt/net-snmp
+USES+= execinfo
+
+CPPFLAGS+= ${EXECINFO_CPPFLAGS}
+LDFLAGS+= ${EXECINFO_LDFLAGS}
SUB_FILES= pkg-message
diff --git a/net-mgmt/zabbix22-frontend/Makefile b/net-mgmt/zabbix22-frontend/Makefile
index 694d61c28580..0e3e21ca6e3f 100644
--- a/net-mgmt/zabbix22-frontend/Makefile
+++ b/net-mgmt/zabbix22-frontend/Makefile
@@ -8,6 +8,7 @@ PKGNAMESUFFIX= -frontend
MASTERDIR= ${.CURDIR}/../zabbix22-server
NO_BUILD= yes
+NO_ARCH= yes
PATCHDIR=
PLIST= ${PKGDIR}/pkg-plist.frontend
diff --git a/net-mgmt/zabbix22-server/Makefile b/net-mgmt/zabbix22-server/Makefile
index 166739c6846d..04e603d1df09 100644
--- a/net-mgmt/zabbix22-server/Makefile
+++ b/net-mgmt/zabbix22-server/Makefile
@@ -59,8 +59,11 @@ CONFIGURE_ARGS+= --enable-${ZABBIX_BUILD} \
--with-iconv=${ICONV_PREFIX}
.if ${ZABBIX_BUILD} != "agent"
-LIB_DEPENDS= libnetsnmp.so:${PORTSDIR}/net-mgmt/net-snmp \
- libexecinfo.so:${PORTSDIR}/devel/libexecinfo
+LIB_DEPENDS= libnetsnmp.so:${PORTSDIR}/net-mgmt/net-snmp
+USES+= execinfo
+
+CPPFLAGS+= ${EXECINFO_CPPFLAGS}
+LDFLAGS+= ${EXECINFO_LDFLAGS}
SUB_FILES= pkg-message
diff --git a/net-mgmt/zabbix24-frontend/Makefile b/net-mgmt/zabbix24-frontend/Makefile
index 094bffbbdedc..58e0ac40f423 100644
--- a/net-mgmt/zabbix24-frontend/Makefile
+++ b/net-mgmt/zabbix24-frontend/Makefile
@@ -8,6 +8,7 @@ PKGNAMESUFFIX= -frontend
MASTERDIR= ${.CURDIR}/../zabbix24-server
NO_BUILD= yes
+NO_ARCH= yes
PATCHDIR=
PLIST= ${PKGDIR}/pkg-plist.frontend
diff --git a/net-mgmt/zabbix24-server/Makefile b/net-mgmt/zabbix24-server/Makefile
index ac6b94b541b6..76299f3891d0 100644
--- a/net-mgmt/zabbix24-server/Makefile
+++ b/net-mgmt/zabbix24-server/Makefile
@@ -60,8 +60,11 @@ CONFIGURE_ARGS+= --enable-${ZABBIX_BUILD} \
--with-iconv=${ICONV_PREFIX}
.if ${ZABBIX_BUILD} != "agent"
-LIB_DEPENDS= libnetsnmp.so:${PORTSDIR}/net-mgmt/net-snmp \
- libexecinfo.so:${PORTSDIR}/devel/libexecinfo
+LIB_DEPENDS= libnetsnmp.so:${PORTSDIR}/net-mgmt/net-snmp
+USES+= execinfo
+
+CPPFLAGS+= ${EXECINFO_CPPFLAGS}
+LDFLAGS+= ${EXECINFO_LDFLAGS}
SUB_FILES= pkg-message