aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2020-04-25 20:25:27 +0000
committerThierry Thomas <thierry@FreeBSD.org>2020-04-25 20:25:27 +0000
commitb1ee5addc7468071f37e8baaeaef4b7e85659b66 (patch)
tree02e0803cefb265f26d05fcf3e2f0da6f26c51333
parentd81d4c8fa7abb0e758f98f45d1889a382c033f7d (diff)
downloadports-b1ee5addc7468071f37e8baaeaef4b7e85659b66.tar.gz
ports-b1ee5addc7468071f37e8baaeaef4b7e85659b66.zip
Notes
-rw-r--r--cad/opencascade/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/cad/opencascade/Makefile b/cad/opencascade/Makefile
index a430d05ad9ab..eb80178b468b 100644
--- a/cad/opencascade/Makefile
+++ b/cad/opencascade/Makefile
@@ -3,7 +3,7 @@
PORTNAME= opencascade
PORTVERSION= 7.4.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= cad science
MASTER_SITES= LOCAL/thierry
@@ -15,8 +15,10 @@ LICENSE_NAME= LGPL21 with exception
LICENSE_FILE= ${WRKSRC}/OCCT_LGPL_EXCEPTION.txt
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+BUILD_DEPENDS= ${LOCALBASE}/lib/qt5/bin/qmake:devel/qt5-qmake \
+ ${LOCALBASE}/lib/qt5/bin/moc:devel/qt5-buildtools
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
- libvtksys-${VTKVER}.so:math/vtk6 \
+ libvtksys-${VTKVER}.so:math/vtk8 \
libfreetype.so:print/freetype2 \
libtbb.so:devel/tbb
RUN_DEPENDS= bash:shells/bash
@@ -24,7 +26,7 @@ RUN_DEPENDS= bash:shells/bash
# Check ${WRKSRC}/dox/overview/overview.md
# and ${WRKSRC}/dox/dev_guides/building
USES= alias:10 cmake compiler:c++14-lang dos2unix \
- gl python shebangfix tk tar:tgz xorg
+ gl python qt:5 shebangfix tk tar:tgz xorg
USE_XORG= ice sm x11 xext xi xmu xt
USE_GL= gl glu
@@ -37,7 +39,7 @@ SHEBANG_FILES= adm/templates/*.sh \
gendoc
ENVSH= adm/templates/env.sh
-VTKVER= 6.2
+VTKVER= 8.1
OPTIONS_DEFINE= DOCS DOXYGEN FFMPEG VIS
VIS_DESC= Build Visualizazion module (requires OpenGL, freetype, ftgl and gl2ps)