aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2004-05-24 13:37:35 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2004-05-24 13:37:35 +0000
commitb215e60f8b1ad0d15547bad7b2b666aacfc64989 (patch)
tree1abd4e7d8ecc9732cc78c838ab9ce3cde1ea0976
parent12f4ceb5a0b914c78bdf6694b6fa1313b5d252dd (diff)
downloadports-b215e60f8b1ad0d15547bad7b2b666aacfc64989.tar.gz
ports-b215e60f8b1ad0d15547bad7b2b666aacfc64989.zip
Notes
-rw-r--r--Mk/bsd.sites.mk16
-rw-r--r--lang/php4/Makefile10
-rw-r--r--lang/php5/Makefile10
-rw-r--r--lang/php53/Makefile10
-rw-r--r--www/mod_php3/Makefile13
5 files changed, 26 insertions, 33 deletions
diff --git a/Mk/bsd.sites.mk b/Mk/bsd.sites.mk
index 2677d16a4b9c..7f49ce2d4e8a 100644
--- a/Mk/bsd.sites.mk
+++ b/Mk/bsd.sites.mk
@@ -635,6 +635,22 @@ MASTER_SITE_PGSQL+= \
ftp://ftp.tr.postgresql.org/pub/SQL/postgresql/%SUBDIR%/ \
ftp://ftp.postgresql.org/pub/%SUBDIR%/
+MASTER_SITE_PHP+= \
+ http://www.php.net/%SUBDIR%/ \
+ http://at.php.net/%SUBDIR%/ \
+ http://au.php.net/%SUBDIR%/ \
+ http://br.php.net/%SUBDIR%/ \
+ http://de.php.net/%SUBDIR%/ \
+ http://es.php.net/%SUBDIR%/ \
+ http://fi.php.net/%SUBDIR%/ \
+ http://fr.php.net/%SUBDIR%/ \
+ http://gr.php.net/%SUBDIR%/ \
+ http://it.php.net/%SUBDIR%/ \
+ http://jp.php.net/%SUBDIR%/ \
+ http://se.php.net/%SUBDIR%/ \
+ http://uk.php.net/%SUBDIR%/ \
+ ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,net/www/php/&,}
+
MASTER_SITE_PYTHON+= \
http://www.python.org/%SUBDIR%/ \
http://python.planetmirror.com/%SUBDIR%/ \
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index 42990cf8458e..08d8a3027bc1 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -23,16 +23,10 @@ PORTNAME= php4
PORTVERSION= 4.3.6
PORTREVISION= 1
CATEGORIES?= lang devel www
-MASTER_SITES= http://www.php.net/distributions/:release \
- http://it.php.net/distributions/:release \
- http://fi.php.net/distributions/:release \
- http://de.php.net/distributions/:release \
- http://gr.php.net/distributions/:release \
- http://fr.php.net/distributions/:release \
- http://es.php.net/distributions/:release \
- http://se.php.net/distributions/:release \
+MASTER_SITES= ${MASTER_SITE_PHP:S,$,:release,} \
http://downloads.php.net/ilia/:rc \
http://downloads.php.net/jani/:rc
+MASTER_SITE_SUBDIR= distributions/:release
.if defined(WITHOUT_CLI) && !defined(WITHOUT_APACHE)
PKGNAMEPREFIX= mod_
.else
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index 141b51f0f23f..481ac05a0eca 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -24,14 +24,8 @@ PORTNAME= php5
PORTVERSION= 5.0.0.r2
PORTREVISION= 1
CATEGORIES?= lang devel www
-MASTER_SITES= http://www.php.net/distributions/:release \
- http://it.php.net/distributions/:release \
- http://fi.php.net/distributions/:release \
- http://de.php.net/distributions/:release \
- http://gr.php.net/distributions/:release \
- http://fr.php.net/distributions/:release \
- http://es.php.net/distributions/:release \
- http://se.php.net/distributions/:release
+MASTER_SITES= ${MASTER_SITE_PHP:S,$,:release,}
+MASTER_SITE_SUBDIR= distributions/:release
.if defined(WITHOUT_CLI) && !defined(WITHOUT_APACHE)
PKGNAMEPREFIX= mod_
.else
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index 141b51f0f23f..481ac05a0eca 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -24,14 +24,8 @@ PORTNAME= php5
PORTVERSION= 5.0.0.r2
PORTREVISION= 1
CATEGORIES?= lang devel www
-MASTER_SITES= http://www.php.net/distributions/:release \
- http://it.php.net/distributions/:release \
- http://fi.php.net/distributions/:release \
- http://de.php.net/distributions/:release \
- http://gr.php.net/distributions/:release \
- http://fr.php.net/distributions/:release \
- http://es.php.net/distributions/:release \
- http://se.php.net/distributions/:release
+MASTER_SITES= ${MASTER_SITE_PHP:S,$,:release,}
+MASTER_SITE_SUBDIR= distributions/:release
.if defined(WITHOUT_CLI) && !defined(WITHOUT_APACHE)
PKGNAMEPREFIX= mod_
.else
diff --git a/www/mod_php3/Makefile b/www/mod_php3/Makefile
index f95c58a737d5..9a12ba4a4369 100644
--- a/www/mod_php3/Makefile
+++ b/www/mod_php3/Makefile
@@ -9,15 +9,12 @@ PORTNAME?= mod_php3
PORTVERSION= 3.0.18
PORTREVISION?= 3
CATEGORIES?= www
-MASTER_SITES= http://php.he.net/${PHP_DISTDIR}/ \
- http://www.php3.de/${PHP_DISTDIR}/ \
- http://au.php.net/${PHP_DISTDIR}/ \
- http://at.php.net/${PHP_DISTDIR}/ \
- http://br.php.net/${PHP_DISTDIR}/ \
- http://php3.globe.de/${PHP_DISTDIR}/
+MASTER_SITES= ${MASTER_SITE_PHP}
+MASTER_SITE_SUBDIR= distributions
DISTNAME= php-${PORTVERSION}
-PATCH_SITES= http://www.php.net/distributions/
+PATCH_SITES= ${MASTER_SITE_PHP}
+PATCH_SITE_SUBDIR= distributions
PATCHFILES= mime.c.diff-3.0.gz
MAINTAINER= ports@FreeBSD.org
@@ -29,8 +26,6 @@ USE_APACHE= yes
PATCH_DIST_ARGS= -d ${WRKSRC}/functions
-PHP_DISTDIR= distributions
-
SLAVEDIRS= lang/php3
USE_SUBMAKE= yes